Highlighted

Fully embed Base 14 fonts in PDF from InDesign

New Here ,
Sep 08, 2020

Copy link to clipboard

Copied

Hi,
There were a couple similar threads, but no working solution.
I need to output a PDF from InDesign with all fonts fully embedded. This seems unattainable given the functionality of Base 14 fonts. They do not fully embed. Setting "Subset Fonts When Percent of Characters Used Is Less Than" to 0% will fix most issues.

Times New Roman (Times) can be used as an example.

 

Why I need a full character set available in the PDF:
A secondary program identifies << and >> as field markers for populating variable data. As a result, I need my InDesign PDF to contain the full character set and not a font subset, to cater for any character that may appear in my data...
It reads the position of <<
Then reads the field name within << >>, e.g. <<address>>
Then reads the font of the whole <<field>>
It then replaces <<address>> with "1 Sample Street" in the position of <<, with the same font as <<field>>. The original PDF is unchanged.

I do have the program Fontographer, which allows me to edit fonts along with metadata and licensing restrictions. Though everything I have done in Fontographer & FontForge still are not allowing me to fully embed Times.

 

Help! Thanks

TOPICS
How to, Import and export, Type

Views

43

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Fully embed Base 14 fonts in PDF from InDesign

New Here ,
Sep 08, 2020

Copy link to clipboard

Copied

Hi,
There were a couple similar threads, but no working solution.
I need to output a PDF from InDesign with all fonts fully embedded. This seems unattainable given the functionality of Base 14 fonts. They do not fully embed. Setting "Subset Fonts When Percent of Characters Used Is Less Than" to 0% will fix most issues.

Times New Roman (Times) can be used as an example.

 

Why I need a full character set available in the PDF:
A secondary program identifies << and >> as field markers for populating variable data. As a result, I need my InDesign PDF to contain the full character set and not a font subset, to cater for any character that may appear in my data...
It reads the position of <<
Then reads the field name within << >>, e.g. <<address>>
Then reads the font of the whole <<field>>
It then replaces <<address>> with "1 Sample Street" in the position of <<, with the same font as <<field>>. The original PDF is unchanged.

I do have the program Fontographer, which allows me to edit fonts along with metadata and licensing restrictions. Though everything I have done in Fontographer & FontForge still are not allowing me to fully embed Times.

 

Help! Thanks

TOPICS
How to, Import and export, Type

Views

44

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 08, 2020 0
Doc_Maik LATEST
Advisor ,
Sep 22, 2020

Copy link to clipboard

Copied

I'd say this isn't the job of Indesign, but of Acrobat. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 22, 2020 0