Greek Fonts in InDesign

New Here ,
Jul 10, 2009 Jul 10, 2009

Copy link to clipboard

Copied

I use an Apple iMac with OS 10.5 Leopard.  I do have Greek fonts available and they work well with MS WORD and other software.  BUT .... they will NOT work with InDesign CS3.  I can't type Greek letters directly on an InDesign page.  Also, I can't successfully Copy/Paste from a WORD document containing Greek letters.  This is a very serious handicap for writing anything related to math or science since Greek letters are so widely used as math and science symbols.  Does anyone know of a way to get around this problem?  Thanks in advance for help.  Carl Thomas

Views

23.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jul 10, 2009 Jul 10, 2009

Copy link to clipboard

Copied

I do have Greek fonts available and they work well with MS WORD and other software.  BUT .... they will NOT work with InDesign CS3.  I can't type Greek letters directly on an InDesign page.  Also, I can't successfully Copy/Paste from a WORD document containing Greek letters.

In what way do they not work? What happens when you input or paste Greek? Are you getting missing font messages? What Greek fonts are you using?

Ken

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

I do have Greek fonts available and they work well with MS WORD and

>other software. BUT .... they will NOT work with InDesign CS3. I

>can't type Greek letters directly on an InDesign page. Also, I

>can't successfully Copy/Paste from a WORD document containing Greek

>letters.

>In what way do they not work? What happens when you input or paste Greek?

See the illustrated materials that follow below.

Are you getting missing font messages? What Greek fonts are you using?

No error messages of any kind. Just the "little squares" that you

will see in the third of the illustrations below. ........... I'm not

adequately knowledgeable about the font business to know "what kind"

of fonts these are. My only knowledge is as illustrated below.

This works well with MS WORD also. To get this Greek font, I used

the following. All these fonts ... plus lots more ... are available

originally with my iMac.

When I Copy/Paste that short material from Text Edit over into

InDesign CS3, I get the following. Lots of little squares where the

Greek letters should be. I get the same results if I try to type

directly into InDesign. ....... Incidentally, I have no problems

with typing the other languages and special fonts into InDesign.

INCIDENTALLY ........ I am able to "get around" this problem in a

slow and ponderous manner. .... select Special Characters

below...... it would be much more convenient to use a keyboard typed

input as with the other languages.

and then select from various displays as below. Example: the lower

right corner offers the equivalent of the Greek letter phi .... but

as an object that can be copied and inserted, rather than as a letter

that can be typed.

Thanks for your initial response. I hope you can suggest some way

to handle the Greek letter typing in InDesign in the same way that I

can do the Greek letter typing in Text Edit and in Word.

Have a very good week end.

Carl {Knoxville, Tennessee}

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

Carl,

I don't know if you tried to attach some sort of illustrations, but there is nothing there. Please visit the website if you are posting via email, and use either the camera icon at the top of the editing screen to insert an image, or the attach file field below (which is less reilable). In spite of what it says, you cannot attach a .indd file to the forum, but you can host it somewhere else and post a link, or zip the file and attach that.

Can you at least tell us the name of the font in question? Also, Word has a habit of substituting the symbol font for many of these characters, without bothering to tell you, and that may also be what is happening.

Peter

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

>Carl,

>

>I don't know if you tried to attach some sort of illustrations, but

>there is nothing there.

Yes ..... there were five .png images - - - embedded along with

the text of the email. I have been using this method for a long time

{with Eudora for my emai}, and this is the first time I know of that

the embedded images did not arrive OK.

I will try again later in the day ... using some of your suggestions.

Incidentally .... all these hi-technology problems are generally far

beyond the talents of the typical home user, and interfere with one's

ability to "do things."

I'm a retired engineering professor at the University of Tennessee,

and taught the college wide freshman level computer programming

course - - in Basic and then in Fortran - for several years.

Even so, the current level of computer software and hardware

technology is far beyond me.

In any case, I will try again to get the illustrations to you over

the week end.

Carl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

> I do have Greek fonts available and they work well with MS WORD and other software.  BUT .... they will NOT work with InDesign CS3.  I can't type Greek letters directly on an InDesign page.  Also, I can't successfully Copy/Paste from a WORD document containing Greek letters.

In what way do they not work? What happens when you input or paste Greek?

See the illustrated materials that follow below. 

NOTE .... these illustrations were missing from my initial query.  All of these included images were originally  .png  format - - "clipped" from my computer screen.  The text, however, is the same as initially.

InDesign-1.png

Are you getting missing font messages? What Greek fonts are you using?

No error messages of any kind.  Just the "little squares" that you will see in the third illustration below. ........... I'm not adequately knowledgeable about the font business to know "what kind" of fonts these are.  My only knowledge is as illustrated below.

This works well with MS WORD also.  To get this Greek font, I used the following.  All these fonts ... plus lots more ... are available originally with my iMac.

InDesign-2.png

When I Copy/Paste that short material from Text Edit over into InDesign CS3, I get the following.  Lots of little squares where the Greek letters should be.  I get the same results if I try to type directly into InDesign.  ....... Incidentally, I have no problems with typing the other languages and special fonts into InDesign.

InDesign-3.png

INCIDENTALLY ........ I am able to "get around" this problem in a slow and ponderous manner.  .... select Special Characters below......  it would be much more convenient to use a keyboard typed input as with the other languages.

InDesign-4.png

and then select from various displays as below.  Example:  the lower right corner offers the equivalent of the Greek letter phi .... but as an object that can be copied and inserted, rather than as a letter that can be typed.

InDesign-5.png

Thanks for your initial responses.   I hope someone can suggest some way to  handle the Greek letter typing inyo InDesign in the same way that I can do the Greek letter typing into Text Edit and into Word.

Have a very good week end.

Carl  {Knoxville, Tennessee}

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

Your problem here seems to be that the fonts you are using in InDesign do not match those used in other applications, and thus support a different variety of characters to each other.

I did a quick experiment of my own, by setting my input language to Greek and typing the greek alphabet into TextEdit, and then copying the resulting text into InDesign. What I noticed was that the default InDesign paragraph font (in a new document) of Times displayed the characters correctly, as did Helvetica and Myriad Pro, which is supplied with InDesign. If, however, I changed the font to Century Gothic (which appears to be what you are using in your example) then I get the pink 'missing characters' boxes.

This, I suspect happens because an application like Word will automatically substitue glyphs from another font if they are missing, whilst InDesign (quite rightly) does not.

All this means that, unfortunately, you will have to switch your document's main font to another, which contains support for the Greek script.

Another possibility is that MS Office installs versions of Microsoft fonts, (such as Times New Roman, Georgia, etc.) which are already installed by Leopard, and consequesntly creating duplicates. This is an issue because the Microsoft-supplied fonts have a much smaller symbol coverage that the Apple-supplied ones, as can be seen from the number of characters included in each of the fonts: with Arial as an example, there are 3273 characters in the Apple version, but just 1361 in the Microsoft version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

I changed the font to Century Gothic (which appears to be what you

>are using in your example) then I get the pink 'missing characters'

>boxes.

I use Century Gothic interchangeably between Word, Text Edit and

InDesign CS3. Actually it's the font I use most frequently with

InDesign..

Of the many font types available on my Apple iMac {OS 10.5.7} I have

not run into any problems using any of the "American English" fonts

interchangeably between Word, Excel, Text Edit, and InDesign.

Also I have not had any problems with the fonts of other European,

Russian, etc. languages.

It's ONLY the Greek fonts that I'm unable to type directly into

InDesign, although they also will work well with the MS OFFICE items

mentioned above.

Carl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

>All this means that, unfortunately, you will have to switch your

>document's main font to another, which contains support for the

>Greek script.

Any suggestions about how to do this ? I don't know how to do it.

For the current project that has been underway for six months or

more, I'm using Century Gothic 11 point, and Cambria Italic 12 point

........ occasionally some other sizes.

No problems at all with these fonts.

Carl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

Thanks  jbuk2k7 for your suggestion.  It seems to work, now that I have figured out how to do it.  See the following....

Picture 7.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

Something else I have just noticed: the version of Century Gothic which ships with Office:mac 2008 does not contain any greek characters. However, the version supplied by Office 2007 for windows (and presumably earlier versions) contains Greek and Cyrillic characters. Those fonts can be found as GOTHIC.TTF, GOTHICI.TTF, GOTHICB.TTF and GOTHICBI.TTF on a Windows machine, so if you have access to a PC with Office installed, then you could use that version of Century Gothic. The advantage of doing this would be that the Greek characters in your publication would typographically match the Latin ones.

However, I am not sure of the complete legality of transferring the fonts, although in my eyes as long as you have legitamately obtained copies of both, then it should not be a problem transferring them. if anyone wants to correct me on this, though, feel free.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2009 Jul 11, 2009

Copy link to clipboard

Copied

A lot of the technical insights about fonts are beyond my skills - although I greatly appreciate getting pointed in the right direction to deal with this problem.

Not sure I mentioned it earlier, but it turns out to be possible to "outsmart" the InDesign setup as follows.

1.  Set all of the "American English" text initially in Helvetica

2.  The select Greek or Greek Polytonic from the menu below.  That allows the Greek letters to be typed directly into InDesign.

Picture 2.png

3.  Then, after entering all the required Greek letters/fonts ..... go back and change the Helvetica to Century Gothic.  When I do it this way, I don't lose the Greek letters/fonts that have been typed directly into InDesign CS3.

Thanks again for help from everyone ... and best wishes for a nice week end to everyone.

Carl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jul 12, 2009 Jul 12, 2009

Copy link to clipboard

Copied

This thread is getting pretty long, but I don't think anyone mentioned using File > Place instead of copy/paste. Depending on your preferences settings, copy/paste does/does not include all the Word formatting. I think when you paste you're getting the copied characters, but not the font changes. And if you're pasting greek characters into Helvetica, Helvetica (at least the Helvetica fonts I know) has no greek characters.

So you need to either use File > Place, and Place your Word files, or you should copy/paste and then choose a font that has Greek in it. Minion Pro and Myriad Pro (which both come with Indesign) have a good collection of modern greek characters in them. Should be suitable for scientific work.

Ken

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 12, 2009 Jul 12, 2009

Copy link to clipboard

Copied

>This thread is getting pretty long,

Yes. But it has helped me solve my own problem, and I appreciate

that. Maybe it also will be helpful to others. Thanks for all the

help from everyone.

Carl

>but I don't think anyone mentioned using File > Place instead of

>copy/paste. Depending on your preferences settings, copy/paste

>does/does not include all the Word formatting. I think when you

>paste you're getting the copied characters, but not the font

>changes. And if you're pasting greek characters into Helvetica,

>Helvetica (at least the Helvetica fonts I know) has no greek

>characters.

>

>So you need to either use File > Place, and Place your Word files,

>or you should copy/paste and then choose a font that has Greek in

>it. Minion Pro and Myriad Pro (which both come with Indesign) have a

>good collection of modern greek characters in them. Should be

>suitable for scientific work.

>

>Ken

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 12, 2009 Jul 12, 2009

Copy link to clipboard

Copied

The version of Helvetica which ships with OS X Leopard seems to include Green Greek characters (screencap from FontExplorer X Pro):

Picture 53.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2009 Jul 14, 2009

Copy link to clipboard

Copied

Hello. My issue is Greek Fonts in InDesign but I think it is a little different from what I have been reading on this thread. I have various polytonic Greek fonts: Graecall, Hellinica, Odyssea, Payne, etc. (After a break for many years, I have now gotten back into typing Ecclesiastical Liturgical texts.) Additionally, I have now gotten around to finally upgrading from Adobe PageMaker to Adobe InDesign. I am having a problem that was a fixable problem in PageMaker (I just can't remember what I did to get around it. Additionally, I can not remember who told me how to fix it: was it Adobe or the font designer.) My specific problem: when I hit the φ key (the letter "f") and I hit the ι (the letter i) or the letter λ (the letter l) the φ changes to something totally different. In the first case it changes to a letter I have never seen. In the second case it changes to the superscript number 2. Like I said, I remember I had this problem with PageMaker, I just can't remember how to fix it. Any help would be so appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2009 Jul 14, 2009

Copy link to clipboard

Copied

>My specific problem: when I hit the É" key (the

>letter "f") and I hit the É« (the letter i) or

>the letter ÉŠ (the letter l) the É" changes to

>something totally different. In the first case

>it changes to a letter I have never seen. In the

>second case it changes to the superscript number

>2.

I'm sorry that I can't help on this one. Perhaps

some of the other more experienced people who

have contributed to this thread will be able to

assist you.

Carl Thomas

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 14, 2009 Jul 14, 2009

Copy link to clipboard

Copied

The bad news is, your fonts are not correctly set up. (But do read on,as  the good news is about to follow.)

InDesign assumes that the font designer assigned the correct Unicode character definitions (= a unique identifier per possible character -- worldwide) to the correct 'font glyphs' (= image per character). Thus, it can make a difference between an alpha 'α' and a lowercase 'a', and -- by extension -- between an uppercase alpha 'Α' and an uppercase 'A'. Although they look the same (in this font), they are not the same. One is a Greek character, the other is a Latin one.

It's comparable to old fashioned typewriters that had no digits '0' and '1' -- you were supposed to use the capital 'O' and the lowercase 'l' for these. Nowadays, most people know that you cannot just enter an 'O' into a computer and expect it to 'see' it as a digit zero.

So, your font displays Greek characters but InDesign thinks it's displaying Latin ones. Why does it cause a problem? Since InDesign thinks it now should display a small letter 'f', followed by a small letter 'i', some internal mechanism goes to work. It checks the active font if it has a ligature character for the 'f-'i' combination. Usually -- and I think you see that coming -- the character encoded on the position for a 'fi' ligature looks like an 'fi' ligature -- that's the entire purpose of it. But because your font is encoded badly, there is a totally different character on that position.

InDesign just checks if there is a character on that position, and it displays that.


Almost forgot the good news.

The good news is, this ligature replacement is a text preference, which you can switch off in your paragraph or character styles, or just by selecting all of your text. It's the option called "Ligatures" in the Character panel dropdown menu, and the checkbox under "Basic Character Formats" in Character and Paragraph Style Options.

For InDesign, it's on by default, but you can switch it to off-by-default if you close all your documents, then go to the Character Panel drop down menu (you'll see "Ligatures" is checked) and uncheck it there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2009 Jul 15, 2009

Copy link to clipboard

Copied

Thank you so very much. You have been very helpful. I (and all how will benefit from my writing out in Greek are indebted to you.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 30, 2017 May 30, 2017

Copy link to clipboard

Copied

Hello. I know that this post is seven years old but I will post anyway just in case someone is having this problem and is searching for the answer. I was having the same problem pasting Greek words into InDesign, getting the pink boxes, etc. I won't go into all the details but just skimming over the previous posts I decided to merely change my font for that text to Times and voila; my Greek was back; tried Times Roman, same result.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

LATEST

παντελακος

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines