Highlighted

GREP style not working on imported text

Explorer ,
May 06, 2020

Copy link to clipboard

Copied

Hi, I have a document with two GREP styles applied. They both work on new typed text, but when I copy & paste text, only Style #1 applies. The original text is in a Word document. I have also tried copying to Notes (Mac)  and recopying into InDesign. When I did this, the GREP Style #2 did apply, confusingly, in exactly one (1) case -- but disappeared when I inserted a tab at the beginning of the line (indents had not copied over). I don't know if that's a clue or if it makes things even murkier. 

 

Paragraph style is Basic Paragraph throughout the document, and there are no + signs anywhere, which I understand indicate local overrides. Please let me know if you can help!

 

UPDATE: GREP Style #2 works on new typing only in some places and not in others. Again, no changing in paragraph style or any apparent overrides. GREP Style #1 seems to be working correctly throughout the document.

 

Adobe Community Professional
Correct answer by David_Popham | Adobe Community Professional

Hi Anthony,

 

For the Tech Terms GREP style, try changing to the following:

Period|Sentences?|Underlined Portion|Semi-Colons?|Dash(es)?|Punctuation Marks That Aren't Commas|Punctuation Mark That Isn't A Comma|(?<!Differences Between The )(Answer Choices?)|No-Question|Underlined Portion|No Change|\(A\)|\(B\)|\(C\)|\(D\)|\(E\)|\(F\)|\(G\)|\(H\)|\(I\)|\(J\)|\(K\)

 

The Clear Overrides button is grayed out because there are no overrides in text frame with your main flow of text. There are local overrides in the three other text frames with questions/answer choices that have the [Basic Paragraph] style applied.

 

I would suggest a couple of things:

1) Create custom paragraph styles, as suggested previously, for the questions/answer choices content rather than using [Basic Paragraph].

2) Rather than putting that content in separate text frames, make them part of the main text flow. That way you don't have to move them if the text reflows. If you need two columns, use the Split Column feature. A couple of resources on how to use the feature are below.

 

Span/Split Column references

https://creativepro.com/indesigns-span-and-split-columns/

https://indesignsecrets.com/timesaver-span-and-split-columns-in-cs5.php

TOPICS
Bug, Import and export

Views

674

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

GREP style not working on imported text

Explorer ,
May 06, 2020

Copy link to clipboard

Copied

Hi, I have a document with two GREP styles applied. They both work on new typed text, but when I copy & paste text, only Style #1 applies. The original text is in a Word document. I have also tried copying to Notes (Mac)  and recopying into InDesign. When I did this, the GREP Style #2 did apply, confusingly, in exactly one (1) case -- but disappeared when I inserted a tab at the beginning of the line (indents had not copied over). I don't know if that's a clue or if it makes things even murkier. 

 

Paragraph style is Basic Paragraph throughout the document, and there are no + signs anywhere, which I understand indicate local overrides. Please let me know if you can help!

 

UPDATE: GREP Style #2 works on new typing only in some places and not in others. Again, no changing in paragraph style or any apparent overrides. GREP Style #1 seems to be working correctly throughout the document.

 

Adobe Community Professional
Correct answer by David_Popham | Adobe Community Professional

Hi Anthony,

 

For the Tech Terms GREP style, try changing to the following:

Period|Sentences?|Underlined Portion|Semi-Colons?|Dash(es)?|Punctuation Marks That Aren't Commas|Punctuation Mark That Isn't A Comma|(?<!Differences Between The )(Answer Choices?)|No-Question|Underlined Portion|No Change|\(A\)|\(B\)|\(C\)|\(D\)|\(E\)|\(F\)|\(G\)|\(H\)|\(I\)|\(J\)|\(K\)

 

The Clear Overrides button is grayed out because there are no overrides in text frame with your main flow of text. There are local overrides in the three other text frames with questions/answer choices that have the [Basic Paragraph] style applied.

 

I would suggest a couple of things:

1) Create custom paragraph styles, as suggested previously, for the questions/answer choices content rather than using [Basic Paragraph].

2) Rather than putting that content in separate text frames, make them part of the main text flow. That way you don't have to move them if the text reflows. If you need two columns, use the Split Column feature. A couple of resources on how to use the feature are below.

 

Span/Split Column references

https://creativepro.com/indesigns-span-and-split-columns/

https://indesignsecrets.com/timesaver-span-and-split-columns-in-cs5.php

TOPICS
Bug, Import and export

Views

675

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 06, 2020 0
Adobe Community Professional ,
May 06, 2020

Copy link to clipboard

Copied

Hi Anthony,

I would handle this problem by using custom made paragraph styles.

And never, I repeat never, use the [Basic Paragraph Style].

 

If you want to see overrides you can try to use the [+] symbol in your paragraph styles panel or the character styles panel. That would enable the function Style Override Highlighter. For character property overrides you'll get a blue bar stacked below the characters of a text when in Normal view mode, for paragraph property overrides you'll get a blue bar at the edge of a text frame.

 

See e.g. into this article by Barb Binder:

https://www.rockymountaintraining.com/adobe-indesign-quickly-recognizing-and-removing-overrides/

 

For analyzing GREP patterns see into the What The GREP?!-script by Jongware:

http://www.jongware.com/idgrephelp.html

 

For highlighting the results of GREP patterns see into the GREP Editor-script by Peter Kahrel:

https://creativepro.com/files/kahrel/indesign/grep_editor.html

 

IMPORTANT NOTE: A GREP Style is always limited. It's scope is the single paragraph.

GREP Find/Replace can break this scope up to the whole story of a text.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2020 2
Explorer ,
May 06, 2020

Copy link to clipboard

Copied

Hi again, Uwe. Thanks for all the great info!! The scripts in the last two links look very helpful, expecially the text editor. I've been "storing" my GREP strings in Notes, which is less than ideal. Per your advice, I also created a new Paragraph Style to replace [Basic Paragraph] and applied it to the whole doc.

 

The 1st link seems to be addressing my current formatting issue directly... and I think I almost have it. I've enabled Style Override Highlighter and can see the teal paragraph overrides at the top of every page. However, when I select all the text, the "clear override" button is still greyed out.....

 

So close... any thoughts on what I could be doing wrong?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2020 0
Adobe Community Professional ,
May 07, 2020

Copy link to clipboard

Copied

Hi Anthony,

to get an answer, I think you have to make a sample document available for further inspection.

Put it on Dropbox or a similar service and share the download link.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 07, 2020 1
Explorer ,
May 08, 2020

Copy link to clipboard

Copied

Hi Uwe, below is a link to a test document. It should demonstrate some of the formatting issues that I’m having.

 

Something strange happened overnight, though. Some of the problems from yesterday have “fixed” themselves. I realize I must have done something to make the change, but I have no idea what.

 

Anyway, the main issue is still there. I can see the Override Highlighting, but when I select all, the Delete Overrides button is still grayed out.

 

Another issue from yesterday was that “Tech Terms” would stop working in several cases. 

 

1. At the top of Page 2

2. Whenever a tab is inserted

3.When I make certain changes to the Applied To box. 

 

Strangely, 1 & 2 appear to have been fixed. They are working properly in this doc. 

 

3 is still an interesting problem, though. I want “letters surrounded by parentheses” to be in GREP style “Tech Terms.” I tried to accomplish this by the command |\(A\)|\(B\)|\(C\)|\(D\)|\(E\)|. However there is a syntax error: the )| is missing after B\, so it currently reads “|\(B\(C\)|\(D\)|”. You can see at the bottom of the document the effect of this.

 

The problem is, when I try to fix it, either by just fixing it the Applied To box or by fixing the list in Notes & pasting from there, the whole GREP Style “Tech Terms” stops working throughout the doc. This is still a bit of a mystery.

 

A third issue I was having seems also to have fixed itself: when I would copy & paste from either Word or Notes, neither GREP Style would work. Still true when I copy from Word, but BOTH are working when I copy from Notes. Again, no idea what changed.

 

So in sum, the main problems are 1) Delete Overrides button grayed out, 2) can’t fix the syntax error in Applied To box without the whole GREP style breaking, and 3) any of the problems that were "fixed" could easily come back again, since I have no idea how they got fixed in the first place.

 

Anyway, thanks for your all your help!!! Lmk if the Dropbox link is working, and please share any suggestions. Thanks!!

 

 

 

 

 

https://www.dropbox.com/s/oy8zscj9ihkkvtx/test%20doc.indd?dl=0

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2020 0
Adobe Community Professional ,
May 09, 2020

Copy link to clipboard

Copied

Hi Anthony,

 

For the Tech Terms GREP style, try changing to the following:

Period|Sentences?|Underlined Portion|Semi-Colons?|Dash(es)?|Punctuation Marks That Aren't Commas|Punctuation Mark That Isn't A Comma|(?<!Differences Between The )(Answer Choices?)|No-Question|Underlined Portion|No Change|\(A\)|\(B\)|\(C\)|\(D\)|\(E\)|\(F\)|\(G\)|\(H\)|\(I\)|\(J\)|\(K\)

 

The Clear Overrides button is grayed out because there are no overrides in text frame with your main flow of text. There are local overrides in the three other text frames with questions/answer choices that have the [Basic Paragraph] style applied.

 

I would suggest a couple of things:

1) Create custom paragraph styles, as suggested previously, for the questions/answer choices content rather than using [Basic Paragraph].

2) Rather than putting that content in separate text frames, make them part of the main text flow. That way you don't have to move them if the text reflows. If you need two columns, use the Split Column feature. A couple of resources on how to use the feature are below.

 

Span/Split Column references

https://creativepro.com/indesigns-span-and-split-columns/

https://indesignsecrets.com/timesaver-span-and-split-columns-in-cs5.php

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 09, 2020 2
Explorer ,
May 11, 2020

Copy link to clipboard

Copied

Hi David, thanks for the response!! First of all, I was able to copy & paste your version into the Applied To text box & the (B) & (C) are now working. Funny thing is, I'm pretty sure it's same edit I was trying to make. Don't why I couldn't fix it by typing in the Applied To box or pasting from notes. But anyway, very happy to see it functioning properly.

 

Next, I know I need to address the Q&A text frames -- had put those on the back-burner. But aside from them,  I see Override Highlights at the top of every page, as well as at the end of the text on page 2, after the (H). And those cases, it appears that Body Paragraph style is applied. Do you see those as well, and if so any thoughts on what's going on?

 

Also, I like the idea of no text boxes. I'll take a look at the column functionality that you suggested. Thanks for the tip!

Please lmk if you have any thoughts on the Override Highlights I mentioned. Thanks!!

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2020 0
Adobe Community Professional ,
May 11, 2020

Copy link to clipboard

Copied

Hi Anthony,

 

There are two text frames on the A-Master page. Go to that page and delete the one in back, and that should clear up the overrides that you're seeing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2020 1
Explorer ,
May 12, 2020

Copy link to clipboard

Copied

OK thanks, that worked. All problems have been addressed.  Now I can actually get to work. Thanks, guys!!! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 12, 2020 0