Hatched background when exporting SVG files to PDF

New Here ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

Hello,

 

I have a problem with InDesign. I imported icons in SVG and changed their color using an effect (inner glow). When I see them in InDesign, everything seems fine, the background of the icons is transparent. But when I export the file in PDF, a hatched background (the same color as the icon) appears. 

 

I tried to replace the SVG by PNG files but despite changing the image importation options, some of them have a white background that can't be changed.


Thanks in advance,

Morgane

TOPICS
Bug, How to, Import and export

Views

84

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 11, 2020 Dec 11, 2020
The transparent background is not being rendered in the PDF reader. Are you using Acrobat Reader or Acrobat Professional to view the PDFs?  If not - and using Chrome Reader or Foxit Reader, or any other non-Adobe PDF reader it might have issues interpreting the transparency in the PDF.   If the image has a PNG background - then you need to reimport the the PNG images and when using File>Import make sure to select Show Options.   Alternatively there's a script for it - I wrote about it here - https://creativepro.com/script-show-options-files/...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

The transparent background is not being rendered in the PDF reader.

Are you using Acrobat Reader or Acrobat Professional to view the PDFs? 

If not - and using Chrome Reader or Foxit Reader, or any other non-Adobe PDF reader it might have issues interpreting the transparency in the PDF.

 

If the image has a PNG background - then you need to reimport the the PNG images and when using File>Import make sure to select Show Options.

 

Alternatively there's a script for it - I wrote about it here - https://creativepro.com/script-show-options-files/

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines