Locked

Hebrew text in reverse

Community Beginner ,
Dec 10, 2017 Dec 10, 2017

Copy link to clipboard

Copied

I'm translating a document from English to Hebrew with InDesign ME (middle east) 2017 version.

The original file was made with a regular (not ME) version.

There are tables in the document.

When I put Hebrew text inside the table it appears in reverse, meaning the word appears from left to right (not as mirror).

This is what I do:

I mark a table.

I change the direction of the table to "Right-to-Left Table".

I change the Language to Hebrew in the Character window.

I change the paragraph direction to "Right-to-Left Paragraph Direction".

Still the text is reversed!

I can't solve this. What can I do?

Thanks

Untitled-1.jpg

Views

4.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Dec 12, 2017 Dec 12, 2017
For Hebrew RTL text to work properly you need to be using the correct text composer. If you are using a Hebrew enabled version, then this is found in the Paragraph pallette's pop out menu. There are 4 choices: Adobe Paragraph Composer; Adobe Single Line Composer; Adobe World Ready Paragraph Composer and Adobe World Ready Single Line Composer. For your Hebrew text, you must select one of the two World Ready Composers for the RTL to work properly.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Dec 10, 2017 Dec 10, 2017

Copy link to clipboard

Copied

You need to change the character direction as well. In the paragraph style dialog, it's found here: Middle East Character Formats > Character Direction.

Usually, Default is the best setting, because it allows for a mix of numbers, letters and English characters. But if that doesn't work, you can choose right-to-left.

Ariel

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

Thank you. I tried your suggestion but it didn't work.

I'll be glad for more ieas how to solve it.

Maybe there is a way to format a table from it's contents (not deleting)?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

Did you use a Character Style with the wrong direction settings for Hebrew?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

I tried all the directions possible... It's probably not the problem ...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2017 Dec 11, 2017

Copy link to clipboard

Copied

Have you set your composer (Paragraph menu fly out) to one of the World Ready composers?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

I'm not sure I understood

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

For Hebrew RTL text to work properly you need to be using the correct text composer. If you are using a Hebrew enabled version, then this is found in the Paragraph pallette's pop out menu. There are 4 choices: Adobe Paragraph Composer; Adobe Single Line Composer; Adobe World Ready Paragraph Composer and Adobe World Ready Single Line Composer. For your Hebrew text, you must select one of the two World Ready Composers for the RTL to work properly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

It worked!!! Thank you very much, I learned something new

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 12, 2017 Dec 12, 2017

Copy link to clipboard

Copied

Glad that did it for you. There are a lot of different things that need to be set properly for RTL text to work right.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2019 Jan 21, 2019

Copy link to clipboard

Copied

Thanks for this but it is still extremely limiting as the choice of fonts or effects do not work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 21, 2019 Jan 21, 2019

Copy link to clipboard

Copied

I don't understand what doesn't work. Of course you are limited to fonts that contain the Hebrew character set. A number are included in Windows, and InDesign comes with at least one (Adobe Hebrew) and maybe another, plus many more can be purchased.

Are you using the version with Hebrew support?

If so, let us know exactly what doesn't work and I can probably help you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

thank you!
I'ts work!

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines