How do I stop InDesign from turning on an object effect globally, after applying it to one object?

Explorer ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Hi and thanks for your help. My question: Often, when I apply an object effect like outer glow or feather to one object, that effect then gets turned on globally so every object I create after that automatically has the effect applied. It doesn't do it every time, and I can't figure out what I'm doing differently (if anything) to make the effect turn on globally. I've had this issue the whole time I've been using InDesign, since maybe CS4. I'm definitely not picking the effect without any object selected, so it's not that I'm accidentally turning it on at a global level myself.

Anyone else have this issue and know why it happens or how to prevent it?

Thanks,

Elena

Views

1.3K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Advisor , Jun 01, 2019 Jun 01, 2019
Regardless, it does sound like you're certain the problem is in InDesign.Barb asked if you were choosing FX options from the other locations (other than the Properties panel) in InDesign, such as the Object menu, the Control panel, or the Effects panel itself. All of these can be active the same time as the Properties panel.You told Barb,ElenaLeeMing  wroteYes, I use those panels, but again the FX option is only available if there's an object already selected, so would it even be possible to set...

Likes

translate

Translate

Translate
Adobe Community Professional ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Apologies for the bluntness but are you sure this isn't happening as a result of you activating an effect with nothing selected? I appreciate you said that you have already ruled this out.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Yes

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Hi Elana:

I'd say it's one of two things:

  1. You are inadvertently setting a document default with nothing selected or
  2. you are inadvertently using an object style for new objects with the effect activated in the style. See Use object styles to format objects in an InDesign document.

Since you are ruling out the first one, explore the second. Let us know what you uncover.

~Barb

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

Hi, Barb - If those are the only two options, I'm going to need some help figuring out what I'm accidentally doing that's activating the effect at the document level.

1. The reason I'm convinced I'm not accidentally setting a document default with nothing selected is that that would require me to--without having anything selected--go into Object Effects, pick my effect, set all my settings, click OK and go back to my document and see that the original object I'd intended to add the effect to hadn't changed. Which would mean going back and making all those selections for a second time with the object selected. And this would have to happen several times a week. I feel like I would notice if that were happening.

2. I never use Object Styles...so, if I never open the panel, is there a keystroke or other selection that I might unknowingly be making that would set a style (or update the Basic style) without opening the panel?

Elena

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2019 May 30, 2019

Copy link to clipboard

Copied

Also, I'd add to this that ever since the last major update I almost always apply object effects using the FX option (under Appearance) in the vertical dock, and that Appearance menu is only available if you have something selected. This just means it would be extra difficult for me to be applying object effects with nothing selected.

Ideas?

Elena

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2019 May 30, 2019

Copy link to clipboard

Copied

Hi Elana:

Do you use the Control panel or the new Properties panel? Effects are available on both:

Screen Shot 2019-05-30 at 6.55.32 PM.png

Inadvertent shortcuts could be the culprit, but the only default shortcut is for a drop shadow. Do you have other shortcuts defined?

Screen Shot 2019-05-30 at 6.58.12 PM.png\

If we can rule out all of these, the next step is to delete the preferences/cache.

~Barb

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 31, 2019 May 31, 2019

Copy link to clipboard

Copied

Hi Barb - Yes, I use those panels, but again the FX option is only available if there's an object already selected, so would it even be possible to set an effect as a document default from there?

And no, no custom shortcuts set for effects.

What's the process for deleting the preferences/cache?

Thanks,

Elena

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 30, 2019 May 30, 2019

Copy link to clipboard

Copied

This problem is easy to fix.

Let's say, for example, you create a blue rectangle and apply a drop shadow. Then the next time you draw a rectangle it too is blue with a drop shadow? And you want a white rectangle with no drop shadow. Sound familiar?

Click the rectangle once while it's still in the Tools panel. Then set the Fill to Paper (White) and open the Effects panel and turn off the Drop Shadow effect.

Now click away to another tool. The next time you click and draw a rectangle your object will have a white fill and no drop shadow.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 31, 2019 May 31, 2019

Copy link to clipboard

Copied

Hi, Scott - Thanks for your reply. Your scenario sounds somewhat familiar....but why is the second object picking up all the attributes of the first object in the first place?

Elena

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 01, 2019 Jun 01, 2019

Copy link to clipboard

Copied

The second object automatically "remembering" and picking up the settings applied to the first object is the default behavior of Illustrator, not InDesign. So if it's happening in InDesign, something is glitchy.

Is it possible that you are actually referring to what's happening in Illustrator? For example, this screen shot is from Illustrator.

2019-06-01_08-01-28.png

There you have the same Properties panel, with the same action you describe; the "fx" option doesn't appear under Appearance unless you select an object first. (Which is also what happens in InDesign.)

This has happened to ALL of us at one time or another, so if it's the case, don't be embarrassed. 😉 If not, sorry, had to bring it up (for lurkers in the future, if nothing else.)

AM

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 01, 2019 Jun 01, 2019

Copy link to clipboard

Copied

Regardless, it does sound like you're certain the problem is in InDesign.

Barb asked if you were choosing FX options from the other locations (other than the Properties panel) in InDesign, such as the Object menu, the Control panel, or the Effects panel itself. All of these can be active the same time as the Properties panel.

You told Barb,

ElenaLeeMing  wrote

Yes, I use those panels, but again the FX option is only available if there's an object already selected, so would it even be possible to set an effect as a document default from there?

Yes, it would be possible. Unlike in the Properties panel, the FX option is always available in those other locations, even though you don't have an object selected. So choosing something there, even with nothing selected, could inadvertently set the defaults for that tool (the Frame tool, for example) if that's the active tool.

The fix is:

  1. Choose Edit > Deselect All
  2. Select the Frame tool (or whichever tool you use to create an object that's coming in with an unwanted appearance)
  3. Check the state of the effects in the  fx menu in the Effects panel or from the Control panel's FX button. There should be no checkmarks next to any effects. If there is, choose that effect again to deselect it.
  4. Check the Fill/Stroke settings in Swatches and Strokes. Change if necessary (as Scott outlined).
  5. Save your document

Now try again. Use the tool to create a shape. It should use the defaults you reset.

FASTER: Instead of steps 3 and 4, another solution is with nothing selected but the tool active, open the Object Styles panel (Window > Styles > Object Styles) and Option/Alt-click on the default style to clear out overrides, indicated by the plus symbol. That will reset the tool to the "factory defaults".

2019-06-01_08-15-18.png

AM

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2019 Jun 01, 2019

Copy link to clipboard

Copied

Thanks, A-M. I think you've nailed it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 02, 2019 Jun 02, 2019

Copy link to clipboard

Copied

Hi, AnneMarie - Yes, as you mentioned, I'm sure this is in InDesign, where I spend 90% of my design time every day.

In response to this comment:

"Yes, it would be possible. Unlike in the Properties panel, the FX option is always available in those other locations, even though you don't have an object selected. So choosing something there, even with nothing selected, could inadvertently set the defaults for that tool (the Frame tool, for example) if that's the active tool."

Sorry, I misread and mis-answered that question from Barb about the Object/Control/Effects panels. I generally don't use those separate panels since it's more streamlined (and more foolproof) to use the dynamic Properties panel on the vertical dock for the exact reason that it feeds you what you need only when you need it and you don't have to have separate panels floating in your workspace. So to confirm, yes I only choose the effects from the Properties panel, when the object is already selected.

I know how to turn off the effect after it's set itself as the new default, but that doesn't explain how to prevent it from happening in the first place (and as I mentioned, it's happening several times a week).

So that still leaves the mystery of why it's happening at all. You mentioned that if it's happening in InDesign, as opposed to Illustrator, then something is glitchy. Is that the whole explanation? A glitch?

Elena

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 04, 2019 Jun 04, 2019

Copy link to clipboard

Copied

Yes, "glitch" is the technical term. 😉

If you're positive it's not user error, then it's some sort of corruption in your preferences, or with the file itself.

Does it happen in all the files you create?

Does it happen if you log on as a test user to your computer?

Does it happen if you rebuild preferences?

That would help diagnose the source of the problem.

AM

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Thanks AnneMarie.  I was having the same issue and opening the Object Styles fixed it for me.  I don't recall ever opening and setting up a style, but the + on the "Basic Graphic Frame" proved it had been modified.  I trashed that, saved, and am back to normal.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines