Highlighted

How to retain preferences + workspace settings?

Explorer ,
Sep 15, 2017

Copy link to clipboard

Copied

Every time I launch InDesign, I have to manually change preferences. I understand that when InDesign crashes, the preferences won't work. But even when I manually quit and restart, I have to keep recreating my settings. This is becoming a nuisance.

My saved workspace, for example, is for a white pasteboard. Even though I've saved it as "white pasteboard," it never resets the default black pasteboard.

I see that a number of other people have asked this question. It doesn't seem to get answered.

Thank you.

Adobe Community Professional
Correct answer by Bill Silbert | Adobe Community Professional

Set up all of your preferences with the program active but with no document open. When you're done setting everything as you like quit the program. When you relaunch the preferences should hold.

If it does not work the first time then try deleting your preferences first.

To do so:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you set up your new preferences as I suggested above make a copy of your "pristine" preference file to use in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

Windows preference file: C:\Users\[User Name]\AppData\Roaming\Adobe\InDesign\Version [#].

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to retain preferences + workspace settings?

Explorer ,
Sep 15, 2017

Copy link to clipboard

Copied

Every time I launch InDesign, I have to manually change preferences. I understand that when InDesign crashes, the preferences won't work. But even when I manually quit and restart, I have to keep recreating my settings. This is becoming a nuisance.

My saved workspace, for example, is for a white pasteboard. Even though I've saved it as "white pasteboard," it never resets the default black pasteboard.

I see that a number of other people have asked this question. It doesn't seem to get answered.

Thank you.

Adobe Community Professional
Correct answer by Bill Silbert | Adobe Community Professional

Set up all of your preferences with the program active but with no document open. When you're done setting everything as you like quit the program. When you relaunch the preferences should hold.

If it does not work the first time then try deleting your preferences first.

To do so:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you set up your new preferences as I suggested above make a copy of your "pristine" preference file to use in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

Windows preference file: C:\Users\[User Name]\AppData\Roaming\Adobe\InDesign\Version [#].

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 15, 2017 0
Adobe Community Professional ,
Sep 15, 2017

Copy link to clipboard

Copied

Set up all of your preferences with the program active but with no document open. When you're done setting everything as you like quit the program. When you relaunch the preferences should hold.

If it does not work the first time then try deleting your preferences first.

To do so:

For Macintosh Users: With InDesign closed Launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the folder called Preferences and within it find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

After you set up your new preferences as I suggested above make a copy of your "pristine" preference file to use in the future to replace any corrupt versions you may need to delete.

For Windows Users: Hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset.

Windows preference file: C:\Users\[User Name]\AppData\Roaming\Adobe\InDesign\Version [#].

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 1
Explorer ,
Sep 15, 2017

Copy link to clipboard

Copied

This did work. Thanks. At first it didn't but I had failed to name the new set of preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
Adobe Community Professional ,
Sep 15, 2017

Copy link to clipboard

Copied

If you deleted preferences after unchecking the Start Page then the program would go back to default and it would be there again. Make all of your customizations to the program with no document open after deleting your preferences. I realize that my original post might have been a little confusing in the order but to be clear: 1. Delete Preferences with program closed. 2. Customize your InDesign with no document open. 3. Quit InDesign and hopefully your preferences will stick.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
Adobe Community Professional ,
Sep 15, 2017

Copy link to clipboard

Copied

Great. Your new reply popped up while I was writing my last one. So, if you're good now you don't even have to read it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
Adobe Community Professional ,
Sep 15, 2017

Copy link to clipboard

Copied

Does this happen every time? Are your folder permissions set to allow InDesign to save your defaults?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
Explorer ,
Sep 15, 2017

Copy link to clipboard

Copied

I'm going to try Bill's above suggestion, but since you ask, I don't know what folder permissions are.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
Adobe Employee ,
Sep 15, 2017

Copy link to clipboard

Copied

Hi,

What do you mean by white pasteboard?

If you have unchecked "Match pasteboard to theme color" in Interface section of Preferences then it should be preserved. Which i guess you are hinting at.

If however you have changed the paste board color from the Preferences->Guide and pasteboard(preview) section to white then it is not preserved since it is stored at document level.

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 1
Explorer ,
Sep 15, 2017

Copy link to clipboard

Copied

By white, I mean that's the name I gave it. No, I'm not setting it at document level. I'm setting it with no file open. But I'll try the suggestion above. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2017 0
New Here ,
Jul 12, 2020

Copy link to clipboard

Copied

Jane, I think I know what you mean. I like my docs to open with my fav settings: all rules are .25 black, and the font is Gotham. To retain this, your create WORKSPACES (all the way in the upper right hand corner). Save 'em and then you can recall them for any new doc. However, mine just stopped working today, and after some fussing around, I just reset them (toggle them on and off - just select another workspace in your blank doc and then reselect the saved workspace).  June

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2020 0