Highlighted

Hyperlink to TOC on Master Page needs to be accessible in pdf

Community Beginner ,
Aug 21, 2020

Copy link to clipboard

Copied

I have an icon on the master page of a 100-page InDesign 2020 document that hyperlinks to the TOC (page 1). The hyperlink works as a pdf, but my pdf needs to pass the accessility checker. What's the proper way to do this? I've made the icon an artifact, but the first image on the page gets nested with the link tag. My only work around is to go into Acrobat and pull every one of the images out of the nested tag. I'd prefer to have it fixed in InDesign. I'm new to accessibility, but have done much research and don't seem to find an answer. Thanks for any help!

I changed Object Export Options to "Based on Object" and deleted the Alt-text from the hyperlink menu (but left Alt-text in the Object Export Options menu) and it worked!! Wahoo!!!

Topics

Bug, Performance

Views

31

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Hyperlink to TOC on Master Page needs to be accessible in pdf

Community Beginner ,
Aug 21, 2020

Copy link to clipboard

Copied

I have an icon on the master page of a 100-page InDesign 2020 document that hyperlinks to the TOC (page 1). The hyperlink works as a pdf, but my pdf needs to pass the accessility checker. What's the proper way to do this? I've made the icon an artifact, but the first image on the page gets nested with the link tag. My only work around is to go into Acrobat and pull every one of the images out of the nested tag. I'd prefer to have it fixed in InDesign. I'm new to accessibility, but have done much research and don't seem to find an answer. Thanks for any help!

I changed Object Export Options to "Based on Object" and deleted the Alt-text from the hyperlink menu (but left Alt-text in the Object Export Options menu) and it worked!! Wahoo!!!

Topics

Bug, Performance

Views

32

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 21, 2020

Copy link to clipboard

Copied

Items on Master Pages are automatically artifacted when exported to an accessible PDF. When that object is hyperlinked, it creates a link that is not attached to anything in the PDF which produces problem. Essentially, you need to override that object on the page(s) that you the object to appear on. If it's a 100 page document, and you want it to appear on every page, you'll need to do it on each page. You can also turn off the "allow master item overrides" option on elements on the master that you don't want overridden, then use the override all master page items command to potentially make it a little quicker. Having not seen your document it's tough to say which would be better. But bottom line, you need those items to appear on each page. That should solve the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 21, 2020

Copy link to clipboard

Copied

I've unlocked the icon from the master page on the first several pages and no longer identified it as an artifact. (I also turned off "allow master item overrides" on all master page elements except for the icon). And I still get "Nested alternate text - Failed". Under Object Export Options the Tagged PDF, Apply Tag is "From Structure". In the PDF the <Figure> and the Link - OBJR are now under the same <Link>.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 21, 2020

Copy link to clipboard

Copied

I changed Object Export Options to "Based on Object" and deleted the Alt-text from the hyperlink menu (but left Alt-text in the Object Export Options menu) and it worked!! Wahoo!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...