Hyperlinks missing when InDesign file is opened on another Mac

New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Help required with Hyperlinks

I created an indesign document with about 100 hyperlinks (all links were to url addresses), all links were flowed into InDesign for a word file and all links were active, as indicated by the green light on the hyperlink panel.

When the InDesign file was packaged and moved to another Mac, the hyperlinks are shown as missing and indicated with the red light on the hyperlnk panel.

Have also tried to save the file as an .idml file and get the same result.

Anyone any ideas???

Views

502

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Does the other computer have access to these URL destinations?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Yes both computers have internet access,

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Are you using Indd file or maybe IDML and previous version of InDesign?

pawel

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Tried both Indd and IDML files, both macs running same version of InDesign

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

What happens on the problem computer if you create a new hyperlink to a different web site? If it's OK, what happens if you create a new hyperlink to the problem web site?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

The problem is not accessing the websites, it is InDesign dropping the web address from the hyperlink

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

So if you create a new link does it show up with green or red?

What exactly do you mean by "InDesign dropping the web address from the hyperlink"? I don't think you've mentioned this before, though I may have missed it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

On the Original InDesign Document, when you open up the hyperlinks panel, they all have green lights and also the web address is present.

But when the file is opened on another mac, the green lights are now red (indicating the link is missing) and also the web address is not present, all that is left is "http://"

hope this helps

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

What I asked was that you open the document on the problem Mac and make new hyperlinks. Please do the tests I described.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Making new hyperlinks works fine on the problem mac

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Ok, so link checking is OK on that Mac. That was the key thing I was checking. The links that you create: are they complete web addresses, starting http:// (two slashes) and the full name?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Yes they start with http:// also they work with starting just www

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

They might seem to work, but I would always use a correct URL. Something starting www is a "relative URL" and can cause you all sorts of pain. Web site designers often make this mistake and the links break once it is live. I don't think that's the issue, but personally I'm all out of ideas now, sorry.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2018 Apr 04, 2018

Copy link to clipboard

Copied

Thanks, for having a look anyway, really appreciate it

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

I am also having this problem. Except my links dissappear on the same Mac. I have one big Indd file that I have 6 different Skill lessons in. When I need to make a workbook with a different combo of skills I Save a copy, then delete the uneeded content. Sometimes this process causes links to dissappear. Other times it is simply opening the same file a new time. They  are the full hyper link (includes the http). I can't figure out what is going wrong....  😞

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines