Hypnation results to two hyphens in one word

New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Some months ago something changed with the automatic hypnation of text in my documents. Some words that are hypnated get a hyphen at the end of the first part (normal), but also at the beginning of the second part that is placed on the next line. Now I have to manualy adjust this. I don't understand why this started and how to fix it. Thanks for your suggestions.

TOPICS
Type

Views

395

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Contributor , May 28, 2021 May 28, 2021
Try to change your dictionary hyphenation to Proximity:

Likes

Translate

Translate
Contributor ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

What is the language of your text? In both British and American English hyphens are only at the end of the first line:

... so-

called ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

The language is Dutch. Also one hypen is needed. But when a word already has an hyphen like 'Oost-Azië' this happens:
...Oost-
-Azië...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Could you please send some part of this project in .indd? I'll have a look.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Thanks, these are two pages of the magazine. I appreciate you want to take a look.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Try to change the language to "Dutch: old rules", and then to "Dutch: 2005 reform" (don't know the right names). Check this out as it worked for me:

old rules: 1.jpg

 

2005 reform: 2.jpg

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

That looks promising! But sadly I don't have the same result here...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Try to change your dictionary hyphenation to Proximity:

3.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Yesss! I've tried that options before with no result. But today for some reason the problem is gone.

Thanks a lot.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

That's great. Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

Hi M.M.J.B82A,

I see the same issue when I open your InDesign document with my German InDesign 2021.

And I also was in trouble to find the right settings so that the hyphenation of the text is the result you are expecting with the applied language for the text: Dutch: 2005 Reform.

 

Here the stages of my little journey:

 

[1] Opened an IDML file of your document, ignored the missing font warnings and headed for Preferences > Dictionary.

As you can see from my German InDesign the language of the dictionary is set to German: 2006 Reform. This setting is not specific to a document, it is for the application.

 

What is a specific preference for a document is Hyphenation. And that is set to Hunspell.

The word Oost-Azië is selected in the text and the hyphenation apparantly is the wrong one. The selected text is formatted with Language: Dutch: 2005 Reform

 

01-WRONG-Preferences-Hyphenation-Hunspell.PNG

 

[2] If I now change my document related preferences for Hyphenation to Proximity, nothing changes. To be absolutely sure about this I answered my changes to the preferences with OK, opened them again and then took the screenshot:

02-WRONG-Preferences-Hyphenation-Proximity.PNG

 

[3] Hm. Now I was unsure what to do next and tried the following:
I changed the language of Hyphenation back to Hunspell and changed the language of the dictionary to Dutch: 2005 Reform. Still hyphenation of the word Oost-Azië was wrong:

03-WRONG-Preferences-Hyphenation-Hunspell-DictionaryLanguage-Dutch2005Reform.PNG

 

[4] The next step was to change hyphenation back again to Proximity:

And now, finally, hyphenation of the selected word changed to the expected result!

And that without closing the Preferences panel with OK:

 

04-RIGHT-Preferences-Hyphenation-Proximity-DictionaryLanguage-Dutch2005Reform.PNG

 

The crazy thing: After I had the right result with text hyphenation I could switch back the language of the dictionary to German: 2006 Reform without changing the hyphenation again.

 

05-RIGHT-Preferences-Hyphenation-Proximity-DictionaryLanguage-German2006Reform.PNG

 

So the expected hyphenation needed a kick by changing the language of the dictionary at least once. Together with a change of hyphenation to Proximity in the Preferences.

 

This behavior could hardly fell under category "good user experience".

That's a bug.

 

FWIW: As a last step I saved the document with a new name, closed it, opened it again and hyphenation of Oost-Azië was still alright.

 

Regards,
Uwe Laubender

( ACP )

 

//EDITED

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

And just a remark about the hyphenation behavior with language "Dutch" ( not Dutch: 2005 Reform ).

With language "Dutch" it is alright, that after the hyphen the dash is maintained in the next line of text:

 

Hyphenation-Dutch-DashWillBeMaintained-2.PNG

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

LATEST

Hi Laubener, thats interesting! I admire your determination to get to the bottom of this problem. It indead looks like a bug, because I've tried several parts of the solution before. Thanks for your time and the fact that I feel less incompetent in fixing it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines