Highlighted

I've had enough. Mac, Magic Mouse, Indesign, app keeps hiding when I click near the top? HELP!

Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

Okay, I've put up with this for a few years now. iMac Pro, with stock magic mouse/keyboard.

 

I'm going to try to explain this the best I can, here goes:

 

When working in InDesign, all of a sudden the program "hides", as if I hit some sort of key command for Hide App. It just dissapears, and I'm suddenly in Photoshop, or whatever other program I have open also. 

 

It appears random, but I don't know if it is. It seems to happen only when I'm clicking near the very top of the screen, like clicking in the very top tool bar in ID. It's absolutely horrible. It can happen every few minutes, sometimes more often. 

 

ID is not crashing, no errors, just having ID go away, and I have to click the dock icon or if I can see part of the app below other windows, click on that to get back and carry on.

 

1. It only happens when working in InDesign

2. I don't have a hot corner for either the top left, or right set at all

3. I have my mouse set to only a right click, so nothing fancy

4. I've looked through all Mac prefs, nothing crazy. Very basic stuff.

5. I only have magic mice in my possession to try. Can't imagine it's a mouse thing, as it's only InDesign.

 

It's done this since I got this new iMac Pro 2 years ago. Both Mojave I have now, and whatever came before Mojave, so it's not an OS thing, or an ID version thing. I've upgraded ID several times since.

 

Again, it could be a mouse thing, it could be ID has some type of upper toolbar thing I don't know about? You guys are my last hope. I have tried googling this issue many times. Nothing comes up, it's always the cursor disappearing or something.

 

I'm open to any and all ideas. Crazy guesses, you name it.

 

Thanks.

TOPICS
Performance

Views

83

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

I've had enough. Mac, Magic Mouse, Indesign, app keeps hiding when I click near the top? HELP!

Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

Okay, I've put up with this for a few years now. iMac Pro, with stock magic mouse/keyboard.

 

I'm going to try to explain this the best I can, here goes:

 

When working in InDesign, all of a sudden the program "hides", as if I hit some sort of key command for Hide App. It just dissapears, and I'm suddenly in Photoshop, or whatever other program I have open also. 

 

It appears random, but I don't know if it is. It seems to happen only when I'm clicking near the very top of the screen, like clicking in the very top tool bar in ID. It's absolutely horrible. It can happen every few minutes, sometimes more often. 

 

ID is not crashing, no errors, just having ID go away, and I have to click the dock icon or if I can see part of the app below other windows, click on that to get back and carry on.

 

1. It only happens when working in InDesign

2. I don't have a hot corner for either the top left, or right set at all

3. I have my mouse set to only a right click, so nothing fancy

4. I've looked through all Mac prefs, nothing crazy. Very basic stuff.

5. I only have magic mice in my possession to try. Can't imagine it's a mouse thing, as it's only InDesign.

 

It's done this since I got this new iMac Pro 2 years ago. Both Mojave I have now, and whatever came before Mojave, so it's not an OS thing, or an ID version thing. I've upgraded ID several times since.

 

Again, it could be a mouse thing, it could be ID has some type of upper toolbar thing I don't know about? You guys are my last hope. I have tried googling this issue many times. Nothing comes up, it's always the cursor disappearing or something.

 

I'm open to any and all ideas. Crazy guesses, you name it.

 

Thanks.

TOPICS
Performance

Views

84

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 15, 2020 0
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

I want to add I'm not 100% sure if it's a clicking action that triggers it. I recall just shooting the cursor up there somewhere and it happening. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

That may be your MacOS setting for Hot Corners.

 

Go to your System Preferences>Desktop & Screen Saver option and click on the Screen Saver area. If Hot Corners are selected, de-select it and apply the settings.

 

Hopefully that will be the answer for you.

 

Randy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 1
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

I almost forgot:

 

Here's an Apple link for checking out exactly how to do that with both the Catalina and Mojave versions of MacOS:

 

De-Select Hot Corners

 

Randy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

There have always been problems with the magic mouse and InDesign.

 

You can download a third party OS preference pane—MagicPrefs—which might solve your problem. I’ve been using it for 6 years and it still works fine on High Sierra and is 64-bit. Updates stopped at 10.8, but you can still download it here:

 

http://magicprefs.com/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Adobe Community Professional ,
Oct 15, 2020

Copy link to clipboard

Copied

You've absolutely got a point about that!

 

I once got so mad at the cursor from my Magic Mouse jumping around erratically and messing up that I literally flung it off the desk. I also got to practice my skills with spackling and sheetrock tape. It didn't do a thing to improve the mouse, however ...

 

Retiring that thing for a run-of-the-mill Bluetooth mouse made my life a heck of a lot easier.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

I'll admit I'm not a huge fan of the mouse. It was really hard, I'm still not over it, to give up my white mighty mouse, with the little ball roller on top. I have some new in the box still as I was worried about them when they quit making them. But I've gotten used to the MM I guess. 

 

It's most definitely not a hot corner thing. I really paid attention since I posted this, and realized it's not only ID, it did happen to me in Photoshop I think.

 

I changed my wording and did a fresh google search, and think I found something.

 

Someone on the Apple forum mentioned suddenly dumping to Finder, once a minute or more. That's what it is, I just end up in Finder. One person suggested unplugging the iPhone from the computer. Apparently it's got something to do with the OS interacting with the phone? And then dumping to the Finder and not popping up any error messages.

 

Sounded bizarre, but I worked for 2 hours just now with the phone NOT docked like I keep it always. And you know what? It hasn't happened since! Why it's mainly ID, and occasionally PS, I have no idea. I'm going to do some Illustrator work and see too. 

 

If that's true, I'm going to be awful shocked. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Adobe Community Professional ,
Oct 16, 2020

Copy link to clipboard

Copied

I have 3 Apple machines running magic mice and the Magic Prefs pane without any ID issues

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
Adobe Community Professional ,
Oct 16, 2020

Copy link to clipboard

Copied

Hopefully you've run across the Karmic Mac Fix. Do something arcane and specifc. Reboot. Then see if it's karmically fixed. Like using a five-key shortcut during the startup sequence for zapping the P-RAM, and after you do it the second or third time the problem is gone.

 

I know the idea may sound bizarre, but some of these things actually work. And get passed passed around by Mac cognoscenti until they become known as a special Mac fix. Hopefully this will be your good fortune, and you can pass your experience along as part of the Legend of Macs®.

 

Good luck,

 

Randy

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
Explorer ,
Oct 16, 2020

Copy link to clipboard

Copied

I can't believe it, but I worked 2 hours last night, and a few this morning, and all is fine. I simply left my iphone unplugged. That's it. So I'm thinking it wasn't really a clicking of the mouse, but just a random action that made it seem like I was doing something to trigger it. 

 

It's done this through 2 OS updates, and 3 iOS updates. So I have no idea if Big Sur or iOS 14, or any combination will fix it. But I guess I can't have my iPhone docked to my iMac anymore...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
Adobe Community Professional ,
Oct 16, 2020

Copy link to clipboard

Copied

That is so odd.  The next time it happens, if there's some way to record it happening,  I'd record it and post it here so we have a better idea what's happening/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0
rob day LATEST
Adobe Community Professional ,
Oct 16, 2020

Copy link to clipboard

Copied

It's done this through 2 OS updates,

 

Yes it is an old problem—goes back to at least OSX 10.8. I think there is a conflict between the OSX Mouse Preference Pane and InDesign. This is the MagicPrefs pane on OSX 10.13.6, which disables the built in Mouse pane:

 

Screen Shot 13.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2020 0