Illustrator Links Show Hidden Objects (on same layer) in InDesign

New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

I have linked .ai files in an InDesign document.  Up until the 2021 version I was able to simply hide an unwanted objects in Illustrator, even objects on the same layer, and InDesign would fit the frame to the visible objects only.  Now InDesign fits the frame to the entire layer, even hidden ones.  I also seeminly need to "fit the artboard bounds to artwork" inside of Illustrator to have InDesign recognize the size properly.

 

Is there a way to have InDesign 2021 to revert back to this kind of behavior?  I can't seem to find a setting for this. The OBJECT LAYER OPTIONS panel seems to only allow visibility by layer but as I said the objects are all on the same layer.

 

Perhaps this is a setting that needs to be adjusted in Illustrator instead?

 

Thanks

TOPICS
Import and export

Views

88

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct Answers

Adobe Community Professional , Feb 09, 2021 Feb 09, 2021
Create an artboard around the object you need in Illustrator.  You can have many different sizes of artboards in illustrator around the same object. The one you have activated when saving is the one that will be used in InDesign.

Likes

translate

Translate

Translate
Adobe Community Professional , Feb 09, 2021 Feb 09, 2021
The issue appears to be that the import options for the images are not retained.   https://creativepro.com/script-show-options-files/   This script allows you to reset the show options filter without having to relink the images.

Likes

translate

Translate

Translate
New Here , Feb 09, 2021 Feb 09, 2021
Thanks @Ian Sayers and @Eugene Tyson. If your problem is the same as mine you can solve it by either:-holding the SHIFT key when opening files from the place item dialouge box-checking the show import options at the bottom of the place item dialouge box Which brings up the [place PDF] option box. From there it is a fairly straightfoward operation *This is different from the one accessible by selecting Object Import Options from the Object tab.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Create an artboard around the object you need in Illustrator.  You can have many different sizes of artboards in illustrator around the same object. The one you have activated when saving is the one that will be used in InDesign.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

The issue appears to be that the import options for the images are not retained.

 

https://creativepro.com/script-show-options-files/

 

This script allows you to reset the show options filter without having to relink the images.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Thanks @Ian Sayers and @Eugene Tyson.

 

If your problem is the same as mine you can solve it by either:

-holding the SHIFT key when opening files from the place item dialouge box

-checking the show import options at the bottom of the place item dialouge box

 

Which brings up the [place PDF] option box. From there it is a fairly straightfoward operation

 

*This is different from the one accessible by selecting Object Import Options from the Object tab.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines