Import from Illustrator looks terrible in InDesign

Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Test.JPG

When I place graphic files in InDesign it looks terrible. Normally it works perfect. What is wrong?

I tried to change from Mac to PC, but that did not help

Views

12.4K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Feb 20, 2017 Feb 20, 2017
Effective PPI are 23Bingo. For print, you want to resolution to be at lease 200 ppi, although the precise number depends on the output device. The files are very very low res and that accounts for the pixelation.You can place native .ai files from Illustrator into InDesign and not have to deal with resolution at all. That's my recommendation.

Likes

translate

Translate

Translate
Advisor ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Are you using High Quality display settings?

Right click and choose display performance as below:

test6.PNG

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

In short > because you could have hundreds or even thousands of graphics/images in an InDesign document unless you specifically tell it to.. InDesign will display everything by default on "typical display settings" or occasionally on Fast display...

This essentially is a thumbnail or pre-render of the actual graphic displayed at a much lower resolution and quality than the original - giving you that blocky effect that you can see.

If however graphics are still blocky on high-quality display settings then this normally means that the original image/graphic is much too small to be scaled to the size you have set it in Indesign (i.e. width/height taken on X size of X spread).

Best,

EW

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

It is now at high, but the result is the same

This illustration is in A4 Size and I import it smaller to Indesign

Photo af Ai årke.JPGÅkre i Inn.JPG

I think is so strange( fruuustrating) , because it never have been a problem earlier.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

And when I try to copy some elipses from Ai to Ind I get the coding instead??

<!-- Generator: Adobe Illustrator 21.0.2, SVG Export Plug-In  -->

<svg version=”1.1”

     xmlns=”http://www.w3.org/2000/svg” xmlns:xlink=”http://www.w3.org/1999/xlink” xmlns:a=”http://ns.adobe.com/AdobeSVGViewerExtensions/3.0/”

     x=”0px” y=”0px” width=”617px” height=”95.3px” viewBox=”0 0 617 95.3”

     style=”overflow:scroll;enable-background:new 0 0 617 95.3;” xml:space=”preserve”>

<style type=”text/css”>

    .st0{opacity:0.77;}

    .st1{fill:#79BBB8;}

    .st2{fill:none;stroke:#E7EFEF;stroke-miterlimit:10;}

</style>

<defs>

</defs>

<g class=”st0”>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Hmmm....

Have you changed the global display settings to high quality?

If that doesn't work have you tried clicking on the frame (that contains the graphic) in InDesign then right click>preview>High Quality?

If none of that works - have you tried exporting to PDF at maximum resolution settings and seeing what that looks like?

Then Finally -

Do you have any raster effect settings set in Illustrator? (Effects > Document Raster Effect Settings...)

Are you using native illustrator files? Do you import and place these or copy and paste them into InDesign?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

It is all on high and some of the graphics have no effect, bur are only shapes with color fill

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

And it also looks terrible in a PDF

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Can I send you the InDesign file in any way?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Yes you can use a file sharing site like Dropbox.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

nilleg57851248  wrote

And it also looks terrible in a PDF

Then I suppose that the links to the original files are not updated or missing.

Check the Links panel.

Regards,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Hi,

did you do a test with Separation Preview panel and Separations turned on?

Or at least with View Overprint turned on?

Regards,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

nilleg57851248  wrote

… I think is so strange( fruuustrating) , because it never have been a problem earlier.

Did you had to trash your preferences lately?

Maybe your import options were set to default?

After inspecting your screenshot of your intital post I cannot see an Illustrator file placed.

Just an EPS file that perhaps was saved with Illustrator.

For EPS file types always check For screen: "Rasterize the PostScript" with your EPS place options.

From my German InDesign where this option is set:

EPS-Import-Options-Rasterize-the-PostScript.png

You can set the Import options at the bottom of the Open dialog where you select the file you want to place.

Regards,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

WOW!!!

THANK YOU SO MUCH!!!!!!

I spent so many hours trying to sort this out and nearly canceled the job - THANK YOU!!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 10, 2021 Apr 10, 2021

Copy link to clipboard

Copied

Bro, I love you! I'm new to Indesign and was frustrated over an imported SVG file being pixelated.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Select one of the images, and check the Effective PPI in the Links panel. What does it say?

InDesign CCss_018.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Actuall PPI are 72

Effective PPI are 23

Dimensions are 97 x 113

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

So that means the exports were at 72ppi, and then the art was scaled up in size on the ID page, thus lowering the effective ppi to a crude 23 ppi. How are you exporting these pngs and jpgs from Illustrator? Why are you not keeping the artwork in a vector format like a native .ai file or a PDF file format?

Mike Witherell

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

I will import an ai file every time now !

Thank you THANK YOU

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Great! And use File > Place.That way you can use the Pencil icon in the Links panel to hop over to Illustrator to edit and file. When you save and close, InDesign will update the document to reflect the latest update.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Effective PPI are 23

Bingo. For print, you want to resolution to be at lease 200 ppi, although the precise number depends on the output device. The files are very very low res and that accounts for the pixelation.

You can place native .ai files from Illustrator into InDesign and not have to deal with resolution at all. That's my recommendation.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Try these steps in this order:

1. Close the file

2. Open InDesign preferences > Display performance

3. Set both Typicals to High Quality

4. Uncheck Preserve Object Level Display Settings

5. Click OK

6. Re-open your file

7. Sometimes InDesign stubbornly ignores these global settings and a right-click of the problem graphic might reveal something under Display Performance.

Further advice:

Don't copy n paste from Illy; it is better to PLACE an Illustrator .ai file. If you feel you must copynpaste, go to Illy preferences  > File Handling > Clipboard. Turn off Include SVG Code. Turn ON AICB and either preserve paths or preserve appearance and overprints, if you are making more complex drawing.

Don't use the aged, creaky EPS filetype anymore. It cannot transparency blend mode. It cannot support live effects like drop shadows. Save stuff as .AI or .PDF from Illustrator.

Oh, and make sure your links are good in the Links panel.

Mike Witherell

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Hurrayyy

It was the handling/clipboard thing

Thank you for so many good advises 😄

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Thank You all for all your good support.

What a relief

Wish you all a wonderful and inspiring week

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines