Importing Word Doc as .RTF to preserve footnote styling is slowing down inDesign

New Here ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Hello, I posted on here a while ago but still haven't received any support. I've been designing a series of publications that require footnotes, and rather than copying and pasting each footnote in manually from Microsoft Word to inDesign, I've been styling body and footnote type in Microsoft Word, saving the doc as an .RTF, and importing the .RTF file into my inDesign document. I have footnote and body type styling preferences saved in ID, and the combination of styling in word while also using my style preferences in ID has given me the best results in terms of reducing the manual changes I need to make. Still, this workflow is significantly slowing down inDesign's performance on each document to the point of making it almost impossible to work. I've tried cleaning my Adobe Cache, removing my Adobe preferences, cleaning my trash bin, making more room on my computer, removing and reinstalling ID, restarting my computer, and nothing seems to work longterm! Any ideas as to how I can get ID to a normal pace again? I've tried everything! 

TOPICS
Bug, How to, Performance, Type

Views

95

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Jan 04, 2021 Jan 04, 2021
Quote: < ...importing all footes at once by converting word documents to .rtf files. > Wow. Never heard that suggestion ever. We work with long complex Word.docx all the time and never have problems with importing them into InDesign layouts. Once in a while there's glitch, but every time we've found that the problems were user errors in the original Word document.   Also check to see if you're importing the file into InDesign or linking it. Linking keeps the live link back to the original Word f...

Likes

translate

Translate

Translate
Adobe Community Professional , Jan 04, 2021 Jan 04, 2021
But remember, when importing any text files into InDesign, choose Import Options when you select the file. This brings up an intermediary dialogue box that lets you control how the file is imported and converted into InDesign.   In your situation, you'll want to check the options to Include Footnotes and Endnotes.    

Likes

translate

Translate

Translate
Adobe Community Professional ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Question: Why are you converting the Word file to RTF? What's the reason why you're not placing/importing the native Word file (with the correctly created and styled Word footnotes) into your InDesign layout?

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs |
Books & Classes | PubCom

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Thanks for your note @Bevi Chagnon - PubCom! I'd read in one of the forum discussions that folks had more luck preserving footnote styling and importing all footes at once by converting word documents to .rtf files. Will I have better luck importing as a word .docx file? 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Quote: < ...importing all footes at once by converting word documents to .rtf files. >

Wow. Never heard that suggestion ever. We work with long complex Word.docx all the time and never have problems with importing them into InDesign layouts. Once in a while there's glitch, but every time we've found that the problems were user errors in the original Word document.

 

Also check to see if you're importing the file into InDesign or linking it. Linking keeps the live link back to the original Word file rather than importing in static text.

 

That setting is under Preferences | File Handling | Create Links When Placing Text and Spreadsheet Files.

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs |
Books & Classes | PubCom

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

But remember, when importing any text files into InDesign, choose Import Options when you select the file. This brings up an intermediary dialogue box that lets you control how the file is imported and converted into InDesign.

 

In your situation, you'll want to check the options to Include Footnotes and Endnotes.

 

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs |
Books & Classes | PubCom

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines