InDesign 16.2.1 macOS GPU problems

Explorer ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Coming from InDesign 16.1, since updating to 16.2.1 this morning the GPU document view renders 3/4 of the document window black and displays an disorted view of the pages.

 

I’m using a MacBook Pro Retina 2017 with macOS 11.3.1. Already tried the usual troubleshooting steps, like disable GPU switching, SMC und PRAM reset.

 

It is usable in CPU-mode, but not in GPU-mode. Other Applications like the current version of PhotoShop are performing GPU intensive tasks without any problems.

TOPICS
Bug, Performance

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Jul 12, 2021 Jul 12, 2021
Todays update to InDesign 16.3.2 actually fixes the problem. Thx

Likes

Translate

Translate
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I'm using a MacBook Pro 2016 with macOS 11.3.1. I run with GPU turned on all the time, and have not experienced the same GPU as you can see before. It may be the GPU on your MacBook Pro, or it could be something else.

 

Screen Shot 2021-05-11 at 3.25.54 PM.png

I'd post a bug report in the InDesign UserVoice forum with as many details as possible so the engineers can try to track your problem down:

 

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Thank you for your response.

I don’t think that the problem is my system/GPU, because I can use GPU intensive functions in PhotoShop without any problem.

I’ll visit InDesign UserVoice forum later today. 

Best, Guido

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Hi Guido,

 

Sorry to hear about your experience. Do you see this behavior with a specific file? Would it be possible for you to share screenshots for better understanding?

We'll be happy to help. Just need more information.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Thank you for your response.

This doesn’t happen with specific files. Either new or old the GPU mode stays the same.

I’m working with a NEC SpectraView Reference 272w attached to my mac, setting the external display as primary display. The MacBook Pro serves as secondary display. In system settings > battery > automatic switching of graphic modes is off.

Best, Guido

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

I'm having the same issue since updating InDesign this morning. See screenshot.

 

15" MacBook Pro mid-2015 with 16GB RAM connected to an Apple Thunderbolt display and running MacOS 10.14.6

 

The issue goes away if I switch off GPU Performance in preferences… 

 

ind.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

GPU performance has been troublesome for years. Turning it off is and has been troubleshooting tip number one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

I’m an InDesign user since version 1 and have never had trouble with GPU performance since it was introduced. This is the first time.

GPU mode is so convenient and I’m used to using it so much that working in CPU mode makes me 10–15% slower.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Hi,

We are trying to isolate this issue. Can you please add your observation for following conditions.

1) When you switch ON application frame. Are you still observing the issue ?

2) If you remove your external monitor , issue is reproducible ?

 

This will really help us in narrowing the possible issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

I’m working with application frame switched off. My dual monitor setup provides enough room for the document window and the palettes.

But, switching application frame on restores the correct display. I can scroll, zoom … and work! Even after switching application frame off the document displays correct. Only after quit and reopen the issue returns.

Removing the external monitor the issue doesn’t show up. Either with or without application frame enabled.

 

Hope this helps

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

It's the same behavior in my setup. switching application frame to ON results in a correct display. Removing the external Monitor doesn't make a difference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

Hi Sumit_Garg,

 

Thanks for your questions.

 

I never use Application Frame on any Adobe apps - it's the first thing I switch off when installing a new Adobe app! But I have switched it ON and back OFF again, just to test, and it displays the document correctly while it is open - but closing and opening the file again results in the incorrect display as previous. 

 

If I remove the external monitor, then yes, the document displays correctly on the MacBookPro screen. Similarly, if I close the MacBookPro (Shutting down the laptop screen) the document also dispalys correctly. 

 

So it seems there is an issue with running a mixture of retina and non-retina screens…?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

I have the same issue. My document renders like snow, or a TV tha is not tuned in, as in the olden days.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

I do have the same issue after updating to 16.2.1 on my Macbook Pro 15" (2017) with 10.15.7 running on it. Second screen as the main is connected (Benq 27" UHD).

When you turn off GPU-preview and work a while, then turn it back on, it works, too.
Application-frame does solve the problem also, but who actually uses this—right?

I see 16.3 beta should've fixed the issue, looking forward to it. How can such an obvious bug slip through quality control? srsly…

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

Hi

I have the same issue after updating to 16.2.1.

Macbook Pro 15" 2018 with 11.3.1.

Second screen as the main is connected (Eizo ColorEdge CS2730).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 12, 2021 Jul 12, 2021

Copy link to clipboard

Copied

Todays update to InDesign 16.3.2 actually fixes the problem.

 

Thx

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 12, 2021 Jul 12, 2021

Copy link to clipboard

Copied

Great if you can get it. Still not available in the United States as of today, July 12, 2021.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 12, 2021 Jul 12, 2021

Copy link to clipboard

Copied

LATEST

I update with 16.3.2 and it's working well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines