Highlighted

Indesign 2017 on Mac Catalina

New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

Hi all,

 

I'm trying to install InDesign 2017 on mac Catalina. The installer I found will not open as it says the "Install" needs to be updated. I take it to mean that the install package for 2017 InDesign is outdated. 

 

Is there a way around this? We need 2017 for production purposes.

 

Thanks

MacOS 10.15.x is incompatible with the 2017 version of InDesign and some of its components (including its installer).

 

Your workaround is to find a computer that is running an older version of MacOS if you really need that version of InDesign “for production.” Generally speaking, the only reason why one would absolutely need to use older versions of InDesign would be use of plug-ins that haven't yet been updated to work with the current version of InDesign.

 

 

TOPICS
How to

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Indesign 2017 on Mac Catalina

New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

Hi all,

 

I'm trying to install InDesign 2017 on mac Catalina. The installer I found will not open as it says the "Install" needs to be updated. I take it to mean that the install package for 2017 InDesign is outdated. 

 

Is there a way around this? We need 2017 for production purposes.

 

Thanks

MacOS 10.15.x is incompatible with the 2017 version of InDesign and some of its components (including its installer).

 

Your workaround is to find a computer that is running an older version of MacOS if you really need that version of InDesign “for production.” Generally speaking, the only reason why one would absolutely need to use older versions of InDesign would be use of plug-ins that haven't yet been updated to work with the current version of InDesign.

 

 

TOPICS
How to

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 24, 2020 0
Adobe Community Professional ,
Aug 24, 2020

Copy link to clipboard

Copied

I believe that InDesign CC 2017 is not supported on Catalina. Where did you get the installer? I don't think Adobe makes it available for users.

 

Why do you want to run InDesign CC 2017? You may have to find another workaround and use a more recent InDesign version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0
Adobe Employee ,
Aug 24, 2020

Copy link to clipboard

Copied

MacOS 10.15.x is incompatible with the 2017 version of InDesign and some of its components (including its installer).

 

Your workaround is to find a computer that is running an older version of MacOS if you really need that version of InDesign “for production.” Generally speaking, the only reason why one would absolutely need to use older versions of InDesign would be use of plug-ins that haven't yet been updated to work with the current version of InDesign.

 

 

- Dov Isaacs, Principal Scientist, Adobe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 0