Highlighted

InDesign 2019 v14.01 spinning beachball every few seconds

Explorer ,
Jan 25, 2019

Copy link to clipboard

Copied

When II open a file, if it's longer (say 60 pages) it spins every few seconds, hangs, and then comes back to life. Ad infinitum.

I am posting this new topic because everything I can find points to v14.00, not v14.01, and explains this exact issue. I've uninstalled all versions of InDesign, reinstalled, systematically removed other apps (Removed all Plugins, deactivated and uninstalled Extensis Suitcase Fusion, ESET Antivirus, Dattodrive sync, etc), deactivated fonts, cleansed all my links, and on and on. The only thing that seems to help is shortening the document, like whatever is taking place is looking at my whole document. Still beachballs but only for a second, and with a single page it doesn't interrupt but still doesn't feel fast.

I also ran Apples hardware test to make sure it wasn't just a broken GPU or something and everything came back positive.

To help get the obvious stuff out of the way:

1. Turned of Save Page Preview

2. Disabled all the fun font features (live preview, preview on hover, etc)

3. turned of page panel thumbnails

4. set view display to Typical and made sure those were at a normal level

System:

iMac (Retina 5K, 27-inch, Late 2015) 32GB RAM, AMD Radeon R9 M395X 4096 MB

External 30" Dell

Logitech Craft Keyboard and Mouse

Anyone have any ideas?

Adobe Community Professional
Correct answer by Bill_Silbert | Adobe Community Professional

When you uninstalled and reinstalled did you do it in the following manner?:

In the app section of your Creative Cloud desktop app click on the “V” next to the app’s (InDesign) name and choose the “Uninstall” option from the pull-down menu that appears. After you’ve run the uninstall then use the Creative Cloud Cleaner Tool Use the Creative Cloud Cleaner Tool to solve installation problems . Then reinstall the program through the Desktop app. Before you reinstall, once again trash all preference files to make sure that your install is completely clean. Then launch InDesign and see if the problem persists.

Views

6.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign 2019 v14.01 spinning beachball every few seconds

Explorer ,
Jan 25, 2019

Copy link to clipboard

Copied

When II open a file, if it's longer (say 60 pages) it spins every few seconds, hangs, and then comes back to life. Ad infinitum.

I am posting this new topic because everything I can find points to v14.00, not v14.01, and explains this exact issue. I've uninstalled all versions of InDesign, reinstalled, systematically removed other apps (Removed all Plugins, deactivated and uninstalled Extensis Suitcase Fusion, ESET Antivirus, Dattodrive sync, etc), deactivated fonts, cleansed all my links, and on and on. The only thing that seems to help is shortening the document, like whatever is taking place is looking at my whole document. Still beachballs but only for a second, and with a single page it doesn't interrupt but still doesn't feel fast.

I also ran Apples hardware test to make sure it wasn't just a broken GPU or something and everything came back positive.

To help get the obvious stuff out of the way:

1. Turned of Save Page Preview

2. Disabled all the fun font features (live preview, preview on hover, etc)

3. turned of page panel thumbnails

4. set view display to Typical and made sure those were at a normal level

System:

iMac (Retina 5K, 27-inch, Late 2015) 32GB RAM, AMD Radeon R9 M395X 4096 MB

External 30" Dell

Logitech Craft Keyboard and Mouse

Anyone have any ideas?

Adobe Community Professional
Correct answer by Bill_Silbert | Adobe Community Professional

When you uninstalled and reinstalled did you do it in the following manner?:

In the app section of your Creative Cloud desktop app click on the “V” next to the app’s (InDesign) name and choose the “Uninstall” option from the pull-down menu that appears. After you’ve run the uninstall then use the Creative Cloud Cleaner Tool Use the Creative Cloud Cleaner Tool to solve installation problems . Then reinstall the program through the Desktop app. Before you reinstall, once again trash all preference files to make sure that your install is completely clean. Then launch InDesign and see if the problem persists.

Views

6.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 25, 2019 1
Adobe Community Professional ,
Jan 25, 2019

Copy link to clipboard

Copied

Are you working across a network or on a cloud drive rather than locally on your hard drive? If you are on some kind of network or server try disconnecting from it and see if you still have a problem. If you are on a network speak to your network administrator to make sure that all network software has been updated to be compatible with your version of InDesign and also your version of the Mac OS (you did not say what version of the OS you are running).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2019 2
Explorer ,
Jan 26, 2019

Copy link to clipboard

Copied

10.13 and no, not over a network. Over a network is how we typically work but that was another step in testing to deal with local files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2019 0
Adobe Community Professional ,
Jan 26, 2019

Copy link to clipboard

Copied

Two other things you should probably check.

If you're using High Quality Display Performance, you should try switching to Typical Display (View > Display Performance > Typical Display) especially if there are lots of complex images.

If you're using a Preflight Profile, turn off Preflight in the Preflight panel (Window > Output > Preflight).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2019 1
Explorer ,
Jan 26, 2019

Copy link to clipboard

Copied

Understood. Definitely made sure both of those were unchecked Before posting. I appreciate the help! This isn’t my first rodeo when it comes to troubleshooting Adobe product issues but I am stumped on this one. It’s also holding me back from implementing the new InDesign to my tram and I’m hoping it’s as simple as a setting or a future update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2019 0
Adobe Community Professional ,
Jan 26, 2019

Copy link to clipboard

Copied

When you uninstalled, did you make sure to Remove Preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2019 0
Explorer ,
Jan 26, 2019

Copy link to clipboard

Copied

Yes I did. I also did the reset on launch, and have uninstalled all InDesign and reinstalled only the latest 2019 after confirming all OS updated were complete.  Essentially hoping anything that needed to be resolved was updated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2019 0
Adobe Community Professional ,
Jan 26, 2019

Copy link to clipboard

Copied

When you uninstalled and reinstalled did you do it in the following manner?:

In the app section of your Creative Cloud desktop app click on the “V” next to the app’s (InDesign) name and choose the “Uninstall” option from the pull-down menu that appears. After you’ve run the uninstall then use the Creative Cloud Cleaner Tool Use the Creative Cloud Cleaner Tool to solve installation problems . Then reinstall the program through the Desktop app. Before you reinstall, once again trash all preference files to make sure that your install is completely clean. Then launch InDesign and see if the problem persists.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2019 1
Explorer ,
Feb 14, 2019

Copy link to clipboard

Copied

Bill, thanks. I am still fighting this issue. I had the opportunity to purchase a new mahcine so I decided to wait it out. Welp, back at it again with the latest non-Pro iMac and it's still doing it.

Though the issue seems the same, I want to blame fonts. I came into this with a clean install on a new machine, and it still stalls out every few seconds, for a few seconds.

So, I appreciate everyone's assistance but it's disappointing  someone decide to mark it as solved. I am sure there are many others out there who just went back to an old version out of frustration.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 2
Adobe Community Professional ,
Feb 14, 2019

Copy link to clipboard

Copied

Being that you're installing InDesign on a brand new Mac and still having the same problem, there must be something else that you're installing that is causing the issue.

If you reinstalled Suitcase, try checking for type conflicts and other type issues: Resolving problems

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0
Explorer ,
Feb 15, 2019

Copy link to clipboard

Copied

Thanks Jeff, I'll continue my hunt. I tried this before installing anything but Microsoft and Adobe products

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 0
New Here ,
Feb 20, 2019

Copy link to clipboard

Copied

Update:

I solved the beachball problem!!!

I went through every image in my document and reduced it's size to the smallest possible while still being "high res" .

It seems my problem was more the video rendering all the huge images. Now there is no problem.

My hardware is a MacMini (late 2012)

Hope this helps you

LMK

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 1
Explorer ,
Feb 21, 2019

Copy link to clipboard

Copied

Martyhz, thanks for your feedback! Did not help me sadly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2019 0
New Here ,
Feb 14, 2019

Copy link to clipboard

Copied

Same issue here. Posted the very same topic about a week ago. The only reply/response was concerning what hardware I was utilizing.

After much research I have narrowed my problem down to Universal Type Client 7.0.1. When Universal type client is completely disabled via stopping Type Core the spinning Beach Ball disappears completely.

The problem is most of my client's fonts are loaded on it and most do not resubmit fonts when printing new jobs. InDesign cc19 14.0.1 works great when fonts are loaded into the apps fonts folder on my desktop!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2019 0
Explorer ,
Feb 15, 2019

Copy link to clipboard

Copied

Thanks for the info! I had an Extensis product (Fusion for teams) and that was one of my early checks. When I had the issue at 14.0 I went through the same troubleshooting only to find Adobe updated InDesign to resolve with 14.01. But then it returned. I've since moved to Fontbase.

I am almost certain it's font related, but I can't figure out why. It's the same fonts we've used for years.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2019 1
Community Beginner ,
Apr 03, 2019

Copy link to clipboard

Copied

I think it's font related too. I'll be working along just fine and then Indesign will start constant beach ball on every move I make. I'm using Suitcase Fusion v20.0.3 (the latest) and the only way I can get Indesign working back a normal, responsive speed. Is to clear the font cache in Suitcase Fusion and restart my computer. Just closing Indesign and reopening it, doesn't make any difference. I also tried just restarting my computer, and that doesn't always work. The clearing of the font cache does.

No the big question: is it Suitcase Fusion causing all of this or is it something to do with fonts in general. Any advice from anyone?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2019 0
Explorer ,
Apr 03, 2019

Copy link to clipboard

Copied

Hey there,

So I know for a fact it's fonts, not a particular font but something about how InDesign handles fonts. I uninstalled and reinstalled Suitcase several times and in the end cancelled my subscription and now use Fontbase.

You can avoid the beachball problem by converting ALL fonts to a single one (using the Find Font dialog (make sure "Redefine Style" is checked). I'd tested this on a few problem documents and have always had success. Sadly it's not a real solution. I will add that I've mainly had this issue with EasyCatalog documents (I do not have EasyCatalog installed currently but the invisible characters are still present in the text frames). The length of the document is also key (typically I see this problem with 60+ page catalog files, but not with a 26 page magazine file).

I just updated to InDesign 2019 14.0.2 in the hopes one of the "fixes crashing..." notes would apply to me, but, alas, still does the same thing, same useless workaround applies but not a real world solution.

SO disappointing. Hope something here helps you, otherwise, ball continues to be in Adobes court. They changed SOMETHING and my hope is they'll fix it so we can use software newer than 2014 in exchange for our incredibly expensive subscription.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2019 1
Most Valuable Participant ,
Apr 03, 2019

Copy link to clipboard

Copied

What operating system?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2019 0
Explorer ,
Apr 03, 2019

Copy link to clipboard

Copied

HI Bob, I am currently on Mojave after purchasing a new machine (iMac 5k 2017), but the problem exists in the same form under High Sierra on my previous machine (iMac 5k 2015).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2019 0
Most Valuable Participant ,
Apr 03, 2019

Copy link to clipboard

Copied

Turn of GPU Performance and disable and third party plugins.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2019 0
Explorer ,
Apr 03, 2019

Copy link to clipboard

Copied

Hi Bob, I did try this first thing and it did not affect anything positively. I've completely crippled InDesign and nothing has any effect except changing all fonts to a single one. No plugins are installed at this time so there's nothing to disable.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2019 0
New Here ,
Apr 04, 2019

Copy link to clipboard

Copied

I'm frustrated that this thread is marked as answered as well, because it is a big problem and it's not been solved. At my office, any file over 2 pages is beachball nightmare to work in.

I just wanted to thank you for all your hard work tearing this down. I too thought it was font issue but can't find any way to fix it. 

C'mon Adobe, help us out!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 2
Explorer ,
Apr 04, 2019

Copy link to clipboard

Copied

Thank you for the comment Michelle, I'm sorry you're going through a similar issue. You don't use EasyCatalog do you? I've seen so many posts throughout various forums it's hard to believe Adobe isn't paying attention, but my heart sank when the new 14.0.2 InDesign update came and the problem was still there...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 0
Most Valuable Participant ,
Apr 04, 2019

Copy link to clipboard

Copied

Every issue is different and saying you have the same problem is not going to help.

My suggestion if you want help is to start a new thread with full system specifications including the full build of InDesign, full build of your operating system, processor, RAM and type of harddrive (SSD vs mechanical HD).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 0
New Here ,
Apr 04, 2019

Copy link to clipboard

Copied

No, we don't use Easy Catalog.

My only other guess was just how old our catalog files in InDesign are. We keep updating and resaving year to year, maybe there's something still in it from the original structure that is causing problems with the newer software. We haven't had time to rebuild anything yet though.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 0
Adobe Community Professional ,
Apr 04, 2019

Copy link to clipboard

Copied

A good way to rebuild your old files is to save them as IDML (which is an XML format) with links to original graphics. Then reopening the IDML creates a completely clean version to start fresh. I would observe the results carefully but there's no absolute guarantee it's 100% the same but it should produce a much faster file, I'm guessing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 0
Explorer ,
Apr 04, 2019

Copy link to clipboard

Copied

Bob, first off, I really appreciate your time and commitment to this forum. You are always helpful and have a great depth of knowledge.

However, from the users side, this issue has been the single most frustrating issue I have ever encountered, and I see traces of it throughout so many places that I wouldn't blame users or expect every solution is different. They come here looking for answers, as I did so many times, and when they see a similar issue that mirrors their own experience they want to learn if there is a solution.

So, while you advice is accurate and sound, it's a lot of work to go down the path you suggest to find out that it's just the same oddball issue with no solution. It can be debilitating. I've gone through so many setups, on two different of my own machines, only to have all my users go back to the last known working version of InDesign. It's a lot of time and budget spent with Adobe in the blame corner for making a change that's affecting so many people who pay them monthly.

I'll end with reiterating how much people like you (and Steve) help people out but sometimes it's Adobe's fault and we all have to wait around until they decide to fix it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 1
Explorer ,
Apr 04, 2019

Copy link to clipboard

Copied

This is great info, and works sometimes, however I've tried this many times with no success for this particular problem.

The main thing that doesn't come over (for me) is objects with gradient transparency effects. Otherwise it's a pretty awesome way to "clean up" a file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 04, 2019 0
Community Beginner ,
Jan 10, 2020

Copy link to clipboard

Copied

Fonts and other issues are valid concerns here - but the elephant in the room is that InDesign is only utilizing one processor core at a time, which means its never actually using the available power of any computer released in the last decade. Unfortunately I learned this AFTER assuming that it was my older mac causing the issue and my company spent nearly twenty thousand dollars on a 2020 mac pro with 28 cores - and indesign runs every bit as slow there as it did on the old machine it replaced. Beachballs and load bars all day.

 

Obviously frustrated I installed a CPU monitor software and saw first hand that despite a load bar estimating a 12 minute wait to sunchronize settings across my 264pg catalog, the cpu was never more than 3% engaged, and only ever one core at a time.

 

The frustration I'm dealing with is tantamout to betting on a high stakes race event and then watching driver I bet on get out and push his 700 horsepower race car around the track as I sit helplessly in the stands screaming WHYYYY dont you use all the power thats RIGHT THERE!!???

 

Actively looking for alternatives to the Adobe platform.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2020 0
New Here ,
Feb 20, 2019

Copy link to clipboard

Copied

I have the same problem with a brochure. I found a few tricks that alleviated it:

1. I opened a different file and noticed the beachball problem was not happening there. when i went back to the problem file the beachball issue temporarily was gone.

2. in my problem file I went to the VIEW menu item and pulled down to DISPLAY PERFORMANCE> High Quality. counterintuitive I know but the beachball issue was gone for 10 minutes...again only temporarily

My file has lots of images that are way too large. I will reduce them all and see if that helps.

I also made a separate font folder with document fonts and turned off all open fonts in Suitcase fusion except those used by the document. no luck

Since i have an InDesign file that does not have the beachball issue my next step will be to build a new file from scratch and paste all the items into it to see if the problem file somehow is corrupt.

Hope this helps

ps. beachball is a euphemism..... should be called the hypnotic productivity-killing rainbow orb of paralysis, LOL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0