Highlighted

InDesign 2020 performance issues on macOS Catalina

Community Beginner ,
May 04, 2020

Copy link to clipboard

Copied

Hi community

 

Am getting constant spinning wheel issues with InDesign only.
Mac OS is Catalina 10.15.4
InDesign 15.0.2

MacBook Pro 2019

 

Spinning wheel appears every few seconds or so, lasting 20-40 seconds each time. InDesign is basically unusable.

 

I tried various suggestions from these pages:

• Removed preferences and cache

• Resaved a doc as IDML

• Changed font in doc to Times New Roman. Disabled all fonts except system ones. Removed all Adobe Fonts.

• Uninstalled InDesign without keeping prefs, then re-installed.

• In new install turned off GPU Preformance, Preflight checking, set Display to Typical, no page thumbnails. 

 

None of those helped. Then I stumbled across that turning WiFi off on my Mac will fix the problem. InDesign then runs normally with no hanging. If I then turn WiFi on again it will run properly for a few minutes, then the spinning ball comes back. When spinning wheel is showing, InDesign in Activity Monitor shows red and "Not Responding", until it clears 30 or so seconds later. Only switching WiFi off again will clear it.

 

Obviously I can't work long-term without WiFi on. Does anyone have any idea why this might be happening and any possible solutions?

Hi all,

 

We're sorry to hear about this. We are currently investigating this issue and need your help in this. I would request if you could try following these steps one by one and share your observations:

 

1. Close all Adobe applications.

 

2. Make sure InDesign is updated to version 15.0.3.

 

3. Change display color profile to Apple RGB (https://support.apple.com/en-in/guide/mac-help/mchlf3ddc60d/mac).

 

4. If that doesn't help, try booting the system into Safe Mode (https://helpx.adobe.com/in/x-productkb/global/start-safe-boot-mode-mac.html) and check how it works there. It starts your system so that it performs certain checks and prevents third party software/ services from automatically loading or opening. If it works fine in Safe mode, then there is some third party service or application like antivirus, plugins or web extensions which are conflicting with the InDesign. 

 

5. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: 

  • Go to Terminal (Go Utilities Terminal.app) 
  • Execute the following command on terminal to provide permission: 
    • sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Application Support 

 

Looking forward to your response!

 

Regards,

Srishti

TOPICS
Performance

Views

573

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign 2020 performance issues on macOS Catalina

Community Beginner ,
May 04, 2020

Copy link to clipboard

Copied

Hi community

 

Am getting constant spinning wheel issues with InDesign only.
Mac OS is Catalina 10.15.4
InDesign 15.0.2

MacBook Pro 2019

 

Spinning wheel appears every few seconds or so, lasting 20-40 seconds each time. InDesign is basically unusable.

 

I tried various suggestions from these pages:

• Removed preferences and cache

• Resaved a doc as IDML

• Changed font in doc to Times New Roman. Disabled all fonts except system ones. Removed all Adobe Fonts.

• Uninstalled InDesign without keeping prefs, then re-installed.

• In new install turned off GPU Preformance, Preflight checking, set Display to Typical, no page thumbnails. 

 

None of those helped. Then I stumbled across that turning WiFi off on my Mac will fix the problem. InDesign then runs normally with no hanging. If I then turn WiFi on again it will run properly for a few minutes, then the spinning ball comes back. When spinning wheel is showing, InDesign in Activity Monitor shows red and "Not Responding", until it clears 30 or so seconds later. Only switching WiFi off again will clear it.

 

Obviously I can't work long-term without WiFi on. Does anyone have any idea why this might be happening and any possible solutions?

Hi all,

 

We're sorry to hear about this. We are currently investigating this issue and need your help in this. I would request if you could try following these steps one by one and share your observations:

 

1. Close all Adobe applications.

 

2. Make sure InDesign is updated to version 15.0.3.

 

3. Change display color profile to Apple RGB (https://support.apple.com/en-in/guide/mac-help/mchlf3ddc60d/mac).

 

4. If that doesn't help, try booting the system into Safe Mode (https://helpx.adobe.com/in/x-productkb/global/start-safe-boot-mode-mac.html) and check how it works there. It starts your system so that it performs certain checks and prevents third party software/ services from automatically loading or opening. If it works fine in Safe mode, then there is some third party service or application like antivirus, plugins or web extensions which are conflicting with the InDesign. 

 

5. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: 

  • Go to Terminal (Go Utilities Terminal.app) 
  • Execute the following command on terminal to provide permission: 
    • sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Application Support 

 

Looking forward to your response!

 

Regards,

Srishti

TOPICS
Performance

Views

574

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 04, 2020 0
Community Beginner ,
May 04, 2020

Copy link to clipboard

Copied

Same issues here, as well as crashing when copying and pasting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2020 0
New Here ,
Jun 10, 2020

Copy link to clipboard

Copied

Did you ever get an answer for this? Of possibly find a fix yourself? Having the same issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Community Beginner ,
Jun 11, 2020

Copy link to clipboard

Copied

No, other than the two that just appeared below. Turning off wifi while I work seems to be the only thing that truly fixes it. I'll check the below and report back.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2020 0
Adobe Community Professional ,
Jun 10, 2020

Copy link to clipboard

Copied

I can't necessarily answer why, but I can offer some things to consider that may help.

 

1) Turn off your CC Library. Creative Cloud lets you save/share things like graphics, color swatches and even paragraph/character styles. Anytime you ask for resources shared on both your system and the cloud — or anytime InDesign even thinks you may want access to resources shared to the cloud — it makes a quick check over the internet to Creative Cloud servers.

2) Substitute your cloud-sourced Adobe Fonts. It's cool that Adobe offers all those spiffy fonts, but anytime you access those fonts — calling for your system to access them when opening an InDesign document/template/book file, incorporating them into paragraph/character styles, applying them to placed copy, typing directly into InDesign (a big resource ask), save/print the document — your system is "phoning home" to Adobe servers to reference those fonts. It even references the Adobe Fonts when packaging your documents, just to make note not to include them into the package's Fonts folder. Whenever remotely possible (pun not intended), be sure to use resident fonts in your documents.

 

Those are two big resource draws when working with InDesign documents. Cutting them out of the picture may help stabilize your InDesign application. Hopefully this'll help keep your InDesign application from crashing on the fly ...

 

Randy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Community Beginner ,
Jun 11, 2020

Copy link to clipboard

Copied

Thank you Randy. I'd already removed Adobe Fonts and just worked with local fonts, which didn't seem to help, but I will try the Library idea. I did assume it was connecting for some third party reason and both of those seem good starting points.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2020 0
Adobe Community Professional ,
Jun 11, 2020

Copy link to clipboard

Copied

My pleasure.

 

FWIW, I've set both restrictions for myself when it comes to working with InDesign — and have for a while.

 

One more thing to note: pay close attention when creating new swatches and/or paragraph/character styles. There are options in the dialog boxes when you create new styles/swatches which are set, by default, to store those new properties in CC Libraries. Fail to uncheck those default check boxes before clicking the OK button and you'll re-open the CC Libraries within InDesign, in the background, and not know what you've done until you open any Library panel and see it's popped up again.

 

Good luck,

 

Randy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi all,

 

We're sorry to hear about this. We are currently investigating this issue and need your help in this. I would request if you could try following these steps one by one and share your observations:

 

1. Close all Adobe applications.

 

2. Make sure InDesign is updated to version 15.0.3.

 

3. Change display color profile to Apple RGB (https://support.apple.com/en-in/guide/mac-help/mchlf3ddc60d/mac).

 

4. If that doesn't help, try booting the system into Safe Mode (https://helpx.adobe.com/in/x-productkb/global/start-safe-boot-mode-mac.html) and check how it works there. It starts your system so that it performs certain checks and prevents third party software/ services from automatically loading or opening. If it works fine in Safe mode, then there is some third party service or application like antivirus, plugins or web extensions which are conflicting with the InDesign. 

 

5. If that doesn't help either, login to root account (https://support.apple.com/en-in/HT204012). Check how application works there. If it works fine there, then it could be related to permission errors. Follow these steps to repair permission errors: 

  • Go to Terminal (Go Utilities Terminal.app) 
  • Execute the following command on terminal to provide permission: 
    • sudo chmod -R 777 /Users/<user>/Library/Preferences/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Caches/Adobe InDesign 
    • sudo chmod -R 777 /Users/<user>/Library/Application Support 

 

Looking forward to your response!

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Community Beginner ,
Jun 12, 2020

Copy link to clipboard

Copied

Hi Srishti

 

I've finished current InDesign project and am now working on website projects, so hard to test this right now.

 

The next time, hopefully soon, I'm back working in InDesign, and if the problem is still present, I'll run through the steps you have indicated above, and post here what happens.

 

Thanks for responding.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2020 0
Participant ,
Aug 03, 2020

Copy link to clipboard

Copied

Hi there,

 

I'm experiencing spinning wheel issues since years no matter if I reinstall everything, change hardware and clean install. There might be a lot of different issues in InDesign ending up with spinning wheel.

 

Open Activity monitor and check if you see one or more (usually more) tasks named CEPHtmlEngine. Force quit those tasks all together (not the "helper") and quickly go back to ID and check if it's back to normal speed. Be aware that those tasks will be reopened automatically afted a very short amount of time, but you might have time to check whether they are the cause of ID spinning wheels.

 

If this is the case that's a a very BAD and possibly not endorsed by Adobe method to solve (on MAC):

 

- quit InDesign

- go to Applications folder and find your InDesign app icon (no, not in the dock!)

- right click and select "show package content"

- navigate to Contents/MacOS/CEP/CEPHtmlEngine folder

- RENAME CEPHtmlEngine file to something easy to revert like "CEPHtmlEngine_" (need to enter your Mac admin pw)

- restart InDesign.

 

Process won't start again, be aware you WILL LOSE some features like the home page, the "new" new document window, and some icons in page layout (lock, link warnings etc) but InDesign should work basically great anyway. Remember you can set preferences to use the "legacy" new document window and it will open, as it does not contains any HTML related UI.

 

- When you need to go back to your normal operation or miss something in the UI you need, just rename back the file to the original name

 

Yes it's terrible, I know, but it really works for me, while I wait (since years) for a solution from Adobe.

 

Take care and let me know.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 03, 2020 0