InDesign 2020 Slow performance on new MacBook Pro 2019

New Here ,
Nov 07, 2019

Copy link to clipboard

Copied

Since 2 weeks I have a new macbook pro. It's the latest version. I also installed the latest InDesign 2020. 

When I open a new file, the program is getting slow imediatly. My mouse is fallowing much later then the movement. As soon as my mouse is over the boarder of the InDesign screen it is fast again. All other Adobe programs run super fast. I tried re-installing InDesign. That didn't work. My display performance is set to 'normal'. This worked for a few hours but now it's slow again. The file I am working in is also not big at all. Like I said earlier, it even does this with a new and empty file.

 

I hope someone can help me with this! 

 

{Renamed By MOD}

TOPICS
Performance

Views

1.3K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Nov 07, 2019

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble you are facing with InDesign slow performance. Can you try resetting the preferences for InDesign by following the steps below:

 

  • Close all Adobe applications 
  • Go to Locations:  
  • ~/Library/Caches 
  • ~/Library/Preferences 
  • Rename Adobe InDesign and com.adobe.indesign to Adobe InDesign.old and com.adobe.indesign.old 
  • Launch InDesign from the CC 

 

Disclaimer: Please note that resetting preferences will remove all the custom settings and InDesign will launch with default settings. This way all your old settings will be saved in .old folders and InDesign will recreate new folders with default settings.  

Let us know if it works or you need any further assistance.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Mar 09, 2020

Copy link to clipboard

Copied

Thks! It has worked for me!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 02, 2020

Copy link to clipboard

Copied

How would I do this on a PC?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Dec 05, 2020

Copy link to clipboard

Copied

Yes, I had the same experience and it is a brand new Macbook pro with 6 cores! And InDesign worked fine till I had 12 pages of contents for a magazine layout and even if you simply zoom in or out, that rainbow circle (processing....) keeps popping up like crazy. This is very disappointing. Why does InDesign uses so much RAM or Memory? 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 06, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about this. Would you mind sharing version of the OS & InDesign? Did you see this behavior with a specific file or all?

This information would help us assist you accordingly. Looking forward to your response.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
EALS LATEST
Explorer ,
Dec 06, 2020

Copy link to clipboard

Copied

Hi Ashutosh,

 

Mine set up: mackbook pro (15" 2019 2,4 GHz i9, 32GB, 1TB (500M free)) running OS 10.15.3.

 

My best

edo

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more