Highlighted

InDesign 2020 Slow Performance

Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Hi,

 

I've been having problems with inDesign for the past few months. Everything is a second or so behind... Everytime I move an image or or text box there is a lag of around half a second. The hand tool and zoom tool are also extremely jumpy. I'm aslo getting a spinning wheel for very simple tasks.

 

This problem seemed to come out of no-where, I have a very powerful machine (spec below) and have other users in the studio running the same version of indesign with no problems at all.

 

{Renamed By MOD}

I've tried the following:

 

  • Working offline
  • Restarting in safe mode
  • Reinstalling software
  • Turning anti virus off

 

Any help would be greatly appreciated as neither myself or our IT support can figure this out

 

Cheers

 

Liam

 

Processor - 3.7 GHz Quad-Core Intel Xeon E5

Memory - 64 GB 1866 MHz DDR3

Graphics - MD FirePro D300 2 GB

 

Indesign 2020 - 15.01

 

 

 

Correct answer by ._Liam_. | Community Beginner

Morning all,

 

Thanks for all of your replys over the last year. I finally found a solution to this problem!

 

After reading through the comments, I noticed a few people had success changing the colour profile from their monitor to Apple RGB or Colour LCD. This didnt work for me when I initially tried it, but after trying out a few more colour options today I found one that works (sRGB IEC61966-2.1). Changing to this colour setting (in preferences/Display) instantly changed inDesign from being laggy and jumpy to smooth and responsive.

 

FYI Im using a Mac Pro with an LG ultra fine display.

 

Thank again


Liam

TOPICS
Performance

Views

6.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign 2020 Slow Performance

Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Hi,

 

I've been having problems with inDesign for the past few months. Everything is a second or so behind... Everytime I move an image or or text box there is a lag of around half a second. The hand tool and zoom tool are also extremely jumpy. I'm aslo getting a spinning wheel for very simple tasks.

 

This problem seemed to come out of no-where, I have a very powerful machine (spec below) and have other users in the studio running the same version of indesign with no problems at all.

 

{Renamed By MOD}

I've tried the following:

 

  • Working offline
  • Restarting in safe mode
  • Reinstalling software
  • Turning anti virus off

 

Any help would be greatly appreciated as neither myself or our IT support can figure this out

 

Cheers

 

Liam

 

Processor - 3.7 GHz Quad-Core Intel Xeon E5

Memory - 64 GB 1866 MHz DDR3

Graphics - MD FirePro D300 2 GB

 

Indesign 2020 - 15.01

 

 

 

Correct answer by ._Liam_. | Community Beginner

Morning all,

 

Thanks for all of your replys over the last year. I finally found a solution to this problem!

 

After reading through the comments, I noticed a few people had success changing the colour profile from their monitor to Apple RGB or Colour LCD. This didnt work for me when I initially tried it, but after trying out a few more colour options today I found one that works (sRGB IEC61966-2.1). Changing to this colour setting (in preferences/Display) instantly changed inDesign from being laggy and jumpy to smooth and responsive.

 

FYI Im using a Mac Pro with an LG ultra fine display.

 

Thank again


Liam

TOPICS
Performance

Views

6.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 16, 2020 2
Adobe Community Professional ,
Jan 16, 2020

Copy link to clipboard

Copied

Have you tried resetting the InDesign preferences ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Adobe Community Professional ,
Jan 16, 2020

Copy link to clipboard

Copied

Are you using a third-party plug-in such as a font manager?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Hi Derek,

 

Thanks for getting back to me. Yes tried resetting the preferences, and I only use the defualt font book - no other programmes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Adobe Employee ,
Jan 16, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble you are facing with InDesign. I would request if you can share a few more details like:

 

  1. The exact version of the Operating System.
  2. Is this happening on a specific file?
  3. Was there an improvement in safe mode?
  4. Where are the files saved, locally or on a network drive or shared drive?

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Hi Rishab,

 

Thanks for your help. Details below:

 

  1. The exact version of the Operating System.
    macOS Catalina 10.5.2(19C57)
  2. Is this happening on a specific file?
    No all files
  3. Was there an improvement in safe mode?
    No
  4. Where are the files saved, locally or on a network drive or shared drive?
    I do work of a server some of the time, however this issue happens when offline or even when creating a new file.

 

I hope this helps, I look forward to your response

Cheers


Liam

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Adobe Employee ,
Jan 16, 2020

Copy link to clipboard

Copied

Thanks for sharing the details. Could you please turn off the GPU performance from the preferences and observe the application performance and let us know how it goes. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Community Beginner ,
Jan 16, 2020

Copy link to clipboard

Copied

Hi Risha,

That didnt help unfortunately, it may have even made it worse. Turning that off would also take away the animated zoom which I use alot


Cheers

Liam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Community Beginner ,
Mar 11, 2020

Copy link to clipboard

Copied

Did you ever get anywhere with this?

 

Our organisation has just moved over from CC2018 to CC2020 and it is slower – like you say there is a lag and sometimes the wheel spins for an annoying amount of time. I know that these same files didn't struggle for CC18

Matt

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 11, 2020 2
Adobe Community Professional ,
Jan 16, 2020

Copy link to clipboard

Copied

Maybe try this:

Unistall InDesign, using the drop-down menu in the Creative Cloud app, and reinstall InDesign again. If that doesn't  solve the problem then unistall it once again and then run Adobe Cleaner before reinstalling InDesign again.

Here's a link to Cleaner: https://helpx.adobe.com/uk/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 16, 2020 0
Contributor ,
Jan 21, 2020

Copy link to clipboard

Copied

Absolutely the same issue for me and I've posted about it in the past. Not the same hardware setup (48Gb RAM; Mac Pro 5,1; 12 core; RX 580 8Gb; m.2 SSD drive). 

 

I THINK it has to do with 4K monitors, because I can move the InDesign window to the 2K monitor above my 4K and InDesign is slick and fast.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 21, 2020 0
Community Beginner ,
Apr 20, 2020

Copy link to clipboard

Copied

UNBELIEVABLE. So ihave to switch to 2k on my 4k monitor everytime I use InDesign so that my workflow doesn't grind to a halt? I just changed resolution after dealing with insane slowdowns, went to 2k from 4k, and everything is lightning fast. Adobe, please get your act together, This is crazy!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2020 2
Contributor ,
Apr 25, 2020

Copy link to clipboard

Copied

What fixed my issue was changing the color setting in System Preferences > Displays > Color and changed the default that my 4K monitor supplied to Apple RGB. 

 

AND INSTANTLY five months of terror was fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2020 1
Community Beginner ,
May 18, 2020

Copy link to clipboard

Copied

Hi Jeff, do you know how I can change this colour setting on PC or if that is even possible? I am running Windows 10.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2020 0
Contributor ,
May 18, 2020

Copy link to clipboard

Copied

I don't but I know two people, one from this forum, that said it did the trick. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2020 1
Contributor ,
May 18, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2020 1
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

Snap! Same issue, color settings in Indesign File > Colour Settings set it to monitor color and Working spaces RGB: Monitor RGB - sRGB IEC61966-2.1

Also added colour profile to my monitor under colour management within the graphics card.... 

My high spec machine was also not the problem.
When the app lags even fractionally one can notice a dent in your performance. Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

UI Scaling... this is causing the slow sluggish demon. Switch it off, you can't see the icons on 4K monitors. Switch to 2K and turn UI off... back to normal speeds... 😞 Adobe? solutions?

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Community Beginner ,
Jun 18, 2020

Copy link to clipboard

Copied

@Realimagine I ended up finding a solution for my lagging which is worth a try but may not be the same thing. If you're working from packaged InDesign folder, try deleting the document fonts folder inside it. Lagging was caused because of a double up in fonts on my computer. This took a month of testing by myelf and IT team to finally figure out!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 3
Adobe Community Professional ,
Jun 19, 2020

Copy link to clipboard

Copied

Yes, same: opening from a packaged document gave us a clue: those are always lagging after opening. Remove the Documents folder (if needed, place those fonts in the system) and gone is the Text lag. I reported this to Adobe many times now. They simply ignore it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2020 2
New Here ,
Jul 02, 2020

Copy link to clipboard

Copied

This is the exact same bug we had with InDesign CS6 with the initial release. Now the June 2020 release has the same problem.

 

All of our users (Windows 10) on different models of desktops and laptops have experienced this problem. Renaming the Document Fonts folder to just Fonts (or deleting it entirely) fixes the issue for now. Adobe needs to fix this.

 

WIth one file open, the problem happens but is not severe. With two files open (even if they are single page documents), InDesign can hang for 10 seconds to over 3 minutes whenever anything is done (click a menu, select an object, etc.) 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 1
New Here ,
Jul 09, 2020

Copy link to clipboard

Copied

Holy crap - I can't even begin to believe that this is what has been causing the issue for me. Tried everything - deleting prefs, changing color profile to sRGB (which seemed to kinda help, but still was getting lag) so finally came across this post and BOOM, no lag whatsoever. Thank you for taking the time to post this solution because I was literally minutes away from giving up. 

 

For context, I just got a Microsoft Surface Studio 2 literally less than 2 months ago and hadn't experienced any issues until today. Up until today, I had opened up to 4 INDD files (none under 75 pages) at once and experienced no issues until today when for the first time I opened not one but two package files and boy was it a shiz-show. I would have to wait sometimes up to 10 seconds when clicking between the two projects and I knew something was just not right... not on this fresh of an install. 

 

Anyway, thank you guys again for keeping me from setting my new computer ablaze.

 

Why the hell hasn't adobe come up with a fix for this issue? Pretty crazy that something so simple could turn my computer in to a bowl of peanutbutter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2020 1
New Here ,
Aug 24, 2020

Copy link to clipboard

Copied

PROBLEM SOLVED: I DELETED THE "FONT FOLDER" FROM THE DOCUMENT FOLDER (THIS IS CRAZY !!!)

I'm a graphic designer and I've been using InDesign since the first version and I've never had any problems with this program until CC2020. I have been wasting time and unnecessary energy for months trying to understand the Indesign slowdown. It slows down to me when I use multiple files together to work in multillanguages (which is normal for me) specifically with the copy and paste between files (tool text); two open files are enough to cause enormous discomfort that has afflicted me.
So THANK YOU, THANK YOU and THANK YOU again to Kate_Bee, I never thought that deleting the Fonts folder could make Indesign come back as it should !!!
But I wonder: but why ???? why does adobe not solve this big problem? for us graphic designers who work on times it is not possible to slow down for this.
Good job everyone!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2020 2
Community Beginner ,
Aug 25, 2020

Copy link to clipboard

Copied

That is so crazy that switching from 4k to 2k solved the problem!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2020 0
New Here ,
Aug 27, 2020

Copy link to clipboard

Copied

Taking the fonts out of the documents folder and deleting the empty folder has fixed the problem I've been fighting for months. We shouldn't have to do this with every package!

We all pay quite a bit for Adobe software and it seems like Adobe should have fixed a problem that has been going on for many months causing headaches and loss of productivity to so many people!

I was having some problems with Acrobat DC crashing for a while, especially when packaging in InDesign. For the most part, that problem seems to have been fixed, but I'm not positive it's fixed completely. It seems like I still have problems with Acrobat DC occasionally.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 27, 2020 1