Indesign 2021 will act as if I have closed a document

Community Beginner ,
Dec 26, 2020 Dec 26, 2020

Copy link to clipboard

Copied

Mac version

16.01

Recently, Indesign will allow me to either open or vreate a new file. However within about 30 seconds, I will get the save changes before closing dialogue box. I have reset the preferences, downgraded to an older version, checked for font conflicts, switched to legacy open document format, removed and reinstalled Indesign and Creative cloud. Nothing works! Photoshop and Illustrator are fine, I am completely lost. Help please

TOPICS
Bug, Performance

Views

202

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

Which version of the OS?

How much RAM and spare disk capacity do you have?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

Sorry forgot to mention that

Installed Ram 40 Gb

Disk is 1Tb woth 500Gb free

OS is Big Sur 11.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

Try resetting your InDesign preferences:

1) Close InDesign
2) Double click on Adobe InDesign's icon to launch it
3) QUICKLY hold down Ctrl+Alt+Shift. (for Windows) or CTL+OPT+CMD+Shift (for Mac OS X)
4) When a dialog appears, ask you “Delete InDesign Preference Files?” Click Yes.

(If you don't see the question do it again.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

Hi Derek,

I did that multiple times, still the same result

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 27, 2020 Dec 27, 2020

Copy link to clipboard

Copied

I assume you haven't a third-partyplug-in installed such as a font manager that mighty cause a conflict?

I suggest you unistall InDesign, using the drop-down menu in the Creative Cloud app, and reinstall it again. If that doesn't solve the problem then unistall it once again and then run Adobe Cleaner before reinstalling InDesign again.

https://helpx.adobe.com/uk/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

No its a fresh install with no additional plugins. I uninstalled creative cloud and all apps completely, used the cleaner tool and reinstalled. Nothing has changed, the problem still persists (just for InDesign), Photoshop and Illustrator work fine. I tried installing trial versions of a few apps and they are all fine.

I am convinced it has something to do with Big Sur as nothing else has changed. I really hope an update comes through soon as InDesign is my primary worktool.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

When that dialog is showing:

 

Open Applications >> Utilities >> Activity Monitor

Select the "CPU" tab

In the list locate and select InDesign

Use "Gear icon" >> Sample Process

Wait a while for the result window

Upload anywhere (yes, it's big), and post a link here.

As I don't yet use InDesign with Big Sur, details may vary.

 

The produced process report is roughly similar to a crash dump. This could show the trigger for the dialog - was it caused by any UI gesture, something deep in Fonts etc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Thanks Dirk.

Does this work?

https://file.io/ZwwIZONekulR

I let it run and the save/don'tsave dialogue box came up. Whichever option I choose the program quits (I chose don't save if thats relevant)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Sorry, someone was faster.

> File.io is an ephemeral file sharing service, which means that files are automatically deleted as soon as they are downloaded ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

This appears to be the actual shutdown.

Please keep the dialog open until the process report is created ...

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

In my initial post I was joking "something deep in Fonts", but you should give it a try.

These lines 241/242 (in Optical Kerning) sound like it, the plus signs starting at 244 also lead to 368 (in Font Manager) and deeper.

My first guess was 244 (Application UI) and below appears to be the dialog, but then I saw 335 etc. (in Style Panel). Strange. All those "DoPostCreate" sound like either character or paragraph style panel is opening - e.g. following the change when welcome screen is changed into the initial workspace just after opening a document. Nothing about the close dialog …

 

So this process report - even without the dialog - gives two trails to follow. We're far from pointing fingers, though, just poking around in the dark.

I'd first try to disable all custom fonts, in a second pass if that won't work, also disable TypeKit.

Then you could also do something about the style panels - character and paragraph styles.

With no document, just open the panels. Does that already cause trouble?

Again with no document, switch from the "welcome" screen to a typical workspace. If you're using "Advanced", close the PStyle and CStyle panels before you open the document. "Essentials" also does not even have the panels, better try that. Does that make any difference when you then open the document?

 

Edit: after a second thought, all of the above could be just regular activity and does not neccessarily lead to the dreaded closing dialog. Maybe try again, do your thing and when the closing dialog shows give it a few seconds. Then keep the dialog open and switch to Activity Monitor.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Firstly Dirk,

Thank you so much for trying to help. It is very very appreciated

 

I'm not sure if I'm doing it correctly. I also tried disabling all non system fonts but that makes no difference

 

 

 

http://s000.tinyupload.com/index.php?file_id=18650715887540871841

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

That's an enormous process report.

Lines 43 thru 54 appears to be the relevant part but unfortunately that is almost opaque - not what I had hoped for. Could be the opening of your "closing dialog" but only if the problem happened somewhere earlier and the actual dialog is "deferred" to the event loop - as indicated by that "ExecuteFunction" line.

 

The rest is explainable with my requested changes:

Plenty more panels, likely when they are drawn in behind.

Besides – actually far better to watch than that "closing dialog" – there is the "font usage dialog", also deferred from opening the document. No surprise when you removed most fonts 😉

 

If this were happening on my development machine I'd look deeper at those nested commands until line 74, and at the activity before. Unfortunately you can't do that.

 

Sorry for the wasted effort, sometimes the process report gives a better idea.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

All I can say is thank you very much for trying to help. Although we didn't "fix" the issue, your help is appreciated very much

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about this. I see you have tried multiple troubleshooting steps they but didn't help. You may try creating a new user account on your machine & let us know if you have the similar issue with the InDesign there.

Looking forward to your response.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

LATEST

Just an update for anyone who might be having the same problem. I think I have it figured out:

Its to do with TIME MACHINE, it appears that there is some kind of conflict where time machine is saving to frequently when using InDesign causing the crash.

I stopped TIME MACHINE and the crash issue seems resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines