InDesign CC 2017 - links always red in hyperlinks panel

Participant ,
Apr 19, 2017 Apr 19, 2017

Copy link to clipboard

Copied

I am having an issue since upgrading to InDesign CC 2017 where all the hyperlinks in the hyperlinks panel are displaying as red (ie. 'URL is not available'). However when I click on the red icon to test the hyperlink destination most the hyperlinks actually work ie. they should be green not red. I am having this issue with all documents.

I didn't have this issue in the previous version of InDesign CC. Has anyone else had this issue or know what might have changed in the hyperlink functionality for InDesign CC 2017?

Many thanks,

HJ

Views

3.8K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Participant , Apr 21, 2017 Apr 21, 2017
Sorry for the multiple posts but the workaround I had above wasn't quite right. This is what I needed to do to get it working properly:1. In the hyperlinks panel turn off 'Auto Update URL Status'. 2. Now select all hyperlinks in the hyperlink panel and click the 'Refresh URL status' icon. The icon next to each hyperlink should change from red to grey.3. Now in the hyperlinks panel turn 'Auto Update URL Status' back on. It will now gradually refresh all hyperlinks - all working hyperlinks will be...

Likes

translate

Translate

Translate
Most Valuable Participant ,
Apr 20, 2017 Apr 20, 2017

Copy link to clipboard

Copied

Can you post an example URL?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 20, 2017 Apr 20, 2017

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 20, 2017 Apr 20, 2017

Copy link to clipboard

Copied

I should say I am having this issue in both InDesign CC 2017 on mac and PC.

As all hyperlinks are red (and are red all the time), maybe its something to do with working behind a firewall or something else to do with our network???

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 21, 2017 Apr 21, 2017

Copy link to clipboard

Copied

Ok, I have a clue:

If I create new hyperlinks directly in the InDesign document then they display correctly as green. However I have been importing word documents (with hyperlinks) into InDesign via a third party product. For some reason in my InDesign documents that have had the text and hyperlinks imported from Word they always display red - even though everything looks correct in the hyperlinks panel?

I will keep investigating but if anyone has any ideas please let me know!  Many thanks. HJ

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 21, 2017 Apr 21, 2017

Copy link to clipboard

Copied

Also if I highlight the hyperlink in the hyperlink panel, then select 'Edit Hyperlink...' it will become green. I then click OK in the 'Edit Hyperlink...' window and it now stays green, even though I made no changes to it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 21, 2017 Apr 21, 2017

Copy link to clipboard

Copied

Ok, here is my workaround (tested on mac):

In the hyperlinks panel turn off 'Auto Update URL Status'. Now select all hyperlinks and click the 'Refresh URL status' icon. Gradually it rechecks the hyperlinks and now marks them as green.

I does seem a little bit buggy in that I end up having to select alot of the hyperlinks individually to get them to refresh.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 21, 2017 Apr 21, 2017

Copy link to clipboard

Copied

Sorry for the multiple posts but the workaround I had above wasn't quite right. This is what I needed to do to get it working properly:

1. In the hyperlinks panel turn off 'Auto Update URL Status'.

2. Now select all hyperlinks in the hyperlink panel and click the 'Refresh URL status' icon. The icon next to each hyperlink should change from red to grey.

3. Now in the hyperlinks panel turn 'Auto Update URL Status' back on. It will now gradually refresh all hyperlinks - all working hyperlinks will be correctly marked as green.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 21, 2017 Apr 21, 2017

Copy link to clipboard

Copied

I should say that in addition to the issue of hyperlinks not refreshing properly in InDesign (InDesign bug?), our  virus software on the PC was somehow causing the Hyperlinks to remain red. When the virus software was disabled and the above steps were followed in InDesign then URL status displayed correctly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

I ran into this, this evening, and your answer was just what I needed. Thanks so much. 🙂

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

I'm now having this prolem and cannot resolve it in InDesign Beta on my Mac Mini M1. I can't get the red icon to disappear. 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines