InDesign CC Shift Key not working

New Here ,
Apr 14, 2014

Copy link to clipboard

Copied

Normally I'd just hold the shift key down to resize an image or object in InDesign CC to constrain its proportions. Lately when I try to resize an image, the shift key doesn't do anything anymore. It no longer holds the proportions of the image box. Is there a way to fix this problem or is there a new tool that replaces the hot key shortcut? Transform > Scale is taking way too much time to resize an image to the proper size I need it to be.

Any and all help is very appreciated.

-Jon

TOPICS
Performance

Views

105.0K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Community Beginner , Aug 25, 2015
juarthy Community Beginner , Aug 25, 2015
Hello Carol, I posted a fix that worked for me perfectly, it was webroot virus scanning software. I turned it off, and the problem disappeared. I only run it at night, when I’m not working. An apple tech told me virus scan software can interfere with key commands. Not sure if this is your issue, but hope it helps. My macbook pro was fine, the software wasn’t installed on it, it was the mac pro with the virus scanning software that had the issue.Good luck

Likes

Translate

Translate
Jump to answer Jump to answer
133 Replies 133
Advisor ,
Apr 15, 2014

Copy link to clipboard

Copied

You have scaling values in the top bar. Per cent and other units. Just enter there what you need. Only takes little time, not "way too much".

Apart from that, the Shift key might be broken or you're pressing it at the wrong time.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 06, 2014

Copy link to clipboard

Copied

same on my end.

what happened?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
May 06, 2014

Copy link to clipboard

Copied

It might be the order you do things. Since about CS3 it has been necessary to press the modifier key before clicking the mouse. Perhaps they finally screwed up the Mac platform the same way.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 22, 2014

Copy link to clipboard

Copied

Jon,

Same issue on multiple occasions... it seems a bug in CC 2014 that the shift key just stops working.  The only way I've found to get it back is to quit all programs and restart my mac.

~ hope that helps

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 24, 2014

Copy link to clipboard

Copied

I'M HAVING THE SAME ISSUE. THE SHIFT BUTTON DOESN'T WORK FOR SCALING OR FOR ALIGNING OBJECTS.

IS RESTARTING THE ONLY SOLUTION FOR THE MOMENT?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 24, 2014

Copy link to clipboard

Copied

I haven't heard of another method, do this seems to be the only solution for the time being. Adobe really should look into this.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 29, 2014

Copy link to clipboard

Copied

I have this same issue. mine is only on indesign cc 2014. my shift and option key won't work as well. I've tried quitting the programs and rebooting my computer. I've also tried to reinstall them as well... nothing seems to be working. any ideas?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Oct 16, 2014

Copy link to clipboard

Copied

Been having exactly the same problem for months - just realised it's related to having Smart Guides switched on. If you hold down 'ctrl' to ignore smart guides & 'shift' to keep your image in pro it should solve the problem

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 02, 2017

Copy link to clipboard

Copied

THIS is the issue. Thanks for solving!!!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Mar 17, 2020

Copy link to clipboard

Copied

This worked!! So odd! I use a PC at work and have never had this issue but I use at Mac at home and the smasrt guides resolved it. I wonder if it a mac/pc issue. Thank you for the fix!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Mar 17, 2020

Copy link to clipboard

Copied

I have to eat my wods a little here. I just updated to the new version and now this little trick does not work. Very bizarre 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 05, 2014

Copy link to clipboard

Copied

Has there been a fix for this? My shift key just stopped working today in InDesign CC 2014. I thought it might be a broken shift key but that's not the case as I went to open Illustrator and it's also doing the same thing in there.

Is there a universal setting that might have been affected? Is there a constrain-proportions-property setting somewhere that may have been thrown off? I'm still looking for a solution. Any help would be appreciated.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
J_Prinz AUTHOR
New Here ,
Nov 05, 2014

Copy link to clipboard

Copied

On a similar note, the spacebar quick key for the hand tool in Illustrator sometimes stops working as well. Not as annoying to deal with but its kind of inconvenient.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Jan 07, 2015

Copy link to clipboard

Copied

I was having this problem as well, within indesign CC 2014 only, not photoshop or illustrator. Virus or firewall can interfere with key modifiers. I have webfoot virus software. When I turn it off temporarily the shift key constrains angles and draws straight lines again as usual.  There may be a better workaround, but this works for me, though I have to turn the virus software off and on.

I have a laptop that I haven't installed webroot on yet and it runs the same version of indesign cc 2014 as my main mac… there was never an issue with the shift key on the laptop.

Good luck!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 23, 2015

Copy link to clipboard

Copied

I have been having this problem and none of the above fixes worked for me, until now. Webroot was recently installed on my machine and when I turn it off, the shift key immediately starts working again. Thanks for the tipjuarthy!!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 25, 2015

Copy link to clipboard

Copied

TOTALLY WAS SMART GUIDES. View>Grids and Guides> Smart guides

i unchecked then re checked and seems like my shift button scaling is back, also back is the space bar hand tool hot key. thanks.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 09, 2016

Copy link to clipboard

Copied

This didn't work for me

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
May 10, 2016

Copy link to clipboard

Copied

What didn't work? Did you read the entire thread?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
May 10, 2016

Copy link to clipboard

Copied

I was responding to geezluweez27​ in regards to turning on and off the Smart Guides in order to get the shift key working again.

Am still looking for a simpler version than uninstalling and reinstalling InDesign in order to get it working again.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
May 10, 2016

Copy link to clipboard

Copied

Many users are finding it's caused by the secure input settings of WebRoot.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
May 10, 2016

Copy link to clipboard

Copied

These applications (in some cases outdated versions) can cause this bug in InDesign or Photoshop:

  • 1Password
  • Box
  • Chronories
  • Firefox
  • Fluid
  • Game Center
  • Google Chrome
  • Hulu Desktop
  • iFinance
  • LastPass
  • loginwindow (Mac os proccess)
  • Notational Velocity
  • Parallels Desktop 9 and 10
  • Quicken Scheduler
  • Safari
  • Slack
  • Terminal
  • Webroot SecureAnywhere

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 06, 2016

Copy link to clipboard

Copied

Just for the masses - I turned off 1password and mine worked instantly - without the need to restart either.

Hope that helps .... not happy that I have to start 1password up every time I need it but I use ID more often so it take prefs.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Engaged ,
Jun 06, 2016

Copy link to clipboard

Copied

Yeah, in an ideal world you shouldn't have to. In my all be it limited experience all other apps are able to understand modifier keys like option and shift when secure input is turned on, these apps should too as the potential for screwing up peoples work if they think they are using the option key when they actually are not is massive. You can only get away with it if you're text expander or an app like that that needs to recognize key presses when the focus is on another window that isn't your app.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 25, 2017

Copy link to clipboard

Copied

This also worked for me

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more