InDesign CC - Spell check not working.

New Here ,
Sep 03, 2013 Sep 03, 2013

Copy link to clipboard

Copied

I can purposefully type a misspelled word in InDesign and the Spell Check doesn't catch it. In fact it doesn't seem to work at all.

TOPICS
Performance

Views

41.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Participant , Feb 24, 2016 Feb 24, 2016
As is often the case, the answer is simple. I find a lot of people jump to things like entering code in the terminal and the like. I had the problem and someone posted that You simply have to be in preview mode. "w" (when your cursor is not typing text, otherwise escape then w) will bring it up. Presto, dynamic spell check is working.

Likes

Translate

Translate
New Here ,
May 29, 2014 May 29, 2014

Copy link to clipboard

Copied

I too was having the same problem after updating to CC. This is what worked for me: Preferences, Dictionary, Spelling-Hunspell. It was set to Proximity by default. My language always had English: USA, so that wasn't my issue. Hopefully this will work for others with the same problem. Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 27, 2015 Jan 27, 2015

Copy link to clipboard

Copied

Once I also changed Preferences, Dictionary, Hyphenation to Hunspell this worked for me.

I had already done the noted steps about checking and fixing Language under Paragraph and Character styles. A bunch of the character styles were indeed not set to a language even through overall preferences were. However until I also changed to Hunspell for both Spelling and Hyphenation under Dictionary dynamic spelling did not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2020 Mar 18, 2020

Copy link to clipboard

Copied

Thank you - you legend ... that has been bugging me for ages 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2020 Mar 31, 2020

Copy link to clipboard

Copied

You're a genius. I'm writing a book that this really messed me up. Your fix worked!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2020 Mar 20, 2020

Copy link to clipboard

Copied

This worked for me - thanks 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

This worked for me years later, thank you !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2020 Apr 05, 2020

Copy link to clipboard

Copied

Bingo! Mine too stopped working after latest upgrade. Tried all other suggestions and this worked - thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2020 Apr 08, 2020

Copy link to clipboard

Copied

Thanks!! This worked for me. For some documents, my spell-checker window just sat there and did nothing no matter how many times I clicked 'Start'. Once I changed hypenation and spelling to Hunspell (from the default Proximity), the spell-checker instantly went back to working as expected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2020 Apr 20, 2020

Copy link to clipboard

Copied

This has also worked for me – thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2020 Apr 20, 2020

Copy link to clipboard

Copied

This was the answer to my problem as well... (Well changing both Hyphenation & Spelling to "HUNSPELL") I have an office 15 designers and we where all stumped... for like weeks! Thank you. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2020 Apr 21, 2020

Copy link to clipboard

Copied

Changing hyphenation and spelling to Hunspell fixed my issue as well. However, I needed to fix this within each individual documents that I was collaborating with. New documents on my system had it set to Hunspell properly. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2014 Nov 18, 2014

Copy link to clipboard

Copied

I had the same problem too, ever since InDesign CS6 was first installed on my MBP laptop (OS X, late-2008 model).

I just fixed the issue by replacing two of the original en-US dictionary files with ones I downloaded from OpenOffice.  Here are the directions that I followed to accomplish this -- Add or remove Hunspell dictionaries | CC, CS6.  And this is the file I downloaded to replace the AFF and DIC files -- http://extensions.openoffice.org/en/project/us-english-spell-checking-dictionary.

I hope this helps.  Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 05, 2018 May 05, 2018

Copy link to clipboard

Copied

maiyo8  schreef

I had the same problem too, ever since InDesign CS6 was first installed on my MBP laptop (OS X, late-2008 model).

I just fixed the issue by replacing two of the original en-US dictionary files with ones I downloaded from OpenOffice.  Here are the directions that I followed to accomplish this -- Add or remove Hunspell dictionaries | CC, CS6.  And this is the file I downloaded to replace the AFF and DIC files -- http://extensions.openoffice.org/en/project/us-english-spell-checking-dictionary.

I hope this helps.  Cheers!

Thank you maiyo8! This is the only thing that worked for me (after a recent InDesign CC update I could not get the spell check working, even after trying everything else posted here). Replacing the Hunspell dictionaries finally worked! More than 3 years later and Adobe is still not able to fix this problem??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 30, 2015 Apr 30, 2015

Copy link to clipboard

Copied

I too was having the same problem with my brand-new copy of Indesign, just downloaded last week. Spellcheck completely failed to work. I checked all the preferences recommended here, still nothing. But what HAS worked was the advice from maiyo8: downloading the English dictionaries from OpenOffice (aiff & dic) and replacing the ones that came with the software. Restarted Indesign and bingo: spellcheck works now. Thanks so very much, maiyo8! You have saved my reputation as a graphic designer who always checks to make sure my layouts are delivered to the client spelling-error free. Although I have yet to find a fix for the errors a client makes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2015 Jun 15, 2015

Copy link to clipboard

Copied

I just cleared overrides in the paragraph styles panel and it works. Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2015 Oct 01, 2015

Copy link to clipboard

Copied

Forgive me if I'm suggesting something a bit basic, but it caught me out...  I was working in print mode rather than preview (which switches by pressing 'w').  In print mode, spell check doesn't work, I switched to preview (on advice from a colleague) and it works fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2016 Apr 12, 2016

Copy link to clipboard

Copied

Actually brilliant!!! This fixed my problem!!! Thank you @davidc26288426

"27. Re: InDesign CC - Spell check not working.

davidc26288426 Community Member davidc26288426 01-Oct-2015 07:58 (in response to @SeeFuller)

Forgive me if I'm suggesting something a bit basic, but it caught me out...  I was working in print mode rather than preview (which switches by pressing 'w').  In print mode, spell check doesn't work, I switched to preview (on advice from a colleague) and it works fine."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 09, 2015 Oct 09, 2015

Copy link to clipboard

Copied

Having the same issue. Cleared overides and that fixed it for the short term but it shouldn't be happening. Please Fix!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2015 Nov 04, 2015

Copy link to clipboard

Copied

Just tried this. Im working in CS6. So im not sure if it will apply to the CC or not. I had all the above issues about spell check not working, checked all of the dictionaries and language and whatnot. Nothing worked.

Then I went to Indesign Preferences > Spelling then I checked "misspelled words" and that seems to have done the trick. Seems too simple to overlook for such a complex issue, but I thought what the hell. So I tired it and it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2016 Jan 05, 2016

Copy link to clipboard

Copied

Spent ages trying to figure this out, nothing was working, then realised I still had overprint preview ticked (under view). Make sure this is un ticked!

Silly mistake but worth a check

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2016 Jan 05, 2016

Copy link to clipboard

Copied

I just tested in InDesign CC 2015.2 on a Mac. No problems doing spell checking when Overprint Preview is turned on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2016 Jan 13, 2016

Copy link to clipboard

Copied

Crap. I just read through everyone's posts and I still cannot get my old documents to spellcheck. Anything new I create works and if I cut and paste into a new document, that works as well. Oh well at least I got that part figured out! Thanks for all of the troubleshooting tips everyone!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2016 Feb 02, 2016

Copy link to clipboard

Copied

Same issue here. I've tried every suggestion in this thread and it still won't work!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 24, 2016 Feb 24, 2016

Copy link to clipboard

Copied

As is often the case, the answer is simple. I find a lot of people jump to things like entering code in the terminal and the like. I had the problem and someone posted that You simply have to be in preview mode. "w" (when your cursor is not typing text, otherwise escape then w) will bring it up. Presto, dynamic spell check is working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2016 Feb 24, 2016

Copy link to clipboard

Copied

Tried that... still doesn't work. Darn it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines