InDesign CC - Spell check not working.

New Here ,
Sep 03, 2013 Sep 03, 2013

Copy link to clipboard

Copied

I can purposefully type a misspelled word in InDesign and the Spell Check doesn't catch it. In fact it doesn't seem to work at all.

TOPICS
Performance

Views

41.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Participant , Feb 24, 2016 Feb 24, 2016
As is often the case, the answer is simple. I find a lot of people jump to things like entering code in the terminal and the like. I had the problem and someone posted that You simply have to be in preview mode. "w" (when your cursor is not typing text, otherwise escape then w) will bring it up. Presto, dynamic spell check is working.

Likes

Translate

Translate
Participant ,
Feb 24, 2016 Feb 24, 2016

Copy link to clipboard

Copied

Dang. Sorry to hear that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 18, 2019 Aug 18, 2019

Copy link to clipboard

Copied

Most bizarre solution, but it works. Thanks David,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2016 Jul 20, 2016

Copy link to clipboard

Copied

Turning on preview mode (pressing "W") worked for me! Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2016 Aug 29, 2016

Copy link to clipboard

Copied

Having the same issue here as well.  Checked everything, reset preferences, Spell Check is just not working.  Going to try re-istalling InDesign.  Will update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2016 Aug 29, 2016

Copy link to clipboard

Copied

Un-install/re-install seems to have fixed the issue.  I will post if the problem reoccurs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2016 Sep 08, 2016

Copy link to clipboard

Copied

I too have had this problem--Spell Check working in some docs and not in others. The only thing I can figure is that some of the files are older than others, but still not something that should create a problem for a Spell Check.

The fix I found was simply to do a Save As of the file, making a copy of it, and then restarting the App. The new file spell-checked in the normal manner (i.e., actually locating misspelled words).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 24, 2017 Aug 24, 2017

Copy link to clipboard

Copied

Hey go to to View > Screen Mode

Make sure that you have 'Normal' selected and not 'Preview'

Just worked for me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 19, 2018 Feb 19, 2018

Copy link to clipboard

Copied

I just worked on a big document and knew there was a specific word incorrectly spelt after being picked up by someone, so went back to runt he spell check again and out of 40+ pages it was only showing 4-5 incorrect words on one page that were just funny surnames of people. I question how many other incorrect words it missed along the way...

In general InDesign 2018 is the. worst.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 17, 2018 Mar 17, 2018

Copy link to clipboard

Copied

PROPOSAL:  Really has consistently caused problems that the Dynamic spell check only shows when you are NOT in "Preview Mode".  Many many documents went out with typos because you assume the dynamic check was on - when in fact you were in preview mode... ore worse forgot that you toggled back.  There should be a poll or something - Who would NOT want to see a typo indicated ?   Anyway, it took about an hour to figure out that this was even the case - after questioning my own sanity, and the effectiveness of the spell checker for months...  #nightmare default protocol.   Why not make persistent spell check an option in the preferences OR in the spell check menu?

Cheers David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 13, 2019 Oct 13, 2019

Copy link to clipboard

Copied

October 2019- still happening

In word if i turn autocorrect on it works, what's going on here?

Please don't repeat all the "fixes" on the net- been there done that

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2019 Oct 15, 2019

Copy link to clipboard

Copied

Something that worked for me was checking that the dictionary in preferences was set to the same dictionary as that of the paragraph style. For example, I had English-UK at the preference level then, English-AUS at the paragraph style. I changed both to UK and it starting underlining mistakes again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

I should add: after making the dictionary fix, toggle your dynamic spelling off and then on agsin (Edit > Spelling > Dynamic spelling) that should 'wake it up'.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

I have given up with it, why make it complicated , i now type in ms Word brilliant autocorret and thesaurus, copy and paste it over

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

ARGH!!!!! I jsut found a tab in preferences called: Enable Dynamic Spelling that was not checked!!!!! Did you try this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

nope, that didn't work either. I have been havving the same problem since cc upgrade.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

Not sure why but after a restart (pc) it began working and has continued to work with the 400+ files i work with

So solved for me but not sure why it wasn't previously

Current tabs

Edit--> Preferences --> Spelling --> all buttons clicked

Edit--> Preferences --> Autocorrect --> enabled autocorrect

Edit--> Preferences --> Dictionary--> language english UK, hyphenation and spelling "hunspell", compose using "user dictionary and coument", all other buttons clicked

 

Good luck all

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

Actually, I looked at the link to my dictionary, and discovered that I don't think my cloud subscription downloaded the dictionary, which means indesign would like me to relink my dictionary, only I don't have the dictionary file on my system, and since it wiped out my old dictionary when it did the upgrade, as best I can tell. I looked for the dictionary file online, and I am not finding it. Very frustrating!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2020 Mar 27, 2020

Copy link to clipboard

Copied

This worked for me! I tried some of the other suggestions, but no luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

These are the steps you should take:

1. Go to Edit > Preferences > Spelling and check the box for Enable Dynamic Spelling 

2. Go to Edit > Spelling and make sure there is a checkmark next to Dynamic Spelling

3. Make sure you are in Normal mode, not Preview! (Shortcut key is W, or click and hold the very last icon on the toolbar on the left.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 04, 2020 Apr 04, 2020

Copy link to clipboard

Copied

W still didn't work for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 05, 2020 May 05, 2020

Copy link to clipboard

Copied

Everybody, all I had to do was the following:

 

Go to PREFERENCES > DICTIONARY. In the boxes labeled  HYPHENATION and SPELLING use the pull-down to change to Hunspell.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 12, 2020 Jun 12, 2020

Copy link to clipboard

Copied

Thanks so much! FYI this worked for me AFTER restarting my Mac. Changing the prefs to Hunspell before that didn't work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Edit > Spelling > enable dynamic spelling.

cleared the problem right up

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Cheers it worked 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2020 Nov 10, 2020

Copy link to clipboard

Copied

Anytime, glad to help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines