Highlighted

InDesign CC Start-up Error: "...lack sufficient permissions to access the preferences folders"

Community Beginner ,
Oct 13, 2013

Copy link to clipboard

Copied

InDesign CC

Having successfully installed many CC apps on my Mac Pro Desktop, I proceeded to do the same on my laptop. However, after two attempts at uninstalling and re-downloading both InDesign CC and the Creative Cloud Desktop. When starting up InDesign, I repeatedly get this error message: "Error: Unable to launch Adobe InDesign as you lack sufficient permissions to access the preferences folders. Ensure that you have appropriate permissions and then restart Adobe InDesign." and can go no further.

I can find no instruction on how to do this, or reference to anyone else getting this error.

MacBook Pro

17-inch, Late 2011

Processor  2.5 GHz Intel Core i7

Memory  8 GB 1333 MHz DDR3

Graphics  AMD Radeon HD 6770M 1024 MB

Software  Mac OS X Lion 10.7.5

Correct answer by creatorii | Community Beginner

I've seen this stock suggestion posted on many discussions. I've solved the problem with LiveChat with Adobe Support:

Mohammed: As I understand you are not able to launch CC apps since it is giving error "Unable to launch Adobe InDesign as you lack sufficient permissions to access the preferences folders". Is that correct?

Paul: Yes

Mohammed: Please open a Finder window. Choose Go > Go To Folder. Type ~/library and you will get Preferences folder.

Paul: In Library now

Mohammed: Are you able to find preferences folder?

Paul: yes

Mohammed: Control-click the folder and choose Get Info.

Mohammed: Expand the Sharing & Permissions section.

Mohammed: Click the lock icon in the lower-right corner. Enter your administrator user name and password when prompted, and then click OK.

Paul: done

Mohammed: Please click on + icon and add the Admin and all users showing.

Paul: done

Mohammed: Set permission for all users and admin as read/write

Mohammed: Click the Gear icon, and select Apply to Enclosed Item

Paul: to each of the individual users and groups?

Paul: one at a time?

Paul: I've done it.

Mohammed: Please open a Finder window. Choose Go > Go To Folder. Type ~/library/Application support and give full permission to Adobe folder.

Paul: That's completed... I've added all the users and groups, given each 'Read and Write" and extended the permissions to all enclosed items.

Mohammed: Now please open a Finder window. Choose Go > Go To Folder. Type /library/Application support and give full permission to Adobe folder.

Paul: OK, I understand... I am proceeding with your instruction.

Mohammed: Thank you.

Paul: I'm finished.

Mohammed: Please close all Adobe Applications and then launch InDesign CC and let me know the result.

Paul: OK... looking good so far Mohammed... fingers crossed!

Paul: Thanks Mohammed... it's launched!

Mohammed: Excellent, I am so happy to hear this from you.

Mohammed: I certainly appreciate your patience in this process.

Paul: And I yours.

Views

43.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign CC Start-up Error: "...lack sufficient permissions to access the preferences folders"

Community Beginner ,
Oct 13, 2013

Copy link to clipboard

Copied

InDesign CC

Having successfully installed many CC apps on my Mac Pro Desktop, I proceeded to do the same on my laptop. However, after two attempts at uninstalling and re-downloading both InDesign CC and the Creative Cloud Desktop. When starting up InDesign, I repeatedly get this error message: "Error: Unable to launch Adobe InDesign as you lack sufficient permissions to access the preferences folders. Ensure that you have appropriate permissions and then restart Adobe InDesign." and can go no further.

I can find no instruction on how to do this, or reference to anyone else getting this error.

MacBook Pro

17-inch, Late 2011

Processor  2.5 GHz Intel Core i7

Memory  8 GB 1333 MHz DDR3

Graphics  AMD Radeon HD 6770M 1024 MB

Software  Mac OS X Lion 10.7.5

Correct answer by creatorii | Community Beginner

I've seen this stock suggestion posted on many discussions. I've solved the problem with LiveChat with Adobe Support:

Mohammed: As I understand you are not able to launch CC apps since it is giving error "Unable to launch Adobe InDesign as you lack sufficient permissions to access the preferences folders". Is that correct?

Paul: Yes

Mohammed: Please open a Finder window. Choose Go > Go To Folder. Type ~/library and you will get Preferences folder.

Paul: In Library now

Mohammed: Are you able to find preferences folder?

Paul: yes

Mohammed: Control-click the folder and choose Get Info.

Mohammed: Expand the Sharing & Permissions section.

Mohammed: Click the lock icon in the lower-right corner. Enter your administrator user name and password when prompted, and then click OK.

Paul: done

Mohammed: Please click on + icon and add the Admin and all users showing.

Paul: done

Mohammed: Set permission for all users and admin as read/write

Mohammed: Click the Gear icon, and select Apply to Enclosed Item

Paul: to each of the individual users and groups?

Paul: one at a time?

Paul: I've done it.

Mohammed: Please open a Finder window. Choose Go > Go To Folder. Type ~/library/Application support and give full permission to Adobe folder.

Paul: That's completed... I've added all the users and groups, given each 'Read and Write" and extended the permissions to all enclosed items.

Mohammed: Now please open a Finder window. Choose Go > Go To Folder. Type /library/Application support and give full permission to Adobe folder.

Paul: OK, I understand... I am proceeding with your instruction.

Mohammed: Thank you.

Paul: I'm finished.

Mohammed: Please close all Adobe Applications and then launch InDesign CC and let me know the result.

Paul: OK... looking good so far Mohammed... fingers crossed!

Paul: Thanks Mohammed... it's launched!

Mohammed: Excellent, I am so happy to hear this from you.

Mohammed: I certainly appreciate your patience in this process.

Paul: And I yours.

Views

43.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 13, 2013

Copy link to clipboard

Copied

Hi creatorii,

A few standard troubleshooting steps we'd like you to test out:

1. Check the user / disk permissions.

2. Recreate preferences: http://forums.adobe.com/thread/526990

3. Disable any third party plug-ins

4. Starting your computer in Safe boot mode: http://support.apple.com/kb/HT1455

5. Creating a new user account / Root user account ( http://support.apple.com/kb/ht1528 )and see if the issue persists

Please let us know how it goes. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 13, 2013

Copy link to clipboard

Copied

I've seen this stock suggestion posted on many discussions. I've solved the problem with LiveChat with Adobe Support:

Mohammed: As I understand you are not able to launch CC apps since it is giving error "Unable to launch Adobe InDesign as you lack sufficient permissions to access the preferences folders". Is that correct?

Paul: Yes

Mohammed: Please open a Finder window. Choose Go > Go To Folder. Type ~/library and you will get Preferences folder.

Paul: In Library now

Mohammed: Are you able to find preferences folder?

Paul: yes

Mohammed: Control-click the folder and choose Get Info.

Mohammed: Expand the Sharing & Permissions section.

Mohammed: Click the lock icon in the lower-right corner. Enter your administrator user name and password when prompted, and then click OK.

Paul: done

Mohammed: Please click on + icon and add the Admin and all users showing.

Paul: done

Mohammed: Set permission for all users and admin as read/write

Mohammed: Click the Gear icon, and select Apply to Enclosed Item

Paul: to each of the individual users and groups?

Paul: one at a time?

Paul: I've done it.

Mohammed: Please open a Finder window. Choose Go > Go To Folder. Type ~/library/Application support and give full permission to Adobe folder.

Paul: That's completed... I've added all the users and groups, given each 'Read and Write" and extended the permissions to all enclosed items.

Mohammed: Now please open a Finder window. Choose Go > Go To Folder. Type /library/Application support and give full permission to Adobe folder.

Paul: OK, I understand... I am proceeding with your instruction.

Mohammed: Thank you.

Paul: I'm finished.

Mohammed: Please close all Adobe Applications and then launch InDesign CC and let me know the result.

Paul: OK... looking good so far Mohammed... fingers crossed!

Paul: Thanks Mohammed... it's launched!

Mohammed: Excellent, I am so happy to hear this from you.

Mohammed: I certainly appreciate your patience in this process.

Paul: And I yours.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 18, 2014

Copy link to clipboard

Copied

Solved my problem. Thanks so much for posting!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 09, 2015

Copy link to clipboard

Copied

That was it, fixed the issue for me. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Aug 17, 2015

Copy link to clipboard

Copied

Thank you creatorii! This solved my problem on OS X 10.10.4.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 20, 2015

Copy link to clipboard

Copied

creatorii wrote:

Mohammed: Set permission for all users and admin as read/write


I'm not sure this is a good idea. As I read this, Adobe is recommending that you completely bypass the security controls of Mac OS X. This recommendation above (at least the first step) is giving all users full read/write permissions to EVERY preference folder for ALL applications in YOUR OWN user library. This is a bad idea. I understand why it works... of course if you bypass the security controls on your machine then you won't have any problems with permission errors, but this is not an adequate replacement for a proper solution that maintains your Mac's security.


This proposed solution is like me complaining to a locksmith "The key to my front door isn't working," and the locksmith taking a hammer and ripping the lock off the door, and saying, "It's fixed!"


Does anyone have a solution that isn't so irresponsible?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 01, 2015

Copy link to clipboard

Copied

matth40640805 schreef:

creatorii wrote:

Mohammed: Set permission for all users and admin as read/write


I'm not sure this is a good idea. As I read this, Adobe is recommending that you completely bypass the security controls of Mac OS X. This recommendation above (at least the first step) is giving all users full read/write permissions to EVERY preference folder for ALL applications in YOUR OWN user library. This is a bad idea. I understand why it works... of course if you bypass the security controls on your machine then you won't have any problems with permission errors, but this is not an adequate replacement for a proper solution that maintains your Mac's security.


This proposed solution is like me complaining to a locksmith "The key to my front door isn't working," and the locksmith taking a hammer and ripping the lock off the door, and saying, "It's fixed!"


Does anyone have a solution that isn't so irresponsible?

Instead of the entire preference folder do the same steps to each adobe folder inside the prefference folder, and instead of adding all the users only add administrators and yourself. I just did this on my mac and it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 14, 2016

Copy link to clipboard

Copied

Mohammed, I follow your instructions! Thank you so much for your help. It works!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 08, 2017

Copy link to clipboard

Copied

This is not solved, as some MacBook Pro users (mainly me) have updated the Preferences folder permissions to 777 and still cannot open InDesign.

Additionally, I confirmed that this was the correct Preferences folder (contains necessary preferences for Adobe) and also tried to set permissions recursively so all subsequent files/directories follow the permission update. No luck.

Additionally, additionally, this was first reported in 2013 and still doesn't have an appropriate fix for it. mwillems is completely right in concluding that this issue needs to be fixed on Adobe's end and not by this method.

Additionally, additionally, additionally, what is the point of having a subscription to these products if crap isn't fixed in a timely manner? It makes sense at that point to buy the old stable versions that actually work and just forgo all of the new awesome features that aren't accessible. 

Rave please offer some explanation Adobe as this is not the comment of a happy customer (more sad than mad, but sorta mad)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
egw1900 LATEST
New Here ,
Apr 17, 2020

Copy link to clipboard

Copied

I know this is three years late, but for someone else with the same issue: oddly going in through the GUI and changing the preferences folder to add "admin" and then give R&W is NOT the same as just chmod -R 777 Preferences/Adobe*. Note that "admin" is NOT my administrator user name, but rather the entire collective group of users. I have no idea why this is Adobe-specific, no other application installed on my computer had a similar issue, but I noticed previously that Adobe (and only Adobe) had somehow changed their chown to "root" rather than my user name. I chowned it back to my regular user name as well. 

 

I have an external harddrive that I switch between computers — sometimes as a boot disk, sometimes not — and thus had to mess around (a lot...) to get this to work. 

 

I don't use InDesign but this fixed both Illustrator and Photoshop for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Aug 20, 2014

Copy link to clipboard

Copied

Thank you very much Mohammed, clear and easy to follow steps, worked immediately.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 17, 2015

Copy link to clipboard

Copied

Worked for me thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 25, 2015

Copy link to clipboard

Copied

Thank you, this solved my problem as well!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Oct 11, 2015

Copy link to clipboard

Copied

And me, all fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...