Highlighted

InDesign checkbox appearance in Acrobat

New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

I am trying to do a questionnaire in InDesign, with multiple choice questions. I want the user to be able to see if the answer they selected is correct or not once they clicked, and so I want to use the check sign and the X sign as such:

But when I export it to PDF the automatic checkbox is select instead:

What is the point of changing the appearance of a checkbox if is not going to be exported to PDF?

Is there any way that checkbox will not appear? I have been trying everything! a button wouldn't work because I need the appearance to stay. The radio button also does not work because there are several correct answers.

Thank you!!

[Moved out of the Forum comments forum (which is for issues with these forums themselves) and into a product-specific, support forum by a moderator.]

Hmmmm, are you sure?

What you call "a set look for check boxes" is what you see when Highlight existing fields* is ON, don't you?

I am confused

* "Mettre les champs existants en surbrillance" in my French version

span.gif

Views

3.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign checkbox appearance in Acrobat

New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

I am trying to do a questionnaire in InDesign, with multiple choice questions. I want the user to be able to see if the answer they selected is correct or not once they clicked, and so I want to use the check sign and the X sign as such:

But when I export it to PDF the automatic checkbox is select instead:

What is the point of changing the appearance of a checkbox if is not going to be exported to PDF?

Is there any way that checkbox will not appear? I have been trying everything! a button wouldn't work because I need the appearance to stay. The radio button also does not work because there are several correct answers.

Thank you!!

[Moved out of the Forum comments forum (which is for issues with these forums themselves) and into a product-specific, support forum by a moderator.]

Hmmmm, are you sure?

What you call "a set look for check boxes" is what you see when Highlight existing fields* is ON, don't you?

I am confused

* "Mettre les champs existants en surbrillance" in my French version

span.gif

Views

3.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

Hi Irene:

You are posting two separate questions, both of which require troubleshooting. The most expedient option to solve both issues is to use one of the checkbox presets that comes with InDesign.

  1. Window > Buttons & Forms
  2. Choose Sample Buttons and Forms
    Screenshot 2018-02-26 07.36.26.png
  3. There's one that looks a lot like the one you want, so you can drag it onto the page
    Screenshot 2018-02-26 07.37.07.png
  4. They work as expected in Acrobat or Reader
    Screenshot 2018-02-26 07.37.27.png

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 1
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Hi Barb,

Those are buttons. I need it to be a checkbox.

When I use a checkbox then it gets overridden in Acrobat and that is what I want to change.

Thanks

Irenia

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

I am so sorry—it's early in my time zone.

Not only did I responded with radio buttons when you asked about checkboxes—the difference is that you can select multiple answers for a group of checkboxes and only one for radio buttons—you actually want the button to reveal the correct answer, which I completely overlooked. You can do that with two buttons per answer and with the show/hide fields action.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

no problem!

Can I put a button on top of the other? I guess my best option will be to have the red mark or green to appear at the end of the question with a show/hide field. It is so much easier to do this if I was exporting to Epub

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Most Valuable Participant ,
Feb 26, 2018

Copy link to clipboard

Copied

This is the default behavior of checkbox appearance overridden in Acrobat/Reader by the checkbox style.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Hi!

So there is no way around it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Guide ,
Feb 26, 2018

Copy link to clipboard

Copied

I am not sure I understood your question correctly.

But I believe you are talking about the (annoying) "Highlight existing fields" Acrobat (reader/pro) feature.

You can turn it off in Acrobat, but be aware this is an application setting, not a document one. So, even if the PDF is displayed fine for you, this feature might be turned on in any other user application.

Now, here comes the trick: you can use a small JavaScript code in order to turn it off by default while opening the PDF.

In Acrobat Pro, go Tools > JavaScript > Document JavaScripts, create a new Script (name it as you wish), click add and replace the existing bit by:

app.runtimeHighlight = false;

Click OK and you should be done.

Vinny

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Hi,

No, not talking about that. I know I can turn that off.

I am talking about the appearance of the checkbox. Acrobat has a set look for the checkbox, that thick black check mark. Even if I change the appearance of the checkbox in InDesign to be i.e a red cross, once it is exported and I select the box it will come back to the black check mark.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
Guide ,
Feb 26, 2018

Copy link to clipboard

Copied

Hmmmm, are you sure?

What you call "a set look for check boxes" is what you see when Highlight existing fields* is ON, don't you?

I am confused

* "Mettre les champs existants en surbrillance" in my French version

span.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Thank you so much!

You were right. This has fixed the issue.

Again thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
New Here ,
Nov 25, 2018

Copy link to clipboard

Copied

sorry how was this problem fixed? Im having the same issue..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2018 1
New Here ,
Dec 17, 2018

Copy link to clipboard

Copied

If you are in Acrobat DC, toggle this off under Preferences:Forms to show your form designs as you intended.

forms.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2018 1
New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

This has NOT been "solved." While you can turn off "Highlight existing fields" locally on your own computer, it will not correct it for other users who are sent a form and are opening it on their own computer where this feature is on by default and your checkboxes are back to behaving weirdly and displaying the default appearance rather than the custom appearances created in InDesign. In addition to this, it's helpful to highlight the form fields (not buttons or checkboxes) where you enter text, yet all interactive elements lumped together in this feature. Because of this, the javascript some people have shared as a solution (which also changes the Acrobat setting on the computer belonging to the user opening the file, which may upset people) is not an option for everyone (myself included).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
New Here ,
Jul 14, 2020

Copy link to clipboard

Copied

Thank you. This is helpful. 

Sure, not a full workaround, but gets me where I need to be. Much appreciated. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2020 0
Adobe Community Professional ,
Feb 26, 2018

Copy link to clipboard

Copied

As an example, I am repurposing the radio buttons from my first answer since they most closely resemble yours. Both are now changed to buttons, and I removed the rollover and/or click states. I put one under the other to demonstrate, but you would need to put them on top of each other to get the desired effect, after you get them working.

The checkmark button is set to Hidden Until Triggered. It won't show initially in Acrobat.

Screenshot 2018-02-26 08.19.13.png

The X icon has a show/hide action assigned to On Release or Tap to hide button 1 when it is clicked on, and show button 2. The visibility icons show that when you Release the mouse or Tap the screen, button 1 will hide and button 2 will show.

Screenshot 2018-02-26 08.19.22.png

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 1
New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

This has NOT been "solved." While you can turn off "Highlight existing fields" locally on YOUR OWN computer, it will not correct it for other users who are sent a form and are opening it on their own computer where this feature is on by default and your checkboxes are back to behaving weirdly and displaying the default appearance rather than the custom appearances created in InDesign. In addition to this, it's helpful to highlight the form fields (not buttons or checkboxes) where you enter text, yet all interactive elements lumped together in this feature. Because of this, the javascript some people have shared as a solution (which also changes the Acrobat setting on the computer belonging to the user opening the file, which may upset people) is not an option for everyone (myself included).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
Adobe Community Professional ,
Mar 04, 2020

Copy link to clipboard

Copied

Hi zero_cool1,

you are right. The main issue is not solved.

 

One cannot know the PDF reader app that will open the PDF with the form fields and if Forms preferences are on or off, also if JavaScript is enabled or not, if Adobe Reader is used or not. If on desktop machines or not. So I think, this problem cannot be solved. There is no way I can see with Acrobat's form field technology.

 

In a more narrow sense however the issue is solved. Provided Adobe Reader on desktop machines is used and it was communicated what turn on or off when viewing and using form fields.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
Community Beginner ,
May 02, 2020

Copy link to clipboard

Copied

Not solved-no one should tell every user of their form to change their prefernces. I just downloaded latest Apr 2020 version of acrobat reader to check on this issue (default check mark overriding indesign choice) and it is still this way. Adobe needs to fix this otherwise what is the point of selecting another choice. They own both pieces of software (indesign and acrobat) they can get them to not undo each other.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 02, 2020 1