Indesign cs6, export interactive pdf

New Here ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

When i export my interactive document to pdf, the result is not working well. All the roll over buttons are blinking when the mouse cursor point on it. also i have problem with layers. the appearance of layers is not as same as file, so some images go under other.

I have no problem in preview and it works well in preview but when i export to pdf the result is catastrophic. 

Is there anyone have a same problem? Or anyone know what i am doing wrong?

Views

15.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 21, 2013 May 21, 2013
It seems that for interactive elements, the stacking order is determined by the order in which the objects are converted to buttons. Try removing not just the actions, but turning them back into objects. Or, convert them into buttons in the oppsite order than you did the first time. It's maddening, but it should work. Apparently, button creation order trumps actual stacking order. Weird!

Likes

Translate

Translate
Adobe Community Professional ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

Are you viewing the PDF in Acrobat, reader, or some other viewer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

I am using acrobot reader, i have tried with different program and i have same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

I'm afraid I have no clue. Sorry.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

Any interactivity (e.g., buttons) always appear above anything on the page. That's just the way PDF works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

The buttons are in above, but the problem is is going under the other layers. I already set them to be in front. I export it with CS5 and still i have the same problems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 09, 2013 Apr 09, 2013

Copy link to clipboard

Copied

You're probably going to need to upload some screen captures to convey what you're experiencing. I don't recall layers being rearranged in the process of exporting an interactive PDF file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2013 May 15, 2013

Copy link to clipboard

Copied

I am having the same problem. Here are my screenshots. In Acrbat 10, in the layers pane, the layers names show up correctly, but in the actual graphics of the PDF, the layers are displayed in the reverse order.

Screen Shot 2013-05-15 at 10.54.01 AM.png

Screen Shot 2013-05-15 at 10.54.09 AM.png

Screen Shot 2013-05-15 at 10.58.16 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 14, 2013 May 14, 2013

Copy link to clipboard

Copied

Hi,

Did you ever find out how to fix this?  The same thing is happening to me.  I have a InDesign CS6 file with buttons that trigger animation.  It works great in preview and if I export to swf/html, but some elements (text and buttons that should be displayed) are missing when I export to the Interactive PDF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

No answer for you, but the same thing is happening for me! Mine is like a map with pop-up captions on it. The captions (which are hidden-until-triggered, actionless buttons) are on a layer ABOVE the marker buttons in InDesign, but Acrobat still displays the markers above the captions. I even tried removing all of the actions from the buttons in InDesign and adding them in Acrobat, but it still didn't work. Here's a screenshot from Acrobat of the caption showing up behind the orange markers instead of on top of them:

Screenshot.jpg

Also, you can see that the corner of the caption is disabling the rollover state on the marker - it should be covering up that little orange piece. What is going on!?!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

Are you trying to put static content above interactive content? I'm not

an expert in interactive PDF by any means, but I don't think that's

going to work.

Hopefully one of the PDF gurus will stop by and be able to confirm that.

Bob

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

The captions are buttons too (just with no actions on them), so I was hoping it would treat them as interactive content, but maybe it doesn't! Maybe I will try adding an  action to them to see if that helps. If not, I'll try the re-stacking idea, but that will take a long time since I have tons of them! Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

It seems that for interactive elements, the stacking order is determined by the order in which the objects are converted to buttons. Try removing not just the actions, but turning them back into objects. Or, convert them into buttons in the oppsite order than you did the first time. It's maddening, but it should work. Apparently, button creation order trumps actual stacking order. Weird!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2013 May 21, 2013

Copy link to clipboard

Copied

YAY!! It was the stacking order! And that seems to have solved the rollover transparency issue too. I will just have to undo/redo all of them now, but I'm so glad there's a solution. Thanks so much!! I will definitely remember that for the next project.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2013 May 23, 2013

Copy link to clipboard

Copied

It turns out there are a few workarounds to solving the stacking order issue: copy and pasting, setting tab order in InDesign, or setting tab order in Acrobat. All the soltutions can be found here: http://indesignsecrets.com/stacking-order-bug-exporting-interactive-pdf.php.

Be sure to read through the comments to get all the different solutions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2014 Oct 07, 2014

Copy link to clipboard

Copied

I'm having a similar problem with the interactive not working on buttons.

We're creating advertising, with multiple interactives - hyperlinks for the websites, and clear frames changed to buttons for facebook links and the like...

The links all work when we export from InDesign to PDF for the ads. But when the ads are put on the pages of the publication, then exported a second time in a PDF of the entire page, we keep only web address hyperlinks.

Any ideas on a solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2015 May 08, 2015

Copy link to clipboard

Copied

This is really poor. It has to be a bug.

I have a complex presentation to put together with many buttons on each page (kind of like HDRKarijo22's) and there's no way I'll be able to create all the buttons in a certain order, just to preserve the stacking order.

Imagine if the client wanted to add another button!.

I'd have to start that particular page again!

Not acceptable Adobe.

PLEASE FIX!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 04, 2021 May 04, 2021

Copy link to clipboard

Copied

Hi all,

I also have the same issue but I would like to share something I discovered.

I had a project where, when we roll over on thumbnail, we should see a bigger version of picture.
But it turns out that the tick boxes are over the picture, which its wrong.

Screenshot 2021-05-04 at 1.21.06 PM.jpg

So if you open the PDF in Acrobat and go for Prepare Form tool, you have all interactive objects shown as layers. SO I moved all layers related to big picture on the bottom of the list:

danporto2000_0-1620127518885.png

And now it shows me correctly:

danporto2000_1-1620127555501.png

I know this is not the solution, but I hope it can help you guys.

Best

Danilo

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

June 2021. This problem canno't be solved. I've try all this fixes for hours and hours. What Steve is suggesting, helps a bit, but the problem resides in the final PDF. If you open the file in Adobe Reader, it works great, but when you open the file in Chrome and Edge PDF reader, the result is a mess, because all buttons and form show in reverse stack order! InDesign have a terrible bug problem that needs to be fixed. Please take a look at this screen capture:

 

pdf.jpg

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Don't use roll over buttons for hyperlinks in Interactive PDF's, use simple hyperlinks using a word or words or an image or shape (maybe with a word, such as Home) on it). No multi-state activity works on PDFs nowadays.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Thanks for your suggestion. I used simple plain buttons. No roll over.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

I can't count how many times I've pointed out that with InDesign you are exporting an Adobe PDF. If it works in Reader or Acrobat on a desktop, that's all you're going to get. Browsers, third party readers and mobile devices are a crapshoot.

Add to that the fact that CS6 was version 8 of InDesign. It is unsupported under any modern Windows or Mac OS and is now 8 versions out of date.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Thanks for your suggestions. I get what you mean. The thing is that people use Chrome and other browsers to view PDFs, more than we think. I made my interactive PDF in InDesign CC 2021 (not CS6).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Then start a new discussion. This one is 8 years old!

But, again, it doesn't matter...if they're using browsers then create a form on the website and be done with it. It's a far more efficient way to handle things.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Sorry, but I prefer using another working software. InDesign is not working, not my problem. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines