Highlighted

Indesign Data Merge: Blank Line

New Here ,
Apr 23, 2020

Copy link to clipboard

Copied

I am trying to create a document that looks like the below. It needs to have a bold header name followed by a description. However not every document will have all of the fields. I have set up my data merge file but am still seeing blank lines when I export it. The "Remove Blank Lines for Empty Fields" is checked. Can this be fixed?

 

Document how I want it to look: 

Adobe 1.jpg

 

Set up the data merge tags: 

Indesign Data Merge tagsIndesign Data Merge tags

 

CSV file with my headers/descriptions. Blank spaces where I dont want text. LEDA and LED should not be included. 

Adobe 5.png

 

Merged product. There should not be any spaces in between "Lens" and "Fasteners".

Merged document. Showing line spacesMerged document. Showing line spaces

TOPICS
CC FAQ

Views

227

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Indesign Data Merge: Blank Line

New Here ,
Apr 23, 2020

Copy link to clipboard

Copied

I am trying to create a document that looks like the below. It needs to have a bold header name followed by a description. However not every document will have all of the fields. I have set up my data merge file but am still seeing blank lines when I export it. The "Remove Blank Lines for Empty Fields" is checked. Can this be fixed?

 

Document how I want it to look: 

Adobe 1.jpg

 

Set up the data merge tags: 

Indesign Data Merge tagsIndesign Data Merge tags

 

CSV file with my headers/descriptions. Blank spaces where I dont want text. LEDA and LED should not be included. 

Adobe 5.png

 

Merged product. There should not be any spaces in between "Lens" and "Fasteners".

Merged document. Showing line spacesMerged document. Showing line spaces

TOPICS
CC FAQ

Views

228

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 23, 2020 0
Adobe Community Professional ,
Apr 23, 2020

Copy link to clipboard

Copied

Hi newstarlight,

please show the result with Invisible Characters showing.

And perhaps also with a view from the Story Editor window.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2020 0
New Here ,
Apr 23, 2020

Copy link to clipboard

Copied

Thanks for the quick response. Below is what I see when I Show Hidden Characters. When I go to View-Story Editor-the only option that comes up is Hide Changes. 

 

Adobe 6.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2020 0
Adobe Community Professional ,
Apr 23, 2020

Copy link to clipboard

Copied

Hm. You could tackle the issue two-fold.

[1] Use a special, a unique sequence of characters as fill-in for your empty cells in your data source.

After merging the data remove the whole paragraph where that sequence occurs with GREP Find/Change.

 

[2] Leave your source as is. Do your merge like before. Search for all paragraphs with Unicode FEFF special characters and then remove that paragraphs. The TEXT pattern for that Unicode special character is <FEFF>. As you can see with two paragraphs above "LABEL:" it could be that more than one special character remains in a paragraph.

 

Hm. And I strongly urge you to change your data merge template document:

That is really important! Remove all empty paragraphs in the template. Control the distance from paragraph to paragraph with Space Before and Space After values.

 

Also read into this thread:

 

Data Merge – Blank Lines & Space removal does not work ?
Danny__ | Jul 22, 2019

https://community.adobe.com/t5/indesign/data-merge-blank-lines-space-removal-does-not-work/m-p/10549...

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2020 0