InDesign displays super glitchy

New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

I've updated to the latest InDesign, and used it for a while, then it started displaying super glitchy, especially on my 2nd monitor, but also on my MacBook Pro monitor. It seems stable as long as I don't move around the document or zoom, then Glitch City. It doen't happen in Photoshop or any other Adobe apps. Is there anything I can do to prevent this? Thanks.

 

Screen Shot 2021-05-27 at 1.19.41 PM.pngScreen Shot 2021-05-27 at 1.18.55 PM.png

TOPICS
Bug, Performance

Views

90

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Turn off GPU Performance

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

LATEST

This really needs to be a FAQ at the top of the forums.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines