Highlighted

InDesign interactive form special character not printing

Community Beginner ,
Jun 30, 2020

Copy link to clipboard

Copied

Hi everyone,

So I made an interactive form in InDesign CC to be filled and printed in other devices, that might not have adobe products to fill it. I tested it and could fill everything, everything works, except for the euro sign (€). It shows while filling the form, but trying to print it or save the document through the print page, it doesn't show. It isn't replace by any other symbol, simply doesn't show, as if nothing had been typed there. 

Does anyone know how to fix this? All the solutions I found so far aren't fitting for my problem.

Adobe Community Professional
Correct answer by Bevi_Chagnon___PubCom | Adobe Community Professional

Ensure that the form field calls for a Unicode (OpenType) font, and uses the Unicode character glyph for the Euro sign: Unicode 20AC, which produces that is readable by all computer technologies.

 

In the form field's Properties, are you able to set its format to use the € currency symbol by default?

 

TOPICS
Import and export, Print, Type

Views

64

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign interactive form special character not printing

Community Beginner ,
Jun 30, 2020

Copy link to clipboard

Copied

Hi everyone,

So I made an interactive form in InDesign CC to be filled and printed in other devices, that might not have adobe products to fill it. I tested it and could fill everything, everything works, except for the euro sign (€). It shows while filling the form, but trying to print it or save the document through the print page, it doesn't show. It isn't replace by any other symbol, simply doesn't show, as if nothing had been typed there. 

Does anyone know how to fix this? All the solutions I found so far aren't fitting for my problem.

Adobe Community Professional
Correct answer by Bevi_Chagnon___PubCom | Adobe Community Professional

Ensure that the form field calls for a Unicode (OpenType) font, and uses the Unicode character glyph for the Euro sign: Unicode 20AC, which produces that is readable by all computer technologies.

 

In the form field's Properties, are you able to set its format to use the € currency symbol by default?

 

TOPICS
Import and export, Print, Type

Views

65

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 30, 2020 0
Adobe Community Professional ,
Jun 30, 2020

Copy link to clipboard

Copied

Did you add the € in the empty text field and the user types the number after it?

 

Instead, you can format whatever number is added to the field with the currency symbol (there is a dropdown list of options, including the euro), but this has to be added in Acrobat. InDesign doesn't have the capability.

 

~Barb 

acro.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 1
Community Beginner ,
Jul 06, 2020

Copy link to clipboard

Copied

I added the currency in Acrobat, now it works perfectly. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 1
Adobe Community Professional ,
Jun 30, 2020

Copy link to clipboard

Copied

Ensure that the form field calls for a Unicode (OpenType) font, and uses the Unicode character glyph for the Euro sign: Unicode 20AC, which produces that is readable by all computer technologies.

 

In the form field's Properties, are you able to set its format to use the € currency symbol by default?

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs | Books @ www.PubCom.com/books — NEW! Accessible InDesign + PDF

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 1
Community Beginner ,
Jul 06, 2020

Copy link to clipboard

Copied

That was probably my problem, the font is not OpenType. Thanks for your answer!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 0
Adobe Community Professional ,
Jul 06, 2020

Copy link to clipboard

Copied

FYI, Unicode was universally accepted by the computer industry in 2000, and nearly all operating systems have completed the switch 20 years later.  OpenType is one kind of Unicode font.

 

Unless you intend to limit your designs to the standard ASCII characters that you can see on your keyboard (not the shortcut characters), I'd "retire" all those old TrueType and PostScript fonts for newer OpenType versions. You're going to continue to have this problem in the future, plus OpenType is required for EPUBs and accessible PDFs.

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs | Books @ www.PubCom.com/books — NEW! Accessible InDesign + PDF

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2020 0