InDesign keeps pasting as Arabic Language Dictionary

Participant ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

This is happening to us in the CC2018 13.1 version.

I only saw one earlier example mentioned in the Forums (with CC2014).

Whenever a chunk of text, or text box is pasted into a fresh document, the language is Arabic. [Basic Paragraph] and all other styles have been set to English USA, and even though I do a find format/change format in the offending document, it still pastes as Arabic.

Exporting to .IDML, and reimporting did not solve.

Views

2.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

Hi,

Can you see what happens when you change the language from the character panel when no documents are open in Indesign.

Also, did you try to clean both your cache and preferences?https://forums.adobe.com/thread/526990#

-Aman

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

Thank you, for the response, Aman.
This is not our issue.

(I am an Adobe Certified Expert in InDesign, by the way,) and this one is a stumper, a glitch. It's not preferences. When a text box is copied from the offending document and into another fresh Indesign document, from another computer (or TO another computer) it still pastes as Arabic, and flushes right.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

With no document open go to the Character Panel and make sure that the Language is set to "English USA". Then go into the Paragraph Styles Panel and double-click on the Basic Paragraph Style. In the Advanced Character Formats section make sure that "Language:" is set to English USA. After you've set it in these places, quit InDesign. When you relaunch it will become the default for the program. See screen shot.

Screen Shot 2018-04-30 at 3.30.24 PM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

Bill, Thank you.

This is not our issue.

(I am an Adobe Certified Expert in InDesign, by the way,) and this one is a stumper, a glitch. It's not preferences. When a text box is copied from the offending document and into another fresh Indesign document, from another computer (or TO another computer) it still pastes as Arabic, and flushes right.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

What happens if you adjust the language in the Character Panel and Paragraph Styles Panel after you paste in the text frames?

What happens if you just copy and paste the text from the original document into a fresh text frame in the new InDesign file?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

Thank you, Bill.

What happens if you adjust the language in the Character Panel and Paragraph Styles Panel after you paste in the text frames?

ANSWER: It fixes/works/becomes English USA.

What happens if you just copy and paste the text from the original document into a fresh text frame in the new InDesign file?

ANSWER: It pastes as Arabic (dictionary), and flushes right.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

Have you checked the Advanced character section of all the Paragraph and Character Styles in the original document for the language used? If there are any of the styles used there that are not defined as English USA then this behavior would not be unexpected. It is also possible that some individual characters in the document might have been defined in the Character Panel as Arabic. If you do a "Select All" in a text frame that is showing this behavior when pasted and look at the character panel and it is blank in the language field then that would mean that there is at least one character in the text that has been defined as Arabic since a blank language field would indicate multiple languages used in the text.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Thank you, Bill.

I've run a document-wide Find/Change format of Advanced Character Formats-->change Arabic to English USA.

Then, I've saved the file as a copy. When that copy doc is opened, and a text box is copied from it and pasted into another fresh document, Arabic reappears.Screen Shot 2018-05-02 at 11.29.15 AM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Is there a way to open/edit the idml file and change all references from Arabic to English USA?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

I'm not sure though if what you did would affect existing paragraph and character styles that have been applied. I've done similar find/changes in the past to change fonts globally only to find that it did not affect the fonts indicated in the paragraph and character styles. You may want to make sure that all styles have been changed and then apply them globally through find/change as well.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

  • Can you tell us if your InDesign is a Middle Eastern version or not?
  • Apparently this issue shows when you paste text, can you tell us what is the source of the text, eg. is it an existing InDesign document, MS. Word document or copying from the web?
  • Is the text you're copying and pasting has any Arabic in it?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

It is not a Middle Eastern version of InDesign.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 06, 2018 Jul 06, 2018

Copy link to clipboard

Copied

I am also having this problem. I installed the Arabic version to create one document. And even though I have now tried to uninstall that version, this issue of copy and paste still happens.

If I create a new document, and copy the information into it, it pastes in arabic. If I then override any style sheets to correct the issue in the second document, and copy it again into a third document, it seems to copy successfully. Obviously that is a long-winded, unsatisfactory solution.

Rick, did you find an answer?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

No answer. Still persists.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2018 Sep 05, 2018

Copy link to clipboard

Copied

I am having what I think is the exact same problem. I have INDD 2018 English USA version (latest version) on a Mac running OSX 10.12.6. I work in multiple languages for a client and often move back and forth from English to numerous languages such as Chinese, French, etc. I am taking text from a source INDD document and placing it into another INDD document(for example French from one INDD document and pasting it over existing French text in another INDD document, and so on for each language). For this particular project I am working in 6 different languages and in every single language when I paste the text from INDD source file to INDD destination file it pastes it as Arabic (or right to left) composition. Even though none of these languages I am working in are Arabic (or even right to left), the language indicator at the top tool bar switches it to Arabic, changes the text to Adobe World Composer, and makes it flush right (as you would in Arabic). I have to go back each time I cut and paste to change all of these settings. Never have encountered this problem in my years working in multiple languages until now. Adobe staff, have you found any resolution for this issue? It's really slowing my work down. Happy to provide additional information if needed

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 15, 2019 Jan 15, 2019

Copy link to clipboard

Copied

I'm having the exact same problem and it just started. InDesign is showing the dictionaries as Arabic almost everywhere and I've never used anything but English USA for language. It's now showing USA English in the dictionary prefs panel and shows the correct user dictionary file, but Character panel, spelling panel and spelling prefs panel all show Arabic and when I switch them they automatically switch back, even if I save and quit right after.

indesign-preferences-dictionary.png

Dictionary Prefs show the correct settings

indesign-character-dictionary.png

Character pane shows Arabic as language and when it is set to English it just resets to Arabic

indesign-spelling-dictionary.png

Spelling always shows Arabic as the language, which means none of the words ever are seen as valid.

indesign-user-dictionary.png

Changing the User Dictionary in the spelling tab simply switches back to Arabic right after clicking "Done"

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 15, 2019 Jan 15, 2019

Copy link to clipboard

Copied

Grrrrr.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2019 Feb 01, 2019

Copy link to clipboard

Copied

Having the same issue. None of the fixes on this thread have helped. This is infuriating. Once again thrilled that I'm renting software with these types of glitches.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2019 Oct 24, 2019

Copy link to clipboard

Copied

Did anyone ever find an answer to this? I'm having the same problem...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

Me too!!! Drives me nuts! 😞

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 25, 2020 Jul 25, 2020

Copy link to clipboard

Copied

Very sad to see this is not answered, but finally I know that I am not alone! It happens regardless of what language I'm pasting. Today it was Chinese- everything came in flush right and the characters were in reverse order, language dictionary was Arabic. One factor that is part of my situation is that the client built the file long ago using the ME version (for whatever reason since they only work in English). To get around this problem I only use Paragraph and Character styles and never any local formatting, then select the entire text and click the Remove All Overrides button in the Styles panel. But I shouldn't have to do that, as we all know.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

Hello — did anyone find a solution to this? My preferences, styles, dictionary all say 'English: USA" but all English text is underlined in red as a typo (dynamic spelling). 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Hi - Has anyone found a way to resolve this issue or find a work-around?  I am having all the same experiences described throughout this thread by others, I have my settings as English USA, have NEVER worked in Arabic, nor do I need to.  

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Same issue. Work in an english Indesign, writing in Danish, but copy turns out in greek.. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines