Highlighted

Indesign - Placing PSD file with Spot Channel with shadow

Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

I'm placing into Indesign a transparent PSD file with a Spot channel (left image). However, the drop shadow below the watch (not part of the Spot channel) displays incorrectly – a light grey. The right image is the same file without the Spot channel and displays the shadow as it should.

It's fine when importing into Ai, but seems Indesign cannot handle PSD files with transparency. Any thoughts?!

Screen Shot 2020-07-03 at 9.40.15 am.jpg

Adobe Community Professional
Correct answer by rob day | Adobe Community Professional

I think this has come up before–seems like a bug with PSDs. Try saving as a TIFF with Transparency checked:

 

Screen Shot 12.png

TOPICS
Bug, Import and export

Views

140

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Indesign - Placing PSD file with Spot Channel with shadow

Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

I'm placing into Indesign a transparent PSD file with a Spot channel (left image). However, the drop shadow below the watch (not part of the Spot channel) displays incorrectly – a light grey. The right image is the same file without the Spot channel and displays the shadow as it should.

It's fine when importing into Ai, but seems Indesign cannot handle PSD files with transparency. Any thoughts?!

Screen Shot 2020-07-03 at 9.40.15 am.jpg

Adobe Community Professional
Correct answer by rob day | Adobe Community Professional

I think this has come up before–seems like a bug with PSDs. Try saving as a TIFF with Transparency checked:

 

Screen Shot 12.png

TOPICS
Bug, Import and export

Views

141

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 02, 2020 0
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

What if the shadow is an independent psd file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 0
Community Beginner ,
Jul 02, 2020

Copy link to clipboard

Copied

Yes, have tried that and it works. A definite way around it. Just a bit annoying when you got to do it to 49 different files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 1
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

Have you reviewed the document within InDesign with the Overprint Preview option turned on that is found under the View menu?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 0
Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Yes and no change. When I fill the PSD with the same background flat colour as in the Indesign file, it's fine. So it seems Indesign has an issue dealing with transparent PSD files with a spot channel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0
Adobe Community Professional ,
Jul 03, 2020

Copy link to clipboard

Copied

I think this has come up before–seems like a bug with PSDs. Try saving as a TIFF with Transparency checked:

 

Screen Shot 12.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 2
Community Beginner ,
Jul 03, 2020

Copy link to clipboard

Copied

Rob, you're a gentlemam and a scholar. Well done. That is the winning ticket! Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 0
Adobe Community Professional ,
Jul 03, 2020

Copy link to clipboard

Copied

A placed PSD can only have one opacity mode. If your shadow layer is set to Multiply in Photoshop it won’t appear as Multiply in InDesign. Use Layer Options to hide  the shadow one one copy of the PSD. Duplicte the watch then hide all but the shadow layer and set its opacity to Multiply and move it below the other watch PSD.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 03, 2020 1
rob day LATEST
Adobe Community Professional ,
Jul 04, 2020

Copy link to clipboard

Copied

Hi Scott, that was my first thought, but the addition of a spot channel affects normal transparency in a PSD—only 100% transparent pixels are transparent in InDesign. It’s not a problem with a TIFF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 04, 2020 0