Highlighted

Indesign Server with C# showing no hypenations in Document

Community Beginner ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi Team,
I have created C# application which uses Indesign scripts to create a pdf document. Also I use Extendend script toolkit to run script and create pdf. Both ways are bieng used on Indesign server machine.
When I create pdf using  "Extendend script toolkit" (using Indesign Server), then the output of .indd file & .pdf file is correct and have proper hyphenation. But while creating pdf using  "C# application which uses same Indesign scripts and Template", then the output of .indd file & .pdf file is NOT correct and don't have hyphenations in entire document. When I try to open C# created INDD file in indesign application, Then hyphenation property is set to true but it dont apply/show hyphenations.

All the other changes made to document with scripts are present on both side documents. Only the hyphenation which is set in template is not working properly.
Below is screenshot of both files:
Extendend script toolkitExtendend script toolkit
C# ApplicationC# Application
Kindly help me out of this problem.

Thanks
Vikas Sehgal

 
Correct answer by vikas.seh | Community Beginner

Thanks for the reply. 
This got fixed by restarting the InDesign Server.

TOPICS
Bug, Publish online, Scripting, SDK, Server developers

Views

65

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Indesign Server with C# showing no hypenations in Document

Community Beginner ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi Team,
I have created C# application which uses Indesign scripts to create a pdf document. Also I use Extendend script toolkit to run script and create pdf. Both ways are bieng used on Indesign server machine.
When I create pdf using  "Extendend script toolkit" (using Indesign Server), then the output of .indd file & .pdf file is correct and have proper hyphenation. But while creating pdf using  "C# application which uses same Indesign scripts and Template", then the output of .indd file & .pdf file is NOT correct and don't have hyphenations in entire document. When I try to open C# created INDD file in indesign application, Then hyphenation property is set to true but it dont apply/show hyphenations.

All the other changes made to document with scripts are present on both side documents. Only the hyphenation which is set in template is not working properly.
Below is screenshot of both files:
Extendend script toolkitExtendend script toolkit
C# ApplicationC# Application
Kindly help me out of this problem.

Thanks
Vikas Sehgal

 
Correct answer by vikas.seh | Community Beginner

Thanks for the reply. 
This got fixed by restarting the InDesign Server.

TOPICS
Bug, Publish online, Scripting, SDK, Server developers

Views

66

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 15, 2020 0
Adobe Community Professional ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi Vikas,

I would check if the same paragraph composer is used and if the text has the same value for language.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Community Beginner ,
Jul 23, 2020

Copy link to clipboard

Copied

Thanks for the reply. 
This got fixed by restarting the InDesign Server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0