Highlighted

InDesign Table Grid Lines Disappear when Exported to PDF

Community Beginner ,
Oct 23, 2020

Copy link to clipboard

Copied

Hi,

 

I am currently using InDesign to create a document, and I have created a certain table in this document. This table has several rows and columns, and in some cells there are text and in other cells there are images directly inserted into the cell. My problem is that for no apparent reason some of the grid lines between the cells completely disappear or become invisible when I export to PDF. Furthermore, these specific lines become thinner when I zoom out in InDesign, but other lines do not. Does anyone have a solution to this?

InDesign:

Nate5E73_1-1603461192637.png

 

PDF:

Nate5E73_0-1603461164315.png

Thanks.

Adobe Community Professional
Correct answer by Eugene Tyson | Adobe Community Professional

Thank you - and I take it that you don't want those files shared publicly so I will respect that and not share the file unless you specify this.

 

Just to note - there's nothing wrong with what you have done - it's an  onscreen viewing issue, when I zoom in and out on both InDesign and PDF the row strokes are intact, but clearly there's a viewing issue with the strokes. 

 

On inspection - you can see the areas interacting with the stroke edges as these images do not have a transparent background, and interfere with the visibility of the stroke width of the table. 

 

Untitled.png

 
 
 
 

 

I'd be on the side of filing this as a BUG!

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

 

TOPICS
How to

Views

76

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

InDesign Table Grid Lines Disappear when Exported to PDF

Community Beginner ,
Oct 23, 2020

Copy link to clipboard

Copied

Hi,

 

I am currently using InDesign to create a document, and I have created a certain table in this document. This table has several rows and columns, and in some cells there are text and in other cells there are images directly inserted into the cell. My problem is that for no apparent reason some of the grid lines between the cells completely disappear or become invisible when I export to PDF. Furthermore, these specific lines become thinner when I zoom out in InDesign, but other lines do not. Does anyone have a solution to this?

InDesign:

Nate5E73_1-1603461192637.png

 

PDF:

Nate5E73_0-1603461164315.png

Thanks.

Adobe Community Professional
Correct answer by Eugene Tyson | Adobe Community Professional

Thank you - and I take it that you don't want those files shared publicly so I will respect that and not share the file unless you specify this.

 

Just to note - there's nothing wrong with what you have done - it's an  onscreen viewing issue, when I zoom in and out on both InDesign and PDF the row strokes are intact, but clearly there's a viewing issue with the strokes. 

 

On inspection - you can see the areas interacting with the stroke edges as these images do not have a transparent background, and interfere with the visibility of the stroke width of the table. 

 

Untitled.png

 
 
 
 

 

I'd be on the side of filing this as a BUG!

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

 

TOPICS
How to

Views

77

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 23, 2020 0
Adobe Community Professional ,
Oct 23, 2020

Copy link to clipboard

Copied

Have you placed the image into the cell as anchored text

Or did you convert the cell to a graphic cell?

 

If it's anchored it might be just going over the edge of the table, so the white background is blocking the image.

Try reducing the size of your image frames in the cells

 

or

 

Try converting it to a graphic cell. https://www.adobepress.com/articles/article.asp?p=2418568

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1
Community Beginner ,
Oct 23, 2020

Copy link to clipboard

Copied

I am pretty sure that these are graphic cells, considering as I have the option to convert them to text cells. Do you have any further solution?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1
Adobe Community Professional ,
Oct 23, 2020

Copy link to clipboard

Copied

Can you share the file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Community Beginner ,
Oct 23, 2020

Copy link to clipboard

Copied

Yes, what would be the best way to do that?

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Community Beginner ,
Oct 23, 2020

Copy link to clipboard

Copied

Eugene, I sent you the link in a private message. I only included the relevant page of the document.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 0
Adobe Community Professional ,
Oct 24, 2020

Copy link to clipboard

Copied

Thank you - and I take it that you don't want those files shared publicly so I will respect that and not share the file unless you specify this.

 

Just to note - there's nothing wrong with what you have done - it's an  onscreen viewing issue, when I zoom in and out on both InDesign and PDF the row strokes are intact, but clearly there's a viewing issue with the strokes. 

 

On inspection - you can see the areas interacting with the stroke edges as these images do not have a transparent background, and interfere with the visibility of the stroke width of the table. 

 

Untitled.png

 
 
 
 

 

I'd be on the side of filing this as a BUG!

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2020 1
Nate5E73 LATEST
Community Beginner ,
Oct 28, 2020

Copy link to clipboard

Copied

Thanks for your help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0
Adobe Community Professional ,
Oct 23, 2020

Copy link to clipboard

Copied

Put the file on dropbox and add the link in your reply (public) or message one of us individually (private).

 

~Barb 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1
Adobe Community Professional ,
Oct 23, 2020

Copy link to clipboard

Copied

Hi Nate,

if some of the cell borders look thinner than the others it could be that your PDF viewing app is "smoothing" lines or enhance edges for screen representation. You can do not much to prevent this. The only solution would be to have two stacked tables. One with the contents, text and graphics without borders; plus another table stacked on top with no contents and borders only.

 

At least that's my experience with phenomenons like that.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1