Keeping table rows together on same page

Contributor ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

16.0.1 Mac OS

 

I'm trying to keep the table rows together on the same page, but rows would automatically move to next page if the content of the whole row doesn't fit the text box:

 

Below the row should come "description"Below the row should come "description"but because the content of description row is too long to fit, it breaks off to new pagebut because the content of description row is too long to fit, it breaks off to new page

 

How do I get the "description" row to start immediately after "Name of policies..." row without moving to the next page? I tried the cell options -> rows and columns -> keep with next row, but it doesn't work.

TOPICS
How to

Views

139

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 28, 2020 Dec 28, 2020
Hi @wuts23143389:   InDesign table cells can't split across pages. Vote for the feature request here: https://indesign.uservoice.com/forums/601021-adobe-indesign-feature-requests/suggestions/33854788-option-to-split-table-rows-across-pages.   Here is a thread—with a link to a script—that may be helpful. I haven't tested it. https://community.adobe.com/t5/indesign/table-cells-breaking-across-page-boundaries/td-p/10030070?page=1   ~Barb     

Likes

translate

Translate

Translate
Enthusiast ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Your text is inserted into your text where the underlying Style has keep options that allow the "paragraph" to split anywhere, which is what you probably want for your body text, but it does affect tables as well.  Change the Keep Option to Keep All Lines In Paragraph together. I usually create a separate style to do that, and assign it to the line your table is inserted into.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Hi thank you for your reply,

 

I followed your advice but it still doesn't work for me:

 

Screen Shot 2020-12-28 at 15.37.11.png

 

I tried applying it to all rows and columns of the table as well, it still does not work. Would you happen to know what could have went wrong?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

It's not the styles IN the table that are the problem, but the style of the body text. I was going to suggest you force it to the next page by clicking in the paragraph above and have it start (Start Paragraph) in the next column/page but it looks like your table as a whole wouldn't fit on one page anyway, so it's going to have to break somewhere.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Do you mean I have to manually break it anyway? This is something I strive for:

 

Next row to fill in the spaces left on the pageNext row to fill in the spaces left on the pagethen automatically fill the rest of text on to the next pagethen automatically fill the rest of text on to the next page

 

Yes the table wouldn't fit one page anyway, but the way the rows need to be kept "whole" forbids me to let it flow like the examples I've attached here. Is there a way around it? I'm afraid I don't follow you. What do you mean by:

 

"It's not the styles IN the table that are the problem, but the style of the body text"

 

I adjusted the style of the body text -> keep options like you suggested.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Hi @wuts23143389:

 

InDesign table cells can't split across pages. Vote for the feature request here: https://indesign.uservoice.com/forums/601021-adobe-indesign-feature-requests/suggestions/33854788-op....

 

Here is a thread—with a link to a script—that may be helpful. I haven't tested it.

https://community.adobe.com/t5/indesign/table-cells-breaking-across-page-boundaries/td-p/10030070?pa...

 

~Barb 

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

Thank you

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 28, 2020 Dec 28, 2020

Copy link to clipboard

Copied

Are you sure you applied the "Keep with next row" settings to the Name row and not the Description row?

 

It worked for me, however, if the Description row gets too big, it will split regardless. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

Thank you. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines