Highlighted

Lag using the Text Tool

Community Beginner ,
Apr 22, 2020

Copy link to clipboard

Copied

Hi everyone,

 

I'm using the last version of inDesign 2020 on a Windows 10 machine and until recently I hadn't any problems, but in the last couple of weeks I'm experiencing huge lags using the Text Tool every time that more than a single document is opened. I searched the old posts and tried to delete the preferences folder with the software closed, but it doesn't solve the problem for me.

 

Any suggestions?

Topics

Bug, Performance, Type

Views

792

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lag using the Text Tool

Community Beginner ,
Apr 22, 2020

Copy link to clipboard

Copied

Hi everyone,

 

I'm using the last version of inDesign 2020 on a Windows 10 machine and until recently I hadn't any problems, but in the last couple of weeks I'm experiencing huge lags using the Text Tool every time that more than a single document is opened. I searched the old posts and tried to delete the preferences folder with the software closed, but it doesn't solve the problem for me.

 

Any suggestions?

Topics

Bug, Performance, Type

Views

793

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 22, 2020 0
Adobe Community Professional ,
Apr 22, 2020

Copy link to clipboard

Copied

Try the folowing:

 

  1. Reset your preferences by restarting ID, then holding in Ctrl+Alt+Shift, while the application starts up. It will take a little longer than usual to start up.
  2. Choose save as and save a copy of the document
  3. Choose View Menu > Display performance > Typical Display
  4. Choose Edit Menu > Preferences > Display performance. Change your default view to typical. Up the greeking value to 1pt more than your body copy. This will help ID not draw out each charcter when you are zoomed out. 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 22, 2020 0
Community Beginner ,
Apr 23, 2020

Copy link to clipboard

Copied

Thank you for the reply,

 

I've tried all the suggestions above, but none is working for me.

1. I already reset my preferences, before writing this post.

2. It is not a problem of a single document that is not working, but a recurrent problem every time I open two or more documents in inDesign.

3. The View Menu > Display performance was set on Typical Display all along.

4. I've tried this, but the lag (about 30-45 seconds each time I try to use the Type Tool) persisits even with values greater than 1pt more than the body copy of my documents.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2020 0
Adobe Community Professional ,
Apr 24, 2020

Copy link to clipboard

Copied

Thank you.

 

We work by a process of elimination, so your patience is appreciated.

 

Do you have a lot of fonts installed on your computer?

 

If yes, you may want to disable those you never use.

 

You obviously know what you're doing. So I'm sure you've checked this. You do have adequate free hard disk space and memory?

 

If all else fails, you may want to try rebuild the windows font cache. Here's how: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/how-to-reset-font-settin...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 1
Community Beginner ,
Apr 24, 2020

Copy link to clipboard

Copied

I might have a bunch of fonts installed, they should't be in a huge number, but I'll check if uninstalling them will solve the problem.


I've got more tha 100 GB of free space on the main hard disk (on wich the software is installed) and 320 GB of RAM (of wich only 23% is in use by the whole system. The Task Manager signals that inDesign is barely using 1 GB).

 

If deleting fonts won't work, I'll try to rebuild the windows font cache you linked for me, than I'll let you know.

 

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
Adobe Community Professional ,
Apr 24, 2020

Copy link to clipboard

Copied

How much RAM do you have?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
Community Beginner ,
Apr 24, 2020

Copy link to clipboard

Copied

I've got more tha 100 GB of free space on the main hard disk (on wich the software is installed) and 320 GB of RAM (of wich only 23% is in use by the whole system. The Task Manager signals that inDesign is barely using 1 GB).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
Adobe Community Professional ,
Apr 24, 2020

Copy link to clipboard

Copied

Gotta cover all bases right @Arch?

 

Cool, keep us in the loop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 1
Adobe Community Professional ,
Apr 24, 2020

Copy link to clipboard

Copied

You got a bit of a beast there @Arch.

 

Some resources you may want to check out before your font cull

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/fonts-which-included-fon...

 

https://windowsclassroom.com/install-fonts-windows-10/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 1
Community Beginner ,
Apr 25, 2020

Copy link to clipboard

Copied

Yeah, silly me, I meant that my machine has 32 GB of RAM, but I absentmindedly typed 320 and even dragged the error on the cut and paste! 😄

Jokes on me! 🙂

 

Anyway, my installed font count is 270. I did't remember the ones I installed myself, so I tried to reset the font cache following the instructions in you link, but for some reasons some of that files are always in use, so I can't remove them. I do not understand why, I'm pretty sure to have stopped the associated window service.

 

So I tested around a bit and I found that the problem is indeed linked to the fonts. The lag problem presents itself every time I open more than one inDesign document IF they upload fonts automatically from two different "Document fonts" folders.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 25, 2020 0