Highlighted

Not able to work on more than one document in InDesign 2020 on Windows 10

Explorer ,
Jun 25, 2020

Copy link to clipboard

Copied

Hey guys,

the issue occured since InDesign 15.02 and also in 15.03 / 15.1 / 15.1.1 Win10 (1909):

 

When opening two or more packaged documents with existing document fonts folders, there's a huge delay switching between the docs, selecting any elements or text within a text frame. Selected text takes 5-10 seconds minimum. When moving frames, scaling etc. ID is delayed heavily again. No work on the docs or exchange between is possible any more.

 

I was already able to locate the problem, it relates to a font issue in general, no specific font.

 

Here's how the problem can be remedied immediately:

- hide the control panel, everything runs smoothly again

- switch between documents that are not packaged / doesn't have document fonts folders, everything's fast

- rename only one 'document fonts' folder when several docs are open, e.g. remove the 's' letter from fonts, or move the folder - all docs run smoothly immediately

 

These tests I have done already:

- Remove all ID versions completey and re-install - no effect

- tried different fonts and types for packaging (ttf / otf) - no effect

- tried on several Win10 PCs with ID 15.1 and 15.1.1 - on every machine the same issue

- the bug occurs even on PCs without additional font management software

- no problems on iMac 27" - everything works fast here in current ID version

 

I had to return to ID 15.01 what works fine, but I and several colleagues / Win10 users can't work with more than one packaged document any more in current ID versions.

 

Is this issue already known by the community? Requesting a fix - this is no minor bug(!)

 

Thanks

Regards

 

{Renamed by MOD}

Hi all,

Good news – the issue was fixed in the pre release build 15.1.2.

 

Thanks to Adobe team and community members for the support!

Thread can be closed now.

Topics

Performance, Type

Views

226

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Not able to work on more than one document in InDesign 2020 on Windows 10

Explorer ,
Jun 25, 2020

Copy link to clipboard

Copied

Hey guys,

the issue occured since InDesign 15.02 and also in 15.03 / 15.1 / 15.1.1 Win10 (1909):

 

When opening two or more packaged documents with existing document fonts folders, there's a huge delay switching between the docs, selecting any elements or text within a text frame. Selected text takes 5-10 seconds minimum. When moving frames, scaling etc. ID is delayed heavily again. No work on the docs or exchange between is possible any more.

 

I was already able to locate the problem, it relates to a font issue in general, no specific font.

 

Here's how the problem can be remedied immediately:

- hide the control panel, everything runs smoothly again

- switch between documents that are not packaged / doesn't have document fonts folders, everything's fast

- rename only one 'document fonts' folder when several docs are open, e.g. remove the 's' letter from fonts, or move the folder - all docs run smoothly immediately

 

These tests I have done already:

- Remove all ID versions completey and re-install - no effect

- tried different fonts and types for packaging (ttf / otf) - no effect

- tried on several Win10 PCs with ID 15.1 and 15.1.1 - on every machine the same issue

- the bug occurs even on PCs without additional font management software

- no problems on iMac 27" - everything works fast here in current ID version

 

I had to return to ID 15.01 what works fine, but I and several colleagues / Win10 users can't work with more than one packaged document any more in current ID versions.

 

Is this issue already known by the community? Requesting a fix - this is no minor bug(!)

 

Thanks

Regards

 

{Renamed by MOD}

Hi all,

Good news – the issue was fixed in the pre release build 15.1.2.

 

Thanks to Adobe team and community members for the support!

Thread can be closed now.

Topics

Performance, Type

Views

227

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 25, 2020 1
Adobe Employee ,
Jun 25, 2020

Copy link to clipboard

Copied

Hi there,

 

Thanks for sharing all the information about your findings. I am sure it'll help community users having same concern as yours.

I tried to replicate this on my end but I could not. Are you getting this problem with some specific files?

I'd also request to share some sample files with us. We'll be happy to take a look into it.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0
Explorer ,
Jun 25, 2020

Copy link to clipboard

Copied

Hi Ashutosh,

Thank you for your reply. The issue is related to any file that has been packaged and contains a document fonts folder.

 

What I did to do a test run with most essential files from scratch:

- created two new documents with a blank A4 page

- containing a single text frame only with placeholder text, font Myriad Pro Regular default font

- saved and packaged each doc, named 'unnamed-1.indd' and 'unnamed-2.indd'

 

Two folders are created with .indd files and document font folders, containing 'AdobeFnt22.lst' and the 'MyriadPro-Regular.otf' font file.

 

Both docs can be opened after each other (this takes longer as usual, but they open). But as mentioned there's a permanent delay when trying to select frames, text or switching between the files.

By renaming only one of the document fonts folders, e.g. to 'document font' without the 's', it takes a few seconds and everything works fast and fine as it should. I can rename or move the folders vise versa, same effect.

 

Same effect also by hiding the control panel which shows font information etc. Can be done at 'Window' menu or simply by pressing the tab key. Everything is fast then. Showing the panel again causes the lag again.

 

There is obviously something wrong with the font access that leads to a fully workload of the InDesign app.

As mentioned this concerns several Win10 PCs, all tested with the same essential test files.

My own workstation is particularly affected: in ID 15.02 the font related bug was not that heavy at all but slower than 15.01. From 15.03 to 15.1 and now in current 15.1.1 the two test docs won't even open simultaneously. The first opens instantly, trying to open the second one gets ID hanging in a permament loop and the app can only be shutdown by Windows task manager.

The only version that works still fine for me is 15.01. Since this bug I can't make any update unfortunately.

 

Thanks

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0
Explorer ,
Jun 29, 2020

Copy link to clipboard

Copied

Hi Ashutosh,

could you have a look in between and replicate this on your end?

I also could provide the test files if needed, but I guess they are set up quickly as described.

 

Thanks

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Explorer ,
Jul 01, 2020

Copy link to clipboard

Copied

Hi Ashutosch,

Are there any updates about the topic? Do you need sample files for testing?

 

Our last conversation was a week ago, you offered to take a look into it.

 

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2020 0
Adobe Employee ,
Jul 01, 2020

Copy link to clipboard

Copied

Hi there,

 

Apologies for the delayed response. You may share the sample files with us. Please upload them to the Creative Cloud(or any other cloud service you prefer) and share it here. You may also DM me the information.
I'd also request sharing this concern on Adobe InDesign UserVoice(https://indesign.uservoice.com/). This forum is monitored by product team itself. They'll be happy to assist you.

 

Regards,

Ashutosh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2020 0
New Here ,
Jun 29, 2020

Copy link to clipboard

Copied

I have exactly the same problem for the last few months and it definitely happened after a major update to InDesign software. Thankfully I don't work on Indesign often but its basically unworkable when I have multiple documents open. The delay is just really bad. I can't even copy a paragraph or text as it just freezes the software up for a dozen or so seconds. There must be some bug as I had zero issues in the past 5 years using InDesign. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Explorer ,
Jun 29, 2020

Copy link to clipboard

Copied

Hey,

Good to meet other users having the same concerns. I think it's important now to test by Adobe stuff if this bug occurs on their (Windows) systems, too. As mentioned there were the same issus on several Win10 systems during my test.

 

It was surprisingly not that common every InDesign user works on more than one open document simultaneously so not everybody does even recognize the issue.

 

Maybe it affects a lot of users who don't know about because I couldn't find any related topic to this bug before getting in touch here at Adobe community. Looking forward to Adobe's feedback...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 29, 2020 0
Explorer ,
Jul 15, 2020

Copy link to clipboard

Copied

UPDATE 15/07/2020

 

In the meantime I sent my test files to Adobe team - it worked fine on their end.

Adobe suggested to start a live remote session to demonstrate the issue on my end.

 

We tried a lot to solve the problem e.g. resetting preferences etc. but nothing worked.
Finally it was suggested to repair all of Microsoft Visual C++ 2012 and higher versions to check further if the issue can be solved.

 

The related files have been repaired but InDesign 15.1.1 has still the same issue.

 

Thanks for the support so far.
Are there any other suggestions I could try on my end?
Otherwise I'll be waiting for next upcoming major update CC 2021 hoping everything will run o.k. then.
If it doesn't work even then we'll do a new system setup and check further.


Thanks
Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Most Valuable Participant ,
Jul 15, 2020

Copy link to clipboard

Copied

I can throw out a real shot in the dark only because it worked for me a couple of years ago when I was having a tremendous amount of performance issues.

Are you using one of the interactive Bing wallpapers? If you are, turn it off.

Also, disable any third party plugins, especially font autoactivation plugins.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Explorer ,
Jul 15, 2020

Copy link to clipboard

Copied

Bob,
Thanks for your suggestions on turning off wallpapers and plugins.
I don't use interactive wallpapers, not even a static one.

Regarding any third party plugins I've tested on three independent Win10 machines without font management software or any additional plugin for InDesign in order to do the most cleaned up test possible.
Resetted network card and offline test, too. All system drivers up-to-date.

On every machine the same issue with ID 15.1.1 working on more than one packaged doc containing 'Document fonts' folder in each package. Renaming or moving one of the folders enables fluent work on the fly, hiding control panel in ID also. As soon ID accesses fonts in the Document fonts folder issues occur, no matter what font is used.

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Most Valuable Participant ,
Jul 15, 2020

Copy link to clipboard

Copied

Now there's a hint! Yes, I've seen other reports of issues with document fonts folders.

You've pretty much nailed the ongoing solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Adobe Community Professional ,
Jul 15, 2020

Copy link to clipboard

Copied

Yes, known issue here as well: having a Docuents folder present (from packaged files) and you have a delay at opening. A known bug. Introduced in 15.03, 15.02 is fine as is CC 2019.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Explorer ,
Jul 15, 2020

Copy link to clipboard

Copied

I located that the issue is related to 'document fonts' folder only before I posted the topic here.
Would be very interested in what approaches others had in their reports – do you have referencies to any specific topics that would involve further considerations?

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Explorer ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi,

same here – from 15.02 on ID got worse and worse in performing opening packaged docs.

15.03 / 15.1 / and current 15.1.1 even slower.
Delay at opening depends on size of the doc (blank or big project) and if opened locally or from network.

 

Opened from desktop locally two blank (packaged) docs with single text frame containing placeholder text in Myriad Pro Regular is quite fast but operating within the docs like moving frames or selecting text is impossible to work on fluently.


Renaming/removing document fonts folder or hiding control panel fixes it temporary until you reverse it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Adobe Community Professional ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi ma64165225,

I can also see this issue. First I thought there is no delay until I used the Text Tool in InDesign.

With documents that rely on a Document fonts folder I see a delay of about 3 to 5 seconds every time I switch tools to the Text Tool because I want to edit or format text. Sometimes the delay is only 1 second. Could depend on the number of fonts in the Document fonts folder perhaps.

 

No real workaround yet.

I can avoid the delay if I move the Document fonts folder to InDesign's Fonts folder in the Application folder.

Just tested this.

 

I am using no font management software. My InDesign is version 15.1.1.103 on Windows 10.

Did you report that bug at InDesign UserVoice? https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs

If yes please share the URL so that we can vote for fixing the issue.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Adobe Employee ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi all,

 

Sorry to hear about the trouble. We're able to replicate this issue at our end. While we're investigating it, I would request if one of you could post this issue on UserVoice page (https://indesign.uservoice.com/) and paste the link here so that others can also upvote it.

This way you'll keep getting all the updates related to this issue. This is the best way of communicating with the Engineering and Product Management teams regarding issues so they can be fixed in upcoming releases. 

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Explorer ,
Jul 17, 2020

Copy link to clipboard

Copied

Hi Srishti,

Thanks for your response. I've posted the issue on UserVoice page here:

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/40930579-not-able-to-wo...

 

Thanks

Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2020 0
Explorer ,
Jul 23, 2020

Copy link to clipboard

Copied

Hi all,

Good news – the issue was fixed in the pre release build 15.1.2.

 

Thanks to Adobe team and community members for the support!

Thread can be closed now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Employee ,
Jul 26, 2020

Copy link to clipboard

Copied

Hi there,

 

We're glad to hear this. Please feel free to reach out if you run into any further issues or questions. We'd be happy to help.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 26, 2020 0