Optical Margin Alignment problem in ID CS6

Participant ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

I often use Optical Margin Alignment and am happy with the way it justifies the line. I am working on a project with footnotes and I am using the *, dagger etc as the references (rather than 1, 2, 3...). My problem is that with Opt. Margin Align, the * in the footnote sets outside the left margin. Is there anything I can do to change this?

Thanks for your help

Jon

Views

512

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

So it does. This issue is that the Optical Margin Alignment targets the contents of the linked frames, and not individual paragraphs, and the footnote is inside the same frame as the text.

The only suggestion I have is to use numbers or letters if you want hanging punctuation.

And consider putting this in as a feature request: Wishform - Adobe InDesign .

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

The Story dialog box has the check box for optical margin alignment and under that an entry box for “align based on size”...

Did you try changing the point size of the type in that dialog box?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Normally, you put the type size of the body text in the "align based on size" text box for best results. This is my first time combining hanging punctuation with footnotes, and I'm still messing around with it. If I increase the align based on size value (to let's say 90 pts for 12 pt text) , the asterisks do move inside the frame, but they bring the hanging punctuation in as well.

It seems like an either/or situation from my vantage point. Either you use hanging punctuation and numbered/lettered footnotes, or you turn off hanging functional and use the astericks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Thank you both for your suggestions, and I did try changing the point size butr it didn't give me the desired result.

But I have another problem with my footnotes...In the footnote options pulldown, under footnote formatting I have added em space for a separator but ID isn't inserting one. Changing the separator seems to have no effect. Any ideas??

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

yes, use the metacharacter for the em space

^m

InDesign CCss_031.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

That's what I'm doing and it seems to do nothing!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Show your hidden characters, what do you see?

InDesign CCss_032.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

I see a dot (space sign) not an em dash with a dot below

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Can you set up the same screen shot as mine? Show the footnote, with the hidden characters showing and then the Footnote options dialog box.

When you change the separator, it should change automatically on the page.

InDesign CCss_033.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

LATEST

I know this is an old post, but I found a solution that I can share in case anyone else is facing the same problem. 

In "Document footnote options" select "show prefix/suffix in" "Footnote Text". Set the prefix to "Hair space" (^<). Since the footnote will start with a space instead of the asteriks the Optical Alignment will not cause a problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines