Highlighted

Panel Not Loading in InDesign

Explorer ,
Jul 31, 2020

Copy link to clipboard

Copied

Hi everyone,

 

I recently submitted a Photoshop/InDesign extension to Adobe Exchange. The review team has informed me that the panel works in Photoshop but returns a blank screen in InDesign.

 

Everything works fine on my end and I haven't been able to reproduce the bug so I'm stumped as to what the issue could be. The HTML and JavaScript load function are almost identical on both versions so I'm thinking it must be a problem with my manifest.xml or xmi. I'm testing in InDesign 2019 and 2020.

 

Hoping to gain some clarity on what the problem might be. I've included my manifest.xml and mxi below. Any help is greatly appreciated, thanks!

 

manifest.xml

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<ExtensionManifest xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" ExtensionBundleId="com.scotton.sample" ExtensionBundleVersion="1.1.0" Version="5.0">
  <ExtensionList>
    <Extension Id="com.scotton.sample.panel" Version="1.1.0"/>
  </ExtensionList>
  <ExecutionEnvironment>
    <HostList>
      <Host Name="PHSP" Version="20.0" />
      <Host Name="PHXS" Version="20.0" />
      <Host Name="IDSN" Version="14.0" />
    </HostList>
    <LocaleList>
      <Locale Code="All"/>
    </LocaleList>
    <RequiredRuntimeList>
      <RequiredRuntime Name="CSXS" Version="5.0" />
    </RequiredRuntimeList>
  </ExecutionEnvironment>
  <DispatchInfoList>
    <Extension Id="com.scotton.sample.panel">
      <DispatchInfo>
        <Resources>
          <MainPath>./index.html</MainPath>
          <ScriptPath>./scripts/main.jsx</ScriptPath>
        </Resources>
        <Lifecycle>
          <AutoVisible>true</AutoVisible>
        </Lifecycle>
        <UI>
          <Type>Panel</Type>
          <Menu>Sample</Menu>
          <Geometry>
            <Size>
              <Height>400</Height>
              <Width>300</Width>
            </Size>
            <MaxSize>
              <Height>800</Height>
              <Width>1200</Width>
            </MaxSize>
            <MinSize>
              <Height>300</Height>
              <Width>200</Width>
            </MinSize>
          </Geometry>
        </UI>
      </DispatchInfo>
    </Extension>
  </DispatchInfoList>
</ExtensionManifest>

 

mxi

<?xml version="1.0" encoding="UTF-8"?>
<macromedia-extension
  id="com.scotton.sample"
  name="Sample"
  requires-restart="true"
  version="1.1.0">

  <author name="Shelby Cotton" />

  <description>
    <![CDATA[Description]]>
  </description>

  <ui-access>
    <![CDATA[Instructions]]>
  </ui-access>

  <products>
    <product familyname="Photoshop" platform="mac" version="20" />
    <product familyname="InDesign" platform="mac" version="14" />
  </products>

  <files>
    <file source="Extension/html.zxp"
      destination=""
      file-type="CSXS"
      products="Photoshop"
      platform="mac"
      minVersion="20.0" />

    <file source="Extension/html.zxp"
      destination=""
      file-type="CSXS"
      products="InDesign"
      platform="mac"
      minVersion="14.0" />
  </files>
</macromedia-extension>

Topics

Scripting, SDK

Views

58

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Panel Not Loading in InDesign

Explorer ,
Jul 31, 2020

Copy link to clipboard

Copied

Hi everyone,

 

I recently submitted a Photoshop/InDesign extension to Adobe Exchange. The review team has informed me that the panel works in Photoshop but returns a blank screen in InDesign.

 

Everything works fine on my end and I haven't been able to reproduce the bug so I'm stumped as to what the issue could be. The HTML and JavaScript load function are almost identical on both versions so I'm thinking it must be a problem with my manifest.xml or xmi. I'm testing in InDesign 2019 and 2020.

 

Hoping to gain some clarity on what the problem might be. I've included my manifest.xml and mxi below. Any help is greatly appreciated, thanks!

 

manifest.xml

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<ExtensionManifest xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" ExtensionBundleId="com.scotton.sample" ExtensionBundleVersion="1.1.0" Version="5.0">
  <ExtensionList>
    <Extension Id="com.scotton.sample.panel" Version="1.1.0"/>
  </ExtensionList>
  <ExecutionEnvironment>
    <HostList>
      <Host Name="PHSP" Version="20.0" />
      <Host Name="PHXS" Version="20.0" />
      <Host Name="IDSN" Version="14.0" />
    </HostList>
    <LocaleList>
      <Locale Code="All"/>
    </LocaleList>
    <RequiredRuntimeList>
      <RequiredRuntime Name="CSXS" Version="5.0" />
    </RequiredRuntimeList>
  </ExecutionEnvironment>
  <DispatchInfoList>
    <Extension Id="com.scotton.sample.panel">
      <DispatchInfo>
        <Resources>
          <MainPath>./index.html</MainPath>
          <ScriptPath>./scripts/main.jsx</ScriptPath>
        </Resources>
        <Lifecycle>
          <AutoVisible>true</AutoVisible>
        </Lifecycle>
        <UI>
          <Type>Panel</Type>
          <Menu>Sample</Menu>
          <Geometry>
            <Size>
              <Height>400</Height>
              <Width>300</Width>
            </Size>
            <MaxSize>
              <Height>800</Height>
              <Width>1200</Width>
            </MaxSize>
            <MinSize>
              <Height>300</Height>
              <Width>200</Width>
            </MinSize>
          </Geometry>
        </UI>
      </DispatchInfo>
    </Extension>
  </DispatchInfoList>
</ExtensionManifest>

 

mxi

<?xml version="1.0" encoding="UTF-8"?>
<macromedia-extension
  id="com.scotton.sample"
  name="Sample"
  requires-restart="true"
  version="1.1.0">

  <author name="Shelby Cotton" />

  <description>
    <![CDATA[Description]]>
  </description>

  <ui-access>
    <![CDATA[Instructions]]>
  </ui-access>

  <products>
    <product familyname="Photoshop" platform="mac" version="20" />
    <product familyname="InDesign" platform="mac" version="14" />
  </products>

  <files>
    <file source="Extension/html.zxp"
      destination=""
      file-type="CSXS"
      products="Photoshop"
      platform="mac"
      minVersion="20.0" />

    <file source="Extension/html.zxp"
      destination=""
      file-type="CSXS"
      products="InDesign"
      platform="mac"
      minVersion="14.0" />
  </files>
</macromedia-extension>

Topics

Scripting, SDK

Views

59

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 31, 2020 0
Adobe Community Professional ,
Aug 02, 2020

Copy link to clipboard

Copied

Should your "14" versions be "15" for InDesign?

Mike Witherell

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2020 0
Explorer ,
Aug 02, 2020

Copy link to clipboard

Copied

I followed the version numbers listed here. The minVersion should just mean the panel works with InDesign 2019 or later, correct?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2020 0