Highlighted

Paragraph format picked up an override -- how to get rid of it?

Engaged ,
Aug 08, 2020

Copy link to clipboard

Copied

Hi.I'm importing several Word documents into ID (v15.1.1/windows 10). During my style definition process, my main body style (paragraph ROP) somehow picked up an override for a superscript, so that when I apply paragraph ROP, it looks like this on the lower paragraph:

img_superscript.png

The problem is, that this override doesn't appear anywhere -- it just occurs. Here is the style definition for paragraph ROP, showing Position: Normal

img_paraformat.png

Yet, even though I make sure that Character Style is set to None, when I click paragraph ROP, it jumps to endnote_superscript.

img_char_format.png

Selecting all the text in the paragraph and clicking None in Character Style only sometimes removes the override. But sometimes paragraph ROP suddenly shows a + and I can remove the override on the Paragraph Styles list... but sometimes it stays superscript and both Character Styles is set to None and Paragraph Styles does not show an applied override. Then I have to fool around with it -- clicking, selecting, and eventually -- maybe -- it returns to what it should be. This wastes a lot of time, paragraph by paragraph. And if I don't fix it, it will go on for an entire book..

How can I just get rid of this annoying override?

Thanks as always to the community.

-j

Adobe Community Professional
Correct answer by Creamer Training | Adobe Community Professional

When you select the text and remove the override by setting the Character style to None and removing any remaining overrides on the Paragraph style--you are only fixing the immediate problem with that text. 

 

To remove the problem completely, deselect all text and objects. (I usually switch to the Selection tool and click on the pasteboard.) Then look at your Paragraph and Character styles--change to your desired settings.

 

Whenever you change a setting with nothing selected, you create a document preference. This is actually a feature--setting a temporary, document-based preference, but it causes lots of problems when it's done accidently. 

TOPICS
How to, Type

Views

82

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Paragraph format picked up an override -- how to get rid of it?

Engaged ,
Aug 08, 2020

Copy link to clipboard

Copied

Hi.I'm importing several Word documents into ID (v15.1.1/windows 10). During my style definition process, my main body style (paragraph ROP) somehow picked up an override for a superscript, so that when I apply paragraph ROP, it looks like this on the lower paragraph:

img_superscript.png

The problem is, that this override doesn't appear anywhere -- it just occurs. Here is the style definition for paragraph ROP, showing Position: Normal

img_paraformat.png

Yet, even though I make sure that Character Style is set to None, when I click paragraph ROP, it jumps to endnote_superscript.

img_char_format.png

Selecting all the text in the paragraph and clicking None in Character Style only sometimes removes the override. But sometimes paragraph ROP suddenly shows a + and I can remove the override on the Paragraph Styles list... but sometimes it stays superscript and both Character Styles is set to None and Paragraph Styles does not show an applied override. Then I have to fool around with it -- clicking, selecting, and eventually -- maybe -- it returns to what it should be. This wastes a lot of time, paragraph by paragraph. And if I don't fix it, it will go on for an entire book..

How can I just get rid of this annoying override?

Thanks as always to the community.

-j

Adobe Community Professional
Correct answer by Creamer Training | Adobe Community Professional

When you select the text and remove the override by setting the Character style to None and removing any remaining overrides on the Paragraph style--you are only fixing the immediate problem with that text. 

 

To remove the problem completely, deselect all text and objects. (I usually switch to the Selection tool and click on the pasteboard.) Then look at your Paragraph and Character styles--change to your desired settings.

 

Whenever you change a setting with nothing selected, you create a document preference. This is actually a feature--setting a temporary, document-based preference, but it causes lots of problems when it's done accidently. 

TOPICS
How to, Type

Views

83

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 08, 2020 0
Adobe Community Professional ,
Aug 08, 2020

Copy link to clipboard

Copied

Is the Endnote Superscript Character Style Nested into your ROP Style?

Check the Drop Caps and Nested Styles section of your ROP Paragraph Style. If there is a Nested Character Style, select the listing and Trash it.

Hope this helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2020 0
Engaged ,
Aug 08, 2020

Copy link to clipboard

Copied

Excellent thought... but no. No nested style hiding in my paragraph definition. Here's the Drop Caps/Nested Style definition:

img_nested_style.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2020 0
Adobe Community Professional ,
Aug 08, 2020

Copy link to clipboard

Copied

It's possible that whatever the issue, it's coming in from Word.

Try applying Basic Paragraph, then apply your ROP Style.

Also, are you bringing in formatting from Word? In Import Options, make sure to use Remove Styles and Formatting from Text and Tables. And I'll bet the issue will go away. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2020 0
Engaged ,
Aug 08, 2020

Copy link to clipboard

Copied

Your suggestion is close... but odd things are still happening. I opened the Import Options (shift-place) and have been trying different settings to see what works. Remove Styles and Formatting does work (thanks!) but it also removes Italics and other styles that are required in the -- ahem, extensive -- collection of endnotes that the author put in. I don't want to give up that formatting unless I have to. I'd only have to do it again manually.

 

I've also played with Import Styles Automatically because I have carefully named several paragraph styles in the source Word doc with the correct ID style names and applied them (the author uses direct formatting in his Word doc and has never even considered the use of styles; everything is "Normal" with some addition). Even so, the place process does not apply ID styles to the incoming formatted (by me) Word paragraphs -- it creates a new style with a duplicate style name marked with an in-basket. It does this even though I've tried both resolving Paragraph/Character Style Conflicts in favor of ID and setting up a Customized Style Input table. I just don't have it right... yet.

 

With all of that, I still wind up with a doc in ID where I can click "paragraph ROP" and get a paragraph with superscript applied to it -- even though that's nowhere in the style sheet.<sigh>

 

I will continue to experiment with Import Options (thanks again for reminding me of it). I may just end up importing as text and reformatting by hand referring to the author's original formatting. I can't quite mark your response as correct because I'm still having trouble with this, but you've gotten me a LOT closer to the solution. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 08, 2020 0
Adobe Community Professional ,
Aug 09, 2020

Copy link to clipboard

Copied

OK, here's a thought.

Try the following:

  1. Place your text with the formatting from Word.
  2. Use Find/Change (Edit > Find/Change) to find all text with the Format Italic (in the lower part of the Text section of Find/Change
  3. Use the Change Format section to apply your Italic Character Style to that Italic text.
  4. Select all the text you wish to apply ROP Style, but apply Basic Paragraph instead.

This will make all the text the default formatting of Basic Paragraph EXCEPT for the Italic text. One of the great things about Character Styles is "they always win." You can apply any Paragraph Style and the Character Styles will remain as is.

5. Now appy your ROP Paragraph Style and you should retain your italic formatting

Hope this helps!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2020 0
Adobe Community Professional ,
Aug 09, 2020

Copy link to clipboard

Copied

If you need any help with Find/Change, here's a link: https://helpx.adobe.com/in/indesign/using/find-change.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2020 0
Adobe Community Professional ,
Aug 09, 2020

Copy link to clipboard

Copied

When you select the text and remove the override by setting the Character style to None and removing any remaining overrides on the Paragraph style--you are only fixing the immediate problem with that text. 

 

To remove the problem completely, deselect all text and objects. (I usually switch to the Selection tool and click on the pasteboard.) Then look at your Paragraph and Character styles--change to your desired settings.

 

Whenever you change a setting with nothing selected, you create a document preference. This is actually a feature--setting a temporary, document-based preference, but it causes lots of problems when it's done accidently. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2020 1
Nedlaw LATEST
Engaged ,
Aug 09, 2020

Copy link to clipboard

Copied

Both Jeff's and Idea's suggestions worked and were valuable. Unfortunately I can only mark one as "correct," but you BOTH are, just differently.

 

Selecting on the pasteboard and choosing paragraph ROP allowed me to get rid of the annoying override in a general way. THAT WAS CORRECT and solved the problem.

 

Doing a Find/Replace on the Word formats and replacing them with ID formats allowed the Italic and boldface to survive the application of new paragraph formats. THAT WAS ALSO CORRECT and extremely helpful in this instance.

 

Thank you both. I am going to mark Idea's "remove the override" answer as correct, because that solved the proximate problem, but the suggestion about find/replace was also spot on.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 09, 2020 0