Pasting Copied Text From Excel Into InDesign Proble

Community Beginner ,
Mar 25, 2019 Mar 25, 2019

Copy link to clipboard

Copied

I am having a weird problem that I cannot figure out. I have used both Excel and Indesign for years and never had a problem with pasting long columns of text from Excel to InDesign. I have three columns of data in Excel. All plain text and formatted the same. I copied column A and pasted to Indesign. Once all pages were pasted, I was able to Command-Y to bring it to the text editor and format it using the paragraph style that I wanted. Worked fine. I then copied column B in Excel and pasted to InDesign, but the data is double spaced. Even if I do the Command-Y and apply the same paragraph style as column A, the data stays continues to have spaces between the lines (double spaced). I have looked at all settings in both programs and cannot come up with a reason it should be double spaced, or how to remove that. It seems that if I format two columns of text using the same Paragraph style, that should take care of it.

Views

573

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Apr 15, 2019 Apr 15, 2019
Barb:I never figured it out and had to hand work the data to get it in there. Could not come up with a reason. Did not appear to be formatting, either in Excel or InDesign.Anyway, I had to work around and move on.ThanksRichard Beirne

Likes

translate

Translate

Translate
Adobe Community Professional ,
Apr 15, 2019 Apr 15, 2019

Copy link to clipboard

Copied

Hi Richard:

Did you get this one figured out? Could be that the type is vertically justified or snapped to a baseline grid? Or maybe there is something off with the relatively new Space Between Paragraphs using the Same Style setting?

If you are still having this issue let us know and we can see if we can help.

~Barb

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2019 Apr 15, 2019

Copy link to clipboard

Copied

Barb:

I never figured it out and had to hand work the data to get it in there. Could not come up with a reason. Did not appear to be formatting, either in Excel or InDesign.

Anyway, I had to work around and move on.

Thanks

Richard Beirne

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2019 Apr 15, 2019

Copy link to clipboard

Copied

Hi Richard:

Glad you are back on track. If it happens again, just reply to this post and we'll see if we can give a hand. I'm sure there was a logical explanation—just not sure what it was.

~Barb

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2019 Jul 05, 2019

Copy link to clipboard

Copied

This issue is in your preferences. To paste the cell data as plain text, you need to go to preferences > clipboard handling and select "text only" from the When Pasting Text and Tables..." options. It defaults to All Information.

I would recommend switching it back after you are done though as it can be really helpful to have "all information" for most instances.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 15, 2019 Jul 15, 2019

Copy link to clipboard

Copied

I wish your answer would solve my issue, but it does not. I had already made

sure my Prefs for the clipboard were set at ³text-only². Whatever is causing

this weirdness is not that.

To repeat, I have an Excel spreadsheet with 4 columns. Column 1 has a list

of people. Column 2 has their locations. Column 3 has their years of

service. All three are formatted th same as plain text. Column 1 places into

Indesign just fine. When I place Column 2, the data is double spaced.

Nothing I do can change that except make the column as wide as the entire

page. (which makes layout almost impossible) I have checked the formatting

in both Excel and Indesign. I have set the Indesign prefs to handle the

clipboard as ³text-only².

After using Pagemaker for years followed by Indesign, this would not be an

issue. Weird.

Richard Beirne

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

Thank You Sbano-gensler it really helped me.  Thank You again.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

Thank You Sbano-gensler it really helped me.  Thank You again.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

This worked for me. I copy excel prices into Indesign tables aaalll tthhee ttiimmee!!   Finally something that worked for me!!!!!!!    Thank you!!!

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines