PDF from InDesign - Font Display Issue

Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

I'm having issues when converting InDesign file to pdf.

I placed a logo in the InDesign file. The logo was created in Illustrator and is outlined. The logo file looks good in InDesign, but when convert to pdf, the logo text does not display correctly. Specifically, the "l" in "Technologies" looks too fat. Everything else displays correctly.

Help, please!

 

[Note Screen shot added by moderator]

Screen Shot 2021-03-11 at 5.28.53 PM.png

TOPICS
Import and export, Performance, Print, Type

Views

156

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Engaged , Mar 11, 2021 Mar 11, 2021
Actually, it's BECAUSE the text has been converted to outlines the problem appears. There has been a long-standing issue with the display of PDFs of some san serif type converted to outlines. When the PDF is created, the artwork is compressed, as it should be, and for some reason it processes simple rectangles, like your lower case "L", differently than the other shapes. And for some reason this renders differently on the screen than the rest of the outlined letters and makes it look bolder. (It...

Likes

translate

Translate

Translate
Adobe Community Professional , Mar 11, 2021 Mar 11, 2021
That's a long standing issue with PDF display of certain letters.    If you zoom in / out it should rectify.    In your preferences, you can turn on 'Enhance Thin Lines' - which will work for your machine. But it won't be saved in the file as a preference for other people when they open it.   And finally - you don't know what PDF viewer people are viewing it in - Acrobat is the only true PDF reader, as it's Adobe Acrobat and Adobe authored the PDF format.    Any other PDF reader, Foxit, Chrome, ...

Likes

translate

Translate

Translate
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Back in Illustrator, convert the live text to outlines. This will make a better translation of the stroke on the "L".

Then place it in InDesign.

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs |
Books & Classes | PubCom

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Actually, it's BECAUSE the text has been converted to outlines the problem appears.

 

There has been a long-standing issue with the display of PDFs of some san serif type converted to outlines. When the PDF is created, the artwork is compressed, as it should be, and for some reason it processes simple rectangles, like your lower case "L", differently than the other shapes. And for some reason this renders differently on the screen than the rest of the outlined letters and makes it look bolder. (It would have happened if you had an uppercase "I" as well. Weirdly, it doesn't happen with compound letters, like a lower case "i"... the bottom "rectangle" renders fine.)

 

In any case, this is a display issue and doesn't affect printing. If you zoom in, you will see the letter looks fine. In fact, it may change/disappear depending on what magnification you are at. It also seems to happen more often when viewing on Windows.

One possible solution is to go into your Acrobat prefences, and under Page Display > Rendering... uncheck Enhance Thin Lines. That seems to have worked for many of my clients that have complained about this very issue.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

quote

Actually, it's BECAUSE the text has been converted to outlines the problem appears.

By @roaringmousegraphics

 

OP doesn't say he converted it to outlines (or curves or paths). He said it "is outlined," which I interpreted as having a stroke on live text.

Ambiguos wording.

@justmycupoftea can you clarify the steps you took in Illustrator to create this?

Did you use the utilitly Type / Creat Outlines? (this creates static, dead shapes that look like the text)

Or did you put a stroke on the text? (which keeps the text live)

 

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs |
Books & Classes | PubCom

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Text was converted to outlines (did not add a stroke) in Illstrator - leaving as editable text seems to have fixed the issue!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

I think you're correct! Changing to editable text in ai seems to have fixed the issue! Thanks so much!

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

That's a long standing issue with PDF display of certain letters. 

 

If you zoom in / out it should rectify. 

 

In your preferences, you can turn on 'Enhance Thin Lines' - which will work for your machine.

But it won't be saved in the file as a preference for other people when they open it.

 

And finally - you don't know what PDF viewer people are viewing it in - Acrobat is the only true PDF reader, as it's Adobe Acrobat and Adobe authored the PDF format. 

 

Any other PDF reader, Foxit, Chrome, Preview etc. are 3rd party and don't conform to all modules of a PDF anyway. 

 

 

Your other option is to have Live Text version of your logo - and place that in InDesign. 

PDFs will automatically embed the PDF. And having the live font in the PDF would enable the font 'hinting' (you can look that up).

 

Hope that helps.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

For the record - it's a display issue - it should print fine.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Thanks so much - this seems to have worked!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

I had already outlined the text, but thanks for the suggestion.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines