Highlighted

Photoshop layers not pasting in place in InDesign

New Here ,
Mar 07, 2020

Copy link to clipboard

Copied

I have a PSD file with two layers. I want to import the two layers individually into InDesign, whilst keeping both layers in the exact same position. I copy and paste in place the first image frame but when I try and import the second layer into that frame, it brings it in at a different percentage and hence the image shifts and does not sit on top of the first. I’m sure I’m not doing anything different to what I’ve done many times in the past. It’s driving me nuts!

Most Valuable Participant
Correct answer by Willi Adelberger | Most Valuable Participant

In Photoshop:

  1. Save each layer state as Layer Composition
    Windows > Layer Comps

In InDesign:

  1. File > Place
    Tick Show Import options
  2. Select the desired Layer Composition.
    Don't use last State of the file.
  3. Do the same with the next layer.

Never copy and paste from Photoshop to InDesign. Never!

Views

165

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Photoshop layers not pasting in place in InDesign

New Here ,
Mar 07, 2020

Copy link to clipboard

Copied

I have a PSD file with two layers. I want to import the two layers individually into InDesign, whilst keeping both layers in the exact same position. I copy and paste in place the first image frame but when I try and import the second layer into that frame, it brings it in at a different percentage and hence the image shifts and does not sit on top of the first. I’m sure I’m not doing anything different to what I’ve done many times in the past. It’s driving me nuts!

Most Valuable Participant
Correct answer by Willi Adelberger | Most Valuable Participant

In Photoshop:

  1. Save each layer state as Layer Composition
    Windows > Layer Comps

In InDesign:

  1. File > Place
    Tick Show Import options
  2. Select the desired Layer Composition.
    Don't use last State of the file.
  3. Do the same with the next layer.

Never copy and paste from Photoshop to InDesign. Never!

Views

166

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Mar 07, 2020

Copy link to clipboard

Copied

Make sure that all fitting options are disabled and do not place the image twice. Place it, copy the frame, paste the frame in place and then right click and choose layer options for the graphic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Mar 07, 2020

Copy link to clipboard

Copied

In Photoshop:

  1. Save each layer state as Layer Composition
    Windows > Layer Comps

In InDesign:

  1. File > Place
    Tick Show Import options
  2. Select the desired Layer Composition.
    Don't use last State of the file.
  3. Do the same with the next layer.

Never copy and paste from Photoshop to InDesign. Never!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Mar 07, 2020

Copy link to clipboard

Copied

The OP did not copy / paste from Photoshop, they placed the image in InDesign and the copy / pasted that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...