Photoshop missing in "edit with" context menu for images

Engaged ,
May 02, 2017 May 02, 2017

Copy link to clipboard

Copied

I am using Indesign cc 2017. My "edit with" right click menu does not have Photoshop listed. I have to click "other" and then locate photoshop.exe everytime I want to edit my image in photoshop. What should I do so that photoshop is always listed in my "edit with" context menu?edit with photoshop missing.jpg

Views

5.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 04, 2019 Jun 04, 2019

Copy link to clipboard

Copied

Hi, I've just had the same issue with InDesign CC 2019 (no "open with Photoshop" option) and wanted to log my solution. (BobLevine was right)

I fixed it by setting Photoshop as the default application in Windows Explorer for .jpg files:

Then started indesign, and the Photoshop option was back:

Then I set the default .jpg app back to Photos as it was before, and the option still shows in InDesign.

Hope that helps someone.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2019 Sep 16, 2019

Copy link to clipboard

Copied

I've just had the same issue, i did what you said, it worked!! thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 23, 2020 Sep 23, 2020

Copy link to clipboard

Copied

This solution worked for me too after tearing my hair out for 2 days having to locate Photoshop every time I needed to edit. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Worked for me to! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

Hi I am setting up a new computer and having the same problem. I did your process and I want to log that it did not work for me. Any other fixes out there?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

LATEST

Actually I had to do it in windows explorer for every file type and now it is working. However, I have to keep it set to photoshop in order for indesign to recognize it. That's not a very useful solution as I am often trying to look at files without photoshop open. 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines