placing image changes colors RGB -> CMYK

New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Hi fellow designers,

I'm creating a document in InDesign working in RGB mode since it's purpose is only web-view pdf.
It consists of both text and images. On one of the pages I have to insert a certain amount of logo's from several companies.

However, one of those logo's (a .png created in Photoshop, using greyscale workspace) causes the colors I use in the document for e.g. text, to change from bright RGB colors to flat CMYK-like colors.

At first I thought it was only an indesign preview thing, which would be solved by creating an RGB PDF. But unfortunately the color stays flat even in pdf. I've tried all sorts of ways to both save the images and export the pdf but the problem continues.

Does anybody have to answer to solve this problem?

Thanks.

Views

16.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Guide , Mar 29, 2019 Mar 29, 2019
First thing to check: Is your document blend space set to RGB?

Likes

Translate

Translate
Adobe Community Professional ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Hi,

  • Can you share the OS and version of InDesign you are using. I think a screenshot of the export to PDF window showing the colour correction setting/PDF standard selected might put us on the right path to help.
  • Can you confirm that when you export without the grayscale logo (because you deleted it-backup first, please), the colours are OK in the pdf?
  • Have you tried to convert the logo from grayscale to RGB in Photoshop before reimporting it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

First thing to check: Is your document blend space set to RGB?

Indesign0.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Thanks all of you!

It eventually seemed to be a combination of this setting Vinny38 was talking about(I feel a bit stupid overlooking this), and an error in saving the png in Photoshop due to a missing plug-in setting.

Anyway, problem solved!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

creativeadvantech_0-1621438742908.png

Hi, searched and saw this post, having the same issue, RGB images looks CMYK flat in InDesign, I've made sure Transparency Blend Space is set to RGB, Document setting is set to Web.  But as you can see from my attachement, left being InDesign, right being Photoshop.  the InDesign color clearly is flatter.  This is not going to be printed, only view on monitor so I want to retain the RGB vibrant color.  TIA.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

LATEST

When you select the image and check Link Info, what is the listed ICC Profile? If it is Document RGB try resaving the image and make sure you check Embed Color Profile in the Save dialog. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 29, 2019 Mar 29, 2019

Copy link to clipboard

Copied

Also, make sure you have Overprint Preview and Proof Colors turned off

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines