Highlighted

Problème publipostage Indesign

New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Sur Mac, il faut, pour la liste Excel à utiliser sur Indesign comme source de données :

- Aucune entête de colonne ne doit être vide

- Intituler la colonne, précéder le nom ex. « drapeaux » de ‘@ (apostrophe + arobase)

- Se positionner sur le nom du drapeau choisi (dans son dossier), option+command+C puis coller dans la cellule Excel voulue

- Toujours pour une utilisation sur Mac, dans le tableau Excel, faire « rechercher » les « / »  puis le remplacer par « : » partout

-  Enregistrer le fichier Excel en « texte (séparateur : tabulation) (.txt)

- Sélectionner sur Indesign cette source de données en .txt

 

Aucun souci pour les textes, mais les images ne viennent jamais.

Quelque chose est-il mal paramètré sur Mac ou sur Indesign ?

Toujours le même message :

La source de données renvoie à une ou plusieurs images manquantes.

Les images manquantes ne peuvent être ni pré visualisées ni fusionnées.

Au moment de créer un document fusionné, vous pourrez choisir de générer la liste de toutes les images manquantes.

 

Les « options d’importation des sources de données » sont-elles correctes

(Néanmoins, j’ai essayé avec d’autres paramètres, ça ne change rien !)

Délimiteur : Tabulation

Codage : ASCII

Plate-forme : Macintosh

Conserver les espaces dans les sources de données : non coché

Views

597

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problème publipostage Indesign

New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Sur Mac, il faut, pour la liste Excel à utiliser sur Indesign comme source de données :

- Aucune entête de colonne ne doit être vide

- Intituler la colonne, précéder le nom ex. « drapeaux » de ‘@ (apostrophe + arobase)

- Se positionner sur le nom du drapeau choisi (dans son dossier), option+command+C puis coller dans la cellule Excel voulue

- Toujours pour une utilisation sur Mac, dans le tableau Excel, faire « rechercher » les « / »  puis le remplacer par « : » partout

-  Enregistrer le fichier Excel en « texte (séparateur : tabulation) (.txt)

- Sélectionner sur Indesign cette source de données en .txt

 

Aucun souci pour les textes, mais les images ne viennent jamais.

Quelque chose est-il mal paramètré sur Mac ou sur Indesign ?

Toujours le même message :

La source de données renvoie à une ou plusieurs images manquantes.

Les images manquantes ne peuvent être ni pré visualisées ni fusionnées.

Au moment de créer un document fusionné, vous pourrez choisir de générer la liste de toutes les images manquantes.

 

Les « options d’importation des sources de données » sont-elles correctes

(Néanmoins, j’ai essayé avec d’autres paramètres, ça ne change rien !)

Délimiteur : Tabulation

Codage : ASCII

Plate-forme : Macintosh

Conserver les espaces dans les sources de données : non coché

Views

598

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 26, 2019 0
Adobe Community Professional ,
Sep 26, 2019

Copy link to clipboard

Copied

Bonjour, il me semble qu’il y a plus simple 😉

Pour commencer la page d’aide InDesign sur les fusions de données :

https://helpx.adobe.com/fr/indesign/using/data-merge.html

 

Ensuite pour les images il faut juste un @ avant le nom du champ et les images doivent être dans un dossier bien préparé pour éviter toute surprise. Soit ajouter un chemin de fichier spécifique soit un dossier mais bien vérifier le chemin, les noms et éviter les caractères spéciaux, accentués et autre du genre / ^ pour ne pas avoir de soucis.

Pour ma part je préfère utiliser le séparateur (virgule) dans un fichier. txt, c’est mon approche mais il y en a d’autres.

Selon les versions d’Excel le résultat varie et il peut être très différent.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Bonjour et merci beaucoup. Mais je pense que tu es sur PC. Sur Mac il n’est pas possible de mettre juste « @ » arobase, il faut impérativement mettre une « ‘ » apostrophe devant l’arobase. Ensuite, j’ai également fait attention, partout, à l’écriture. Mon dossier s’appelle MADE-ESSAI, à l’intérieur les dossiers : drapeauxRonds, LOGO, QRcodes, ma liste Excel et mon gabarit Indesign. Je n’ai pas le séparateur (virgule) dans un fichier. Txt (dernière version Excel – dernière version Indesign) J’ai essayé également avec UTF-16 .txt, ça ne change rien. Je vais à nouveau consulter ton lien Adobe, mais je ne vois vraiment pas de problème ! Merci encore

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
Guide ,
Sep 26, 2019

Copy link to clipboard

Copied

Bonjour

Le message renvoyé indique que le chemin n'est pas bon.

Je suis sur PC donc je ne suis pas familier des chemins Mac, par contre il est probable que, Mac ou PC, tu n'aies pas besoin du chemin complet, mais simplement du chemin relatif.

Autrement dit, si ton fichier .txt (ou .csv si tu aimes souffrir ^^) est dans ton dossier MADE-ESSAI, le chemin d'une image peut simplement être \drapeauxRonds\pays.ai 

Donc essaie de supprimer toute la partie du chemin qui précède le dossier dans lequel se situe ton fichier .txt

 

Ainsi, si tu déplaces ton dossier MADE-ESSAI, tu n'auras pas de souci, sinon... je te laisse deviner ^^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Oui, absolument, tu as raison, le chemin relatif semble suffire et c'est déjà un très bon point ! Merci

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Néanmoins, le problème est toujours là, pas d'images. Toujours le même message : La source de données renvoie à une ou plusieurs images manquantes....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
Guide ,
Sep 26, 2019

Copy link to clipboard

Copied

Ce message apparaît lorsque tu te coches la case "Aperçu" n'est-ce-pas ? Est-ce sur tous les enregistrements ou seulement quelques-uns ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
Guide ,
Sep 26, 2019

Copy link to clipboard

Copied

Après une brève recherche sur la toile, il semblerait que selon l'OS, il faudrait utiliser un / plutôt que deux points. Tu peux essayer /drapeauxRonds/France.ai ? Sinon, il faudrait qu'un utilisateur de Mac donne son avis car là, je suis à l'aveugle ^^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
New Here ,
Sep 26, 2019

Copy link to clipboard

Copied

Quand je coche la case aperçu, oui. Sur tous les fichiers, oui.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 26, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Je viens d'essayer à nouveau. Non, ça ne fonctionne pas avec les " /" ! Merci tout de même de ton aide. J'avais comme information qu'il fallait impérativement transformer les "/" en ":" Je vais déposer l'image d'un fichier très simplifié.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Vérification faite, le compte utilisateur porte bien le même nom que le dossier de départ. Je n'ai plus d'idées et je ne sais pas pourquoi Mac démarre ses liens par ":User" et non "Macintoch HD". Sur PC, le lien est le suivant : K:\FR-GON\SIGNALETIQUE\Technique\___ALICE\ESSAI-ENS-BIJ\MADE-2020\MADE-2020\drapeauxRonds\France.ai

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
Guide ,
Sep 27, 2019

Copy link to clipboard

Copied

Hmmmm... Il y a définitivement quelque chose qui ne va pas avec la syntaxe du chemin.

Voici un truc que tu peux essayer afin d'être sûre de la syntaxe :

Crée un bloc et importe une des images que tu veux fusionner. Puis dans ta palette des liens > Copier les informations > Copier le chemin de style de plateforme.

 

Colle ce chemin et dis-nous ce que ça donne...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 1
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

1ère fois que j'utilise ce site, peut-on dans la réponse déposer une pièce jointe ? Je ne vois pas où

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Excellente idée !!!! Le chemin est : Macintosh HD:Users:michelechaullet:Desktop:MADE:DRAPEAU:France.ai

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

L'espace entre "Macintosh" et "HD" ne pose pas de problème ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
Guide ,
Sep 27, 2019

Copy link to clipboard

Copied

A priori l'espace ne devrait pas poser de souci, surtout si tu utilises le chemin relatif, ce que je conseille toujours. Par contre, ce qui m'interpelle, c'est que ton dossier s'appelle MADE et non MADE-ESSAI comme dans tes précédents screenshots... c'est normal ça ??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
Guide ,
Sep 27, 2019

Copy link to clipboard

Copied

Donc logiquement, ton chemin devrait simplement être :DRAPEAU:France.ai

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Ça nous avions essayé hier, je viens de faire l'essai à nouveau, ça ne fonctionne pas. Et c'est bizarre où que je sois sur le Mac, bureau, documents, images, etc. le lien commence toujours par ":User", jamais, jamais par"Macintosh HD"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Oh oui !!! Un grand pas en avant !! J'ai copié ce lien sur la première ligne de mon fichier Excel et ça fonctionne sur la première ligne !!!!! Si je regarde à nouveau mes anciens fichiers Excel, le lien était toujours ":User:michelechaullet:Desktop:MADE:DRAPEAU:France.ai", tous me anciens Excel commencent par ":User" ! Reste à savoir pourquoi lorsque je me place sur mon drapeau, dans son dossier, que je fais option+command+c (copier le lien) puis coller dans la cellule concernée Excel, ça ne démarre jamais par Macintosh "Macintosh HD" mais par ":User"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Ça nous avions essayé hier, je viens de faire l'essai à nouveau, ça ne fonctionne pas. Et c'est bizarre où que je sois sur le Mac, bureau, documents, images, etc. le lien commence toujours par ":User", jamais, jamais par"Macintosh HD".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Le chemin relatif, sur Mac, ne fonctionne pas. Mais peut-être du fait qu'il ne trouve jamais le chemin du "Macintosh HD", mais de":User"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
Guide ,
Sep 27, 2019

Copy link to clipboard

Copied

Le chemin relatif devrait fonctionner, sur mac comme sur PC. ATTENTION Il est relatif par rapport à l'endroit où est enregistré le fichier de source de données (.txt) et non le fichier indesign. Tu as envoyé beaucoup de screenshots et j'avoue être perdu. Un coup, c'est MADE-ESSAI, puis MADE, un coup DRAPEAU, un coup drapeauxRonds... bref je suis un peu perdu.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Le dossier simplifié est "MADE" et "DRAPEAU". Tu as raison, le chemin relatif devrait fonctionner, mais ce n'est pas le cas. Je pense avoir un problème de configuration sur le MAC sur tous mes MAC. Le compte utilisateur sur Mac doit porter le même nom que le dossier de départ. Je vais m'occuper de ce problème (qui résoudra peut-être tout le reste !)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Ça ne peut pas être un problème sur Excel ? Une préférence cochée ou au contraire non cochée ?dès que je colle le lien une partie serait supprimée

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
Sep 27, 2019

Copy link to clipboard

Copied

Après confirmation de Apple, c'est normal que les liens commencent par :User. Tous mes liens commencent par :User mais Indesign ne les comprend pas. Merci tout de même infiniment à tous !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 27, 2019 0
New Here ,
May 06, 2020

Copy link to clipboard

Copied

Bonjour, j'utilise un MAC et obtiens le même message d'erreur que toi lors de ma Fusion de Donéées dans InDesign - les photos ne fonctionnent pas. Comment as-tu solutionné ton problème ? Merci beaucoup!

Capture d’écran 2020-05-06 à 15.14.57.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2020 0
New Here ,
Jul 02, 2020

Copy link to clipboard

Copied

Bonjour, je viens de voir ce poste car j'avais le même problème sur mac et je l'ai résolu en mettant les images au même niveau que la source du fichier excell plutôt que dans un dossier séparé.

J'ai enregistré la base de données excell en mode "texte séparateur :tabulation .txt" et rajouter l'@ devant "photo" ds textedit et ça fonctionne très bien ds indesign.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 0
Adobe Community Professional ,
Jul 02, 2020

Copy link to clipboard

Copied

Hello, il y a un script de Loic Aigon qui permet de générer les chemins des images dans un fichier CSV

https://www.ozalto.com/solutions/telechargement/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2020 0