Highlighted

Problem with strange character spacing

Community Beginner ,
May 25, 2018

Copy link to clipboard

Copied

Hello,

Since a couple of weeks, InDesign started making strange bigger spaces between characters -  especially on the left side of the columns. It happened in a few exisiting independent documents, with which I had been working for a few years without any problem.

There is also a non-seen special character in the beginning of the paragraphs now, which I had never seen before - I don't know what it is, but deleting it didn't help.

I don't know how to attach a file sample (please advise, how to do it), so I'm posting an exported jpg of it:

test.jpg

If anyone can advise me, who to solve it, I would greatly appreciate it!

Thank you very much!

Adobe Community Professional
Correct answer by Chad Chelius | Adobe Community Professional

You've said previously that you're copying and pasting text from somewhere else into InDesign. It appears that there's an extra character in front of each paragraph. I did a little research and it appears to be a punctuation space. I think this is the extra space you're referring to? You can delete that space character and even to a find/replace to get rid of them. This does remove some of the space. Beyond that, you are using a first line indent on each paragraph that is applying a 4mm indent to the first line and then a 1mm indent to the remaining lines of the paragraph.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problem with strange character spacing

Community Beginner ,
May 25, 2018

Copy link to clipboard

Copied

Hello,

Since a couple of weeks, InDesign started making strange bigger spaces between characters -  especially on the left side of the columns. It happened in a few exisiting independent documents, with which I had been working for a few years without any problem.

There is also a non-seen special character in the beginning of the paragraphs now, which I had never seen before - I don't know what it is, but deleting it didn't help.

I don't know how to attach a file sample (please advise, how to do it), so I'm posting an exported jpg of it:

test.jpg

If anyone can advise me, who to solve it, I would greatly appreciate it!

Thank you very much!

Adobe Community Professional
Correct answer by Chad Chelius | Adobe Community Professional

You've said previously that you're copying and pasting text from somewhere else into InDesign. It appears that there's an extra character in front of each paragraph. I did a little research and it appears to be a punctuation space. I think this is the extra space you're referring to? You can delete that space character and even to a find/replace to get rid of them. This does remove some of the space. Beyond that, you are using a first line indent on each paragraph that is applying a 4mm indent to the first line and then a 1mm indent to the remaining lines of the paragraph.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 25, 2018 0
Adobe Community Professional ,
May 25, 2018

Copy link to clipboard

Copied

Hi JerusalemNun:

That is odd.

  1. What version of InDesign and what operating system?
  2. What font are you using?
  3. Does the spacing correct itself when you change the alignment to left, or when you use a different font?
  4. Have you tried recomposing the story? (Win: Ctrl-Alt-/; Mac: Command+Option+/)

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 1
Adobe Community Professional ,
May 25, 2018

Copy link to clipboard

Copied

It looks line a 'First Line Indent' formatting option is applied to the text.

Select some of the text and check in the ribbon (Paragraph section) if that's the case. It could be part of your Paragraph Style

Screen Shot 2018-05-25 at 16.51.02.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 1
Engaged ,
May 25, 2018

Copy link to clipboard

Copied

I don't think the indent is the issue. It's the weird spacing between the first couple of characters on the lines that follow. Interestingly, even that is not consistently wrong -- lines 2, 3, 4 and 6 look like they have extra space after the first character, but lines 5 and 7 do not. I haven't been able to replicate that here, with or without the invisible character. 

The invisible character appears to be a discretionary line break. Not sure what would have caused that to appear at the beginning of a paragraph, but I see no reason not to delete it, even if it doesn't resolve this problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 1
Adobe Community Professional ,
May 25, 2018

Copy link to clipboard

Copied

Mary,

Please answer the questions Barb posted above (reply #1). They could be helpful in diagnosing the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 2
Most Valuable Participant ,
May 25, 2018

Copy link to clipboard

Copied

Is the font you are using installed. Show us the Character Panel when the text curser is in the text.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 1
Engaged ,
May 29, 2018

Copy link to clipboard

Copied

I think you mean JerusalemNun, it's her question.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2018 0
Adobe Community Professional ,
May 25, 2018

Copy link to clipboard

Copied

JerusalemNun  wrote

I don't know how to attach a file sample (please advise, how to do it)...

Hi Jerusalem,

You can't "attach" a file sample, but you can share a file through Dropbox or another file sharing service and post a link.

~ Jane

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2018 1
Adobe Employee ,
May 29, 2018

Copy link to clipboard

Copied

Hi Jerusalem,

I would like to know if the steps suggested above worked for you, or the issue still persists.

Kindly update the discussion if you need further assistance with it.

Thanks,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 29, 2018 0
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

Hello,

I was trying to post a reply earlier, it didn't work hope it works now.

Thanks all for your feedback.

So far non of the solution seems to work.

1. What version of InDesign and what operating system?

InDesign CS 6 and Windows 10.

2. What font are you using?

I used the fonts SKSamsonPolUni_W and MgOldTimes UC Pol . All fonts are installed. Changing to other fonts didn't help.

3. Does the spacing correct itself when you change the alignment to left, or when you use a different font?

When I select a non justified alignment (right, left or center), the spaces disappear. But in any kind of justified alignment (and this is what I need), the spaces are there. If I change and change back, they reappear.

4. Have you tried recomposing the story? (Win: Ctrl-Alt-/; Mac: Command+Option+/)

I'm sorry, I don't know what "recomposing the story" means, but pressing "Ctrl-Alt-/", with the text selected or not, didn't work.

The Indent is set to 0.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
Adobe Community Professional ,
May 30, 2018

Copy link to clipboard

Copied

What's the composer you are using in paragraph formatting?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
Adobe Community Professional ,
May 30, 2018

Copy link to clipboard

Copied

Sending a DropBox or Google Drive link of the file would be most helpful.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 2
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

I'm sorry, I don't know what a composer is.

I write the text by double-clicking within a frame and then type in, or paste (in this case, without formatting).

Here's a link to the file:

text.indd - Google Drive

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
Adobe Community Professional ,
May 30, 2018

Copy link to clipboard

Copied

You've said previously that you're copying and pasting text from somewhere else into InDesign. It appears that there's an extra character in front of each paragraph. I did a little research and it appears to be a punctuation space. I think this is the extra space you're referring to? You can delete that space character and even to a find/replace to get rid of them. This does remove some of the space. Beyond that, you are using a first line indent on each paragraph that is applying a 4mm indent to the first line and then a 1mm indent to the remaining lines of the paragraph.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
Adobe Community Professional ,
May 30, 2018

Copy link to clipboard

Copied

Hi,

you are using the Global Composer that obviously has issues.

Change that to the Adobe Single Line Composer or to the Adobe Paragraph Composer. Your problems will go away.

The language formatting is Greek so you are good to go.

Compose and hyphenate text in Adobe InDesign

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

Thank you!

Now I deleted this character and it solved the issued.

It's strange, because I did the same before, and it didn't.

I wonder where it came from. The original file with this problem, is one I created a few years ago, and have been making minor text corrections a few times after, while the character suddenly appeared in almost all the paragraphs of the text!

How do I find/replace it to get rid of all of them (what to write in the "find" field) ?

Many thanks to all of you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

Thank you, I will learn to work with the other composers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
Adobe Community Professional ,
May 30, 2018

Copy link to clipboard

Copied

Here two screenshots with your test document. Note, that I did not install the needed font. Nevertheless the problem is visible and is solved after changing the composer setting in the paragraph style. From my German InDesign; hope you can follow with your version:

GlobalVsAdobeParaComposer-1.PNG

Changing the composer setting:

GlobalVsAdobeParaComposer-2.PNG

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
Adobe Community Professional ,
May 30, 2018

Copy link to clipboard

Copied

You could use ^k in the find field and leave the change to field blank. I've included a screen shot below. Uwe's right in that changing the paragraph composer from the World Ready Paragraph Composer to the Paragraph Composer also seems to remove the extra space but that character will still be there. I just don't see the value in having that character at the beginning of each line. I'm a proponent of clean text. I'd rather see you clean it up to avoid issues in the future.

2018-05-30_07-26-04.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 1
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

Thank you! I also prefer clear text!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
Community Beginner ,
May 30, 2018

Copy link to clipboard

Copied

Thank you, I followed it up, it worked!

And another file that has the same space problem actually doesn't even have the invisible space character in the beginning of it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
New Here ,
May 21, 2020

Copy link to clipboard

Copied

I have a simlilar or ven worse issue. I tried left align or left justification and it doesn't make a difference for me, InDesign still gives me odd gaps. I also chaged the different composer settings, and nothing. Any ideas? Thanks!InDes Odd gaps.png

This is driving me nuts. Any idea of what is going on? Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 21, 2020 0