Highlighted

Random hyphens appearing in text pasted from Word

Explorer ,
Nov 26, 2018

Copy link to clipboard

Copied

I've just started noticing random hyphens appearing in text I'm pasting from Word into InDesign. I'm pasting into a series of InDesign docs in a journal that get updated every year, and I've never had this happen before. I just pasted in a 900-word story, for example, and there are 12 hyphens inserted into seemingly random words with no pattern I can detect.

Hyphenation is turned off in both Word and the InDesign paragraph style, so there should be no hyphens.

They’re definitely not discretionary hyphens. I have Invisibles turned on in both Word and InDesign and everything looks completely regular. The words are all followed by a space (blue dot) and there are no special characters.

The screenshot I've attached shows the text in InDesign with the source text in Word below.

Anyone else seen this?

Weird hyphens.png

Hi Laubender. Thanks for all your investigating! I just tried to reproduce the problem so I could answer Jongware's question, but for some reason the problem is no longer happening! I'm CUTTING and pasting away, the same text into the same documents, but no hyphens are appearing, which is as much of a mystery as to why it started happening in the first place.

So I'm relieved, but also kind of annoyed?

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Random hyphens appearing in text pasted from Word

Explorer ,
Nov 26, 2018

Copy link to clipboard

Copied

I've just started noticing random hyphens appearing in text I'm pasting from Word into InDesign. I'm pasting into a series of InDesign docs in a journal that get updated every year, and I've never had this happen before. I just pasted in a 900-word story, for example, and there are 12 hyphens inserted into seemingly random words with no pattern I can detect.

Hyphenation is turned off in both Word and the InDesign paragraph style, so there should be no hyphens.

They’re definitely not discretionary hyphens. I have Invisibles turned on in both Word and InDesign and everything looks completely regular. The words are all followed by a space (blue dot) and there are no special characters.

The screenshot I've attached shows the text in InDesign with the source text in Word below.

Anyone else seen this?

Weird hyphens.png

Hi Laubender. Thanks for all your investigating! I just tried to reproduce the problem so I could answer Jongware's question, but for some reason the problem is no longer happening! I'm CUTTING and pasting away, the same text into the same documents, but no hyphens are appearing, which is as much of a mystery as to why it started happening in the first place.

So I'm relieved, but also kind of annoyed?

Views

2.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 26, 2018 0
Explorer ,
Nov 26, 2018

Copy link to clipboard

Copied

Some more examples for reference. InDesign top, Word below. Most words that end up hyphenated in InDesign do seem to be at either the start or end of a line in Word, but as you can see in the screenshot in the post above, not always.

Weird hyphens 2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 0
Enthusiast ,
Nov 26, 2018

Copy link to clipboard

Copied

Stephen

You will get better results if you place the text rather than pasting it.

Ian

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 0
Explorer ,
Nov 26, 2018

Copy link to clipboard

Copied

Thanks for your reply, Ian, but unfortunately placing the text isn't really practical in my example. If it was like a novel/essay, then sure, but in my case the InDesign docs are made up of many text frames for different profiles/stories, and I'm supplied one Word doc with text for a whole section. I'm no chance of getting each bit of text supplied as a separate Word doc, and importing all text then deleting what I don't need is not ideal.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 0
Adobe Community Professional ,
Nov 26, 2018

Copy link to clipboard

Copied

I would still flow it into InDesign by choosing File > Place. Just drop it into a frame on the pasteboard where you can make it as big as you want. Now you can just copy and paste it out of that frame and put the "chunks" of text where they belong. Or try disabling hyphenation in the Word document before copying and pasting. I'd try the place method first though. I recall running into this issue in the past with other clients. If the Word doc is hyphenating the text, the hyphens will get pasted into InDesign.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 0
Explorer ,
Nov 26, 2018

Copy link to clipboard

Copied

Thanks Chad. That would be a good workaround, yes. I think that's what I'll have to do.

Hyphenation is definitely turned off in Word, although I've just discovered something that may indicate the problem is with Word, not InDesign. See below.

Word hyphens 3.png

Hyphenation in Word set to 'None', but hyphen appearing in text nonetheless.

Word hyphens.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 0
Enthusiast ,
Nov 27, 2018

Copy link to clipboard

Copied

I bet that someone converted a PDF with hyphenation back to a word doc at some point. I have seen that happen when hyphens start appearing in random places, conversion from pdf is usually the culprit.

-Dax

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 0
Explorer ,
Nov 27, 2018

Copy link to clipboard

Copied

Hi Max. Not in my case, as the Word docs are definitely written from scratch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 1
Explorer ,
Nov 26, 2018

Copy link to clipboard

Copied

Update for those following along.

I've just discovered that the hyphens are only appearing when I CUT-and-paste into InDesign from Word. COPY-and-paste is fine.

I tend to cut-and-paste as it helps me keep track of where I'm up to in the source document. I asked a friend to try and replicate my issue on his Mac (to see if the problem was with mine), and as I watched I noticed he copy-and-pasted. He's a copier, not a cutter. I went back and tried his way on mine, and problem solved.

Still doesn't explain why it's happening in the first place, but at least there's a simple workaround.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2018 2
Adobe Community Professional ,
Nov 27, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 0
Explorer ,
Nov 27, 2018

Copy link to clipboard

Copied

Thanks Eugene. I turned that setting on, but no hyphens appeared in my Word doc. They only appear after I cut-and-paste the text, and they appear whether or not Optional Hyphens is ticked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 0
Most Valuable Participant ,
Nov 27, 2018

Copy link to clipboard

Copied

Word makes a difference between Copying and Cutting text. Marvellous.

This may have to do with how the text actually appears on the Clipboard, but then this is still a very weird discovery.

Just for clarity: in InDesign, these are the normal single dash hyphens, and show a Unicode of 0x2D in the Info Panel when selected?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 1
Adobe Community Professional ,
Nov 27, 2018

Copy link to clipboard

Copied

Hi Jongware,

yes, copy or cut makes a difference.

Just tested this with my old Word 2011 on German Windows 10 with InDesign CC 2019.

The results leave me rather confused. Set justification of the text to Fully Justified. First I applied Hyphenation "Automatic" to the text. Then I switched to "Manual" where every occassion of hyphenation can be fine-tuned:

First try:

With copy the hyphens were transferred as a HYPHEN_MINUS Unicode 002D characters.

With cut the hyphens became NOT_SIGN Unicode 00AC characters.

Then I went back some steps in my Word document to do some ordered tests. Had a problem to set hyphenation to "None". Word wouldn't like to do this so I did some undo steps to get a clean document.

Second try:
Set justification of the Word text to Left Align, applied Hyphenation "Automatic".

Result: Neither copy nor cut would transfer any hyphens to InDesign.

Third try:

Set justification of the Word text to Fully Justified, applied Hyphenation "Automatic".

Result: Neither copy nor cut would transfer any hyphens to InDesign.

No time to do further tests for now.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 3
Explorer ,
Nov 27, 2018

Copy link to clipboard

Copied

Hi Laubender. Thanks for all your investigating! I just tried to reproduce the problem so I could answer Jongware's question, but for some reason the problem is no longer happening! I'm CUTTING and pasting away, the same text into the same documents, but no hyphens are appearing, which is as much of a mystery as to why it started happening in the first place.

So I'm relieved, but also kind of annoyed?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 0
Guide ,
Nov 27, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/Stephen+Lording  wrote

I've just discovered that the hyphens are only appearing when I CUT-and-paste into InDesign from Word. COPY-and-paste is fine.

If you can't copy from a placed text file on the InDesign pasteboard and must copy directly from Word, you need to make a selection of text before you copy, and the selection should still be active after you copy. You could hit delete after the copy while the text is still selected, and that would let you keep your place the way you did with cut. But I'd probably recommend the place-and-copy method myself. Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 1
Enthusiast ,
Nov 29, 2018

Copy link to clipboard

Copied

Migintosh,

What is happening here is that he is getting random hyphen placement when he places or cut/pastes or copy/pastes. The goal is to get proper hyphenation. Weird issue for sure and bases on everyone's testing, the results seem to be random(ish).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0
bheeney2 LATEST
New Here ,
Aug 02, 2020

Copy link to clipboard

Copied

I wonder does it have anything to do with the fact that when you send a file over the internet (such as an attachment to an e-mail) the filename should be hyphenated to avoid having spaces which can cause problems. (Bearing in mind the settings and complexity of applications.) Or is there another situation where hyphenation is advisory.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 02, 2020 0
Enthusiast ,
Nov 29, 2018

Copy link to clipboard

Copied

This happens to me when copy/pasting non-English languages. I've added a step to my workflow to turn off hyphenation in word before copying/pasting into indesign. That fixes the issue for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 2
Community Beginner ,
Nov 30, 2018

Copy link to clipboard

Copied

In all the years (decades) I've been copying and pasting from Word into InDesign, I've never encountered this problem before this week. Not even all articles. What the heck? I wonder if I copy and paste into TextEdit and then into ID...nope. Still getting the hyphens. I've never placed the text...

So, this time I placed the text, cleaned up what was not supposed to be there at the beginning, and no hyphens. Ridiculous.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2018 0
Most Valuable Participant ,
Nov 30, 2018

Copy link to clipboard

Copied

So, doing it the right way, in your opinion is ridiculous?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2018 0
Community Beginner ,
Nov 30, 2018

Copy link to clipboard

Copied

In the 15 years that I've been using ID, and copying and pasting text from a Word document, I haven't had to. This time, up until I started "placing" it, I've spent the client's money figuring out what was going on. And, because the attorneys writing these articles for this hella long newsletter are getting all fancy-schmancy with their headline formatting, I can't just copy and paste the part I need anyway. I have to place and clean up. So, yeah, to have a problem all of a sudden is ridiculous. But hey, you'll be comforted to know I'm doing it "the right way" now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2018 0
Adobe Community Professional ,
Nov 30, 2018

Copy link to clipboard

Copied

Our studio works on specialty publishing where we create automated publishing workflows, or accessible PDFs, accessible EPUBs, and other cross-media items. We do print + digital.

One law we have: never ever ever copy/paste from Word without cleaning it up. It brings in a lot of Word-specific formatting/coding crud that can foul up in InDesign, or cause problems when exported to other digital formats like HTML, XML, accessible PDFs or EPUBs. (Exporting to print PDF usually doesn't experience the problems, but exporting to other digital formats does.)

In addition to the good tips folks have previously mentioned, you can also "Paste without formatting" from the Edit menu [keyboard shortcut = Control/Command + Shift + V].

I didn't get the chance to chime in earlier, but when I first read this post, my first thought was that the hyphens could be Word's discretionary hyphens put into the content by the user to control hyphenation breaks. That's the kind of Word crud we see daily coming into InDesign layouts.

All Word files are not created equal.

All Word users need a class in how to use it correctly.

And designers shouldn't allow Word crud into their InDesign layouts.

Bevi Chagnon | Designer & Technologist for Accessible InDesign + PDFs | Books @ www.PubCom.com/books — NEW! Accessible InDesign + PDF

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 30, 2018 2
Community Beginner ,
Jun 17, 2020

Copy link to clipboard

Copied

Hi! I just ran into this problem for the first time, and honestly, with certain documents, using Place isn't the "right way" at all. 

In my case, our company had co-written a piece with a third party, and the Word doc had gone back and forth maybe a dozen times between the two sets of disparate editors over the course of the writing process. The final "approved" text was sent to me to be dropped into layout and made "pretty." We typically use Place for Word documents because we have Word templates with Paragraph and Character styles in them that the editors can use, which eases the transition to InDesign. This document had (due to the back-and-forth between companies) picked up all kinds of nasty styling issues, so rather than start the design process by re-styling everything in Word, I opted to copy/paste into a plaintext editor and then drop into ID that way to kill any hidden formatting problems. 

Imagine my surprise when I discovered tons of rand-om hy-phenation in approximate-ly ha-lf of the conte-nt, when viewed in the plain-text editor. Word had hyphenation turned off.  Both copy/paste and cut/paste brought over the hidden hyphens. Turns out that some of the random paragraph styles introduced in the editing process and then manually overridden had discretionary hyphenation turned on and a non-English language set as the default. 

Just for fun, I tried bringing this in to InDesign with Place and it's a disaster (and certain of the hyphens are there, too). 

My eventual solution was to just do a find (in ID) through the entire document for any and all hyphens, and manually remove any that weren't part of a compound word or phrase.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2020 1