Recto-only text flow and verso-only text flow, in same document

Explorer ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

I need to make a bilingual book, with one language on all verso pages, and the other language on all recto.

The two languages are in separate files.

It would be enormously easier to flow text into the verso pages, and have it automatically fill the verso pages as needed, then flow the other language into the recto pages. After that I can just go back and make sure page breaks and other formatting is as appropriate for each spread.

There doesn't seem to be any way to accomplish this except by manually linking every single text frame on all 300+ pages...

Any suggestions?

Views

629

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Most Valuable Participant , May 24, 2018 May 24, 2018
Just create a facing pages master spread and put text frames on each page. Don’t thread them in master and you can place the text separately.

Likes

translate

Translate

Translate
Most Valuable Participant ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

Just create a facing pages master spread and put text frames on each page. Don’t thread them in master and you can place the text separately.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

In other words, manually link every single text frame on 300+ pages.

Unless I've misunderstood your comment somehow.

I just tried it, again, to be sure...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

No, no need to manually link your text. See my answer above.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

When you place the text on the first page, hold the shift key down and new frames will be created. The frames has to be on the master page and you have to work on the live page.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

Well, either your system is different from my system, or I'm having pretty severe comprehension issues today.

I created a new spread document, without primary master frames.

I opened the master page, created two independent text boxes, one on the left page and one on the right page.

They are not linked.

I added 300 pages to the first page, all using the same MasterA I just modified.

If I load text into the left frame on page 2, it fills the left frame, but only on that single page.

If I load text into the left frame on page 2 with the shift key down, it ignores my text box and creates a new text box filling to the margins defined in setup, and flowing onto every page normally, regardless of left or right.

So either our systems work differently (MacOS, native Japanese environment, InD.cc), somebody forgot to include a step, or I'm an idiot.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

Nope, I've tried multiple variations, and always get one of the above two results.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Hi Edward,

since you still have issues with the recommended workflow I wonder why this thread is marked as "Answered".

What could be important: What is your exact InDesign version on what operating system?

Regards,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 24, 2018 May 24, 2018

Copy link to clipboard

Copied

Using Bob's suggestion, you can even Auto-flow the text for each side of the spread. The key is to start with a blank facing-pages document. Make it longer than you think is needed, 300 pages, for example. Choose File > Place to load your text cursor with Recto text. Hold Shift and click your mouse on the first recto page (p3, e.g.) where you want your text to begin. The text will Auto-flow and add additional recto pages on the fly until done. Then do the same for the Verso text.

Problem solved.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

I didn’t (intentionally or knowingly) click Answered, and there doesn‘t seem to be any way to remove it.

In any case, MacOS 10.12.6 with the subscription to InD.cc, which it is always up to date.

The safest assumption is that I’m overlooking something, doing something silly, etc, but it ain’t working!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Hi Edward,

I first had also trouble to make it work.

My advice: Start with a fresh document with facing pages.

Make sure that it has only two pages and you are starting with page 2 so that page 2 and 3 are on one spread left and right from the spine. Do not use the Primary TextFrame option when setting up the document.

Regards,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

I first had also trouble to make it work.

Hi Uwe, Are you getting it to work in 2018? I'm getting the same behavior Edward is describing where with the shift key down the master text frame is ignored and the text flows to new text frames drawn to the margins. I was sure I had done this before so I went back to CS6 and it works there.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Have we uncovered a bug?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Well, now I have it working in 2018, at least with the document I saved out of CS6. Now I'm not sure what I did to replicate Edward's problem.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Hi Rob,

yes, it's working for me now with InDesign CC 2018.1. on Windows 10.

It did not work when I started with a three-page document where page 1 was right from spine. However it worked with a two-page document where the start page number is 2 and there are two pages on the spread.

I did not use the Primary Text Frame. instead I added one text frame each to the master pages A.

Regards,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Yup, did all that.

Several times, in fact.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

Edward, have you tried clearing your prefs?

Now I can't replicate your problem, but I was seeing and it sounds like Uwe had problems with his first try?

Here's a sequence that should work:

MP frames not threaded

Screen Shot.png

5 pages with the text flow's first page's MP frame released

Screen Shot 1.png

Click first frame's outport and Shift click inside of the next MP frame, which has not been overridden

Sel3.png

Autoflowed

Screen Shot 2.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2018 May 25, 2018

Copy link to clipboard

Copied

The set-up you show (thank you for going to all that trouble) is exactly what I've been doing.

It turns out that it only works the right way when I use Shift-Option (maybe that maps to Shift-Alt on Windows?).

But it DOES work with Shift-Option, so I guess the problem is solved!

Thank you all for your help; you've saved me quite a bit of aggravation, and with luck I'll even remember it the next time I have to do it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 28, 2018 May 28, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/Edward+Lipsett  wrote

… It turns out that it only works the right way when I use Shift-Option (maybe that maps to Shift-Alt on Windows?).

But it DOES work with Shift-Option, so I guess the problem is solved! …

Hi Edward,

that's rather strange. It's not the default how this should work. If it's doing what you want that's ok, but it will definitely not work with a different installation of InDesign CC 2018.1. I can only repeat: Usually you need just the Shift key to make it work.

Best,
Uwe

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 28, 2018 May 28, 2018

Copy link to clipboard

Copied

Well, it's a standard MacOS installation, with nothing that should interfere with keyboards or Adobe...
I suppose I could spend a week tearing it all down and rebuilding everything and possibly kill whatever is causing it, but I'd really much rather spend that week working on things I have to do.

I may end up paying for it later when the whole thing goes bonkers, but such be life.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 29, 2018 May 29, 2018

Copy link to clipboard

Copied

I may end up paying for it later when the whole thing goes bonkers, but such be life.

It is an unusual behavior—you might consider clearing your caches or resetting your prefs.

This is from Adobe's helpx page:

Screen Shot 22.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2021 Feb 20, 2021

Copy link to clipboard

Copied

Hi Edward, it´s a bit late to answer 😅, but it may be helpfull to other people.

I´m also working in a bilingual book, on a Windows computer with CC In Design (version 15.1.3). To place the original text (english) on all verso pages, and spanish on all recto, i followed the instructions as others designers suggested, but with a "twist" at the end.
On Master Pages: I created a facing-pages master spread, put text frames on each page, whitouth threading them in master.

-------

On the document:

- I created six pages (2-4-6).

- I imported the english text (CTRL+D) and pasted it on the first page WITHOUT USING AUTO-FLOWING (SHIFT+clic).
- Then, I threaded the text to the next spread (3-4) manually.

- Only there, when heading the fifth page I used the auto-flowing. I pressed Shift+clic and the text autoflowed correctly.

 

Salut!

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines